Cisco Support Community
Community Member

FTP client on Router

Hello All,

I am trying to test file transfer via ftp client on the 2811 router and 3550 switch. I am using a very small adhoc ftp server  (ftpdmin) on my laptop. However I get strange error that I am not able to find resolution. The Root Directory for FTP has read / write permissions to everyone.

Here is some capture of the ftp logs as well as router / switch command that I am trying to test:

Switch#copy run
Address or name of remote host []?
Destination filename [switch-confg]?
Writing switch-confg
%Error writing (Undefined error)

And on Laptop:

C:\>ftpdmin C:/TFTP-Root
ftpdmin v. 0.96  Jun 7 2004
Using 'C:\TFTP-Root' as root directory
ftpdmin ready to accept connections on
    220 Minftpd ready
USER anonymous
    331 pretend login accepted
    230 fake user logged in
    200 Type set to I
PORT 10,10,10,6,42,253
    200 PORT command successful
STOR switch-confg
    150 Opening BINARY mode data connection
connect() failed: No error
    550 No error

What could be wrong? There is no firewall or anything else that is blocking. I have tested both ftp passive and active on router.

Please advise as I am planning to do IOS upgrades on 2811and 1841 routers on a VPN network remotely from HQ and want to make sure that the large images get transfered soonest possible (I have to delete existing images to be able to accomodate the new image, and in absence of any image on flash, I want to make sure that new image is transfered soonest via FTP rather than using TFTP byte by byte and wait and acknowledgement protocol. I am also not sure if  tftpd32 or any other tftp server and cisco routers themselves will permit larger than 32MB images to be transfered over tftp.

Much thanks.

Community Member

Re: FTP client on Router

Good Morning Folks, Can someone look into this and advise? The adhoc ftp server that I am using works fine when I use any ftp client ( including browser) on any PC on the LAN.

Any help will be greatly appreciated.

Community Member

Re: FTP client on Router

Folks, I was able to resolve this issue.

But I find is that contrary to but I had read that default passive does not work very well, and we need to set router / switch to active mode with "no ip ftp passive", I removed that and with default passive mode, it works fine now with my little adhoc FTPDMIN written by Matthias Wandel (

I had earlier tried other ftp servers (and had tried default passive mode) and it wwas not working.

Thanks and have a great day.

CreatePlease to create content