Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to make RV082 access secure web sites in load balanced mode

I just purchased an RV082 Dual WAN gateway/router because I have both Cable and DSL feeds into my office. It all works fine until I try to access a secure web site or have a conversation through my Vonage internet phone. In failover mode it all works. As soon as I select load balancing, I have failures. I don't see this listed anywhere as a "known problem" so there must be some kind of workaround if this is not a bug. Has anyone else seen this and how have you solved thes?

thanks

Poul

^..^

3 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: How to make RV082 access secure web sites in load balanced m

The problem you are having is your doing load balance and the traffic to the secure site is going out both wan's.  The secure site is waiting for a response from the original wan ip that established the connection and then it receives the reply from the other wan ip address.  This is a common issue.  You can do protocol binding under the system management tab and have all your https traffic going out one wan ip address, this will fix this issue.

Re: How to make RV082 access secure web sites in load balanced m

I agree with David.  For a website login page that requires multiple https/tcp sessions coming from the same IP address, RV0xx load balance (round robin) for incoming TCP sessions alone wont work.   Use the Service management configuration to bind https protocol (443) to one of the WAN interfaces and see if that helps.

Re: How to make RV082 access secure web sites in load balanced m

>So I set both HTTPS port:443 and HTTPS Secondary port:8443 to WAN1 and that seems to work so far. I assume that the router will still automatically switch to WAN2 should WAN1 fail.

SR: That's correct.

5 REPLIES
Silver

Re: How to make RV082 access secure web sites in load balanced m

The problem you are having is your doing load balance and the traffic to the secure site is going out both wan's.  The secure site is waiting for a response from the original wan ip that established the connection and then it receives the reply from the other wan ip address.  This is a common issue.  You can do protocol binding under the system management tab and have all your https traffic going out one wan ip address, this will fix this issue.

Re: How to make RV082 access secure web sites in load balanced m

I agree with David.  For a website login page that requires multiple https/tcp sessions coming from the same IP address, RV0xx load balance (round robin) for incoming TCP sessions alone wont work.   Use the Service management configuration to bind https protocol (443) to one of the WAN interfaces and see if that helps.

New Member

Re: How to make RV082 access secure web sites in load balanced m

So I set both HTTPS port:443 and HTTPS Secondary port:8443 to WAN1 and that seems to work so far. I assume that the router will still automatically switch to WAN2 should WAN1 fail.

Taking your lead, to get my Vonage phone adapter unit to behave, I assigned it a static address in my network and then assigned "all traffic" at that ip address to WAN2. Once again I assume that it will failover automatically. Does this sound like the correct thing to do? It seems to work. And if you know, please comment on the failover when in load balancing mode.

thanks

Poul

^..^

Re: How to make RV082 access secure web sites in load balanced m

>So I set both HTTPS port:443 and HTTPS Secondary port:8443 to WAN1 and that seems to work so far. I assume that the router will still automatically switch to WAN2 should WAN1 fail.

SR: That's correct.

New Member

Re: How to make RV082 access secure web sites in load balanced m

Thank you all for your help. I appreciate your answers.

I want to mention something I discovered that I did not pick up from the documentation. When setting up my Vonage telephone adapter for a static IP address, I thought I had to configure the adapter as well as the RV082. It turns out that I could leave the Vonage TA in DHCP mode and still enter an IP address (on the RV082 in load balancing mode) for a given mac address. This had the effect of reserving that IP address and assigning it to the Vonage TA every time it comes on line. Then I could use that IP address to select which WAN to use and what priority or speed. Very cool...   :-)

Poul

^..^

2923
Views
0
Helpful
5
Replies