Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

IP SLA not reverting to primary

I have a C2900 router configured with dual wan:

interface GigabitEthernet0/0

interface GigabitEthernet0/1

The first connection is through optical fiber and the second one as a coax cable modem. The first interface serves as the primary connection and the second serves as a backup. The problem is that the IP SLA config detects when the primary is down, but not when it goes back up. The config is as follows:

ip sla 1

     icmp-echo 10.0.0.1 source-interface GigabitEthernet0/0

      frequency 5

ip sla schedule 1 life forever start-time now

track 1 ip sla 1 reachability

The default routes are:

ip route 0.0.0.0 0.0.0.0 10.0.0.1 track 1

ip route 0.0.0.0 0.0.0.0 11.0.0.1 10

The test is done by pulling the fiber connection out. If I restart the interface in the router it goes back online, but I want it to go automatically. Should I add something to the config, or is it a fiber issue that does not reconect automatically.

Thank you

Message was edited by: Dorian Kavaja After playing with settings, I changed the ping ip to a google ip (instead of ISP1 gateway), and modified the track to "delay up 120 down 10". But even with this config, after 120 seconds the track goes Up, and then Down again after 10 seconds. So my guess is that Interface Gi0/0 never goes up. I have to manually shut it down and bring it up again for things to work.

1 REPLY
Community Member

IP SLA not reverting to primary

Just to let anybody know, I solved it by creating an event manager applet that restarts the interface when the track is down. This way the default route goes up when the track becomes true (up).

226
Views
0
Helpful
1
Replies
CreatePlease to create content