Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Need help troubleshooting QuickVPN hang

I have QuickVPN  on XP Pro SP3 and am trying to connect to a RVS4000 using its public IP address.  QuickVPN gets to "Connecting..." and hangs.  The context menu on the systray icon won't come up, and it won't time out; eventually I have to use Task Manager to kill both wget.exe and VPNClient.exe

I have a client certificate (according to its name) installed in the software installation directory.  I have tried using auto, and both 443 and 60443 explicitly.

I sanitized some values within [] in the files below

wget_error.txt shows, e.g.:

--00:15:48--  https://[username]:*password*@[Router IP]:443/StartConnection.htm?version=1?IP=[client IP]?PASSWD=*password*?USER=[username]
           => `C:[Installation Dir]//vpnserver.conf'
Connecting to [Router IP]:443... connected.

Log.txt shows:

2010/05/05 00:41:19 [STATUS]OS Version: Windows XP
2010/05/05 00:41:19 [STATUS]Windows Firewall is OFF
2010/05/05 00:41:19 [STATUS]One network interface detected with IP address [client IP]
2010/05/05 00:41:19 [STATUS]Connecting...
2010/05/05 00:41:19 [STATUS]Connecting to remote gateway with IP address: [Router IP]
2010/05/05 00:41:19 [WARNING]Server's certificate doesn't exist on your local computer.

(I never got a popup about the certificate issue, but wouldn't know how to get it what it wants as I only have the client cert.)

I noticed that vnpserver.conf in my client directory is zero length, and found a status.conf file with this in it:

rwConnStart message=All 1 wget requests did not return a valid vpnserver.conf

At least if I give it a bogus server IP it times out and gives me a dialogue.  When I give it the actual IP it just hangs.  wget apparently connects but that's as far as it gets.

I'm not near the router and it takes a while to get information from the person who is, but this it getting frustrating and any clues would be appreciated.

Community Member

Re: Need help troubleshooting QuickVPN hang

OK no replies let's try this:

1) What would case the client to complain that it cannot ping the remote server, when I can do so manually?

2) What is the fix for the client complaining that the server certificate is not installed on the local computer, when it IS?

3)and the main problem of the hang.  I have connected to the router with a netbook running XP home SP3, though it's not adequate for the work I need to do.

My XP Pro SP3  desktop still exhibits the symptoms originally described.  My firewall appliance is being used in both cases so that can be eliminated.

The many other differences I have tried eliminating include Windows Firewall being on or off, and trying to disable every feature of Norton Internet Security that I can find, none of which worked.    (NIS about screen shows copyright thru 2009 so I assume it is version 2009)

I've seen other references to problems with NIS, but my box is not hanging at Verifying Network, it's hanging at Connecting.  However the log and wget error files indicate a connection has been made and it's decided the server certificate does not exist... but I never see the dialogue for that warning.  I can't imagine anything other than Norton that would be causing this.  Though I'd also like to know,

4) Is it true that Windows Firewall must be enabled on the client for QuickVPN to work?  If so, why??

Thanks in advance for any answers or clues to any of the above.

... and in lieu of any responses, I'll just keep adding documentation, in prep for the phone call with the support center...

put wireshark on the two boxes and compared dialogues,   On the box with the hang everything is identical until the client acks the server hello/certificate.

What does NOT happen is any communication from the client afterwards... until I eventually stop VPNClient and wget processes, at which time the reset it sent.

  On the box that works, the client follows up the server certificate ack with client key exchange, cipher spec and then on to application data.

All of this is over the TCP session already established ... so what is preventing QuickVPN on the the XP Pro box from sending the information to establighs the VPN connection?

Yeah, talked with the support center and they're blaming Norton, notwithstanding disabling Norton has no effect.  Norton is pernicious but I've seen references to people connecting despite it.  Will try a different thread and see if I can get any responses.

Community Member

Re: Need help troubleshooting QuickVPN hang

I experienced the same problem. QVPN on my Windows 7 machine worked fine one day and not the next. I discovered that uninstalling the application, including removing the profiles and certificates at the prompt, and then running the SETUP.EXE again, created a functioning QVPN.

I haven't yet determined what it is that causes it fail - after a reboot or logoff or some other issue.

CreatePlease to create content