Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NHRP on the SR520

I configured a couple of 881's via Cisco Configuration Professional. One as a DMVPN hub, and the other as a secondary hub. I then have a couple of SR520's which I want to use these two hub servers. I then used CCP to generate a list of commands to connect another unit to the DMVPN. Here is what it generated :

crypto ipsec transform-set ESP-3DES-SHA esp-sha-hmac esp-3des
mode transport
exit
crypto ipsec profile CiscoCP_Profile1
set transform-set ESP-3DES-SHA
exit
interface Tunnel0
exit
default interface Tunnel0
interface Tunnel0
bandwidth 1000
delay 1000
ip nhrp holdtime 360
ip nhrp network-id 100000
ip nhrp authentication DMVPN_NW
ip mtu 1400
no shutdown
ip address 192.168.254.3 255.255.255.0
ip tcp adjust-mss 1360
ip nhrp nhs 192.168.254.1
ip nhrp nhs 192.168.254.2
ip nhrp map 192.168.254.1 75.xxx.xxx.xxx
ip nhrp map multicast 75.xxx.xxx.xxx
ip nhrp map 192.168.254.2 70.254.254.254
ip nhrp map multicast 70.254.254.254
tunnel source FastEthernet4
tunnel protection ipsec profile CiscoCP_Profile1
tunnel key 100000
tunnel mode gre multipoint
exit
router eigrp 1
network 192.168.254.0 0.0.0.255
exit

Ok, so I understand that the SR520's don't support EIGRP, and that i would instead set static routes in place of the EIGRP setup.

However, one thing I wasn't counting on is that the 520s did not seem to support NHRP either. Is this type of setup unsupported on the SR520s, or is there something I'm doing wrong?

When i go into the tunnel 0 interface, and try to type "ip nhrp ..." those commands are unavilible.

If this sort of setup is not availible, how should I be configuring the 520s? Or do I just need a firmware update or something?

I'm running 12.4(20)T5

Thanks

2 REPLIES
Cisco Employee

Re: NHRP on the SR520

Hi,

This issue has been fixed in the later releases.  Please use 12.4(24)T3.

Regards,

Andy

New Member

Re: NHRP on the SR520

I have been waiting about 2 weeks to get my SmartNet contract processed. Isn't there a way to get a free 30 days to IOS updates or something?

671
Views
0
Helpful
2
Replies