Cisco Support Community
Community Member

RV042 DNS issues

Good day,

I've just picked up a client that has an RV042 router. The router appeared to be working without any issues since they have had it. We needed to make some changes to the router and make use of the DNS local database.

When we added entries to the DNS local database they appeared not to take affect so did the usual reboot which had not affect. I did some reading and this seemed to be a common issue and the solutions was to factory reset the device and re-add the information to the DNS local database. So we went ahead and did this, but at the same time we upgraded the firmware to the most current version v4.2.3.07

We then re-configured the router with all it's previous settings (we did not import any previous config files) and added the entries to the DNS local database. This seemed to solve the problem until another issue arose which is what I am trying to solve now. After a random period of time the router stops processing external DNS quries. I believe the issue is to do with the Use DNS Proxy option when is set under the DHCP tab. If I set this to use specific DNS servers or use the DNS servers of the ISP the issue appears not to happen. Although If I use any other setting than Use DNS Proxy then the DNS local database appears to either not respond to is being bypassed. When the issue happens there is still internet access it is just the DNS queries outside of the DNS local database that do not work.

The only way at the moment to resolve the problem is to restart the router when the issue occurs. I suspect there is a cache for the DNS proxy which is either filling up and not clearing it's self out or it stops responding for some reason. I've logged a ticket with Cisco but at the moment I'm being told i'll get an update when they have some more information which is of no use to me I need to get the problem sorted.

Has anyone got any thoughts on what might be causing this and how to resolve it. I need both functions to be working correctly DNS local database and DNS lookup. Something else I noticed when looking through the logs is that the time on the device is out so I set it to lookup using the built in timeserver settings. This took affect yesterday. Today it's dropped off again and the device has reverted to some random time so not sure if it is related in anyway.

At the moment I'm not particularly impressed with the device and if all else fails I'll have to recommend the client swap it out for some else.

Everyone's tags (1)
Community Member

Any luck solving the problem?

Any luck solving the problem? I have this issue too.

Community Member

No luck solving it. I got in

No luck solving it. I got in direct contact with Cisco and raised a support ticket. They asked me to a bunch of testing using wireshark and such, but I simply did not have the time to do this and it was not practical for me to sit at a client all day waiting for the fault to happen so I could run the tests they were after.

It's not a workstation issue as they thought it might be it's a bug in the firmware. I gave up in the end and swapped the Cisco out for a dratyek which does the same and more with better support.

To be fair to Cisco I did not carry out any of the tests they asked for so can't really fault them for trying to help and not being able to solve the problem. On the other hand compared to draytek for instance that I can just call and get support over the phone regardless of product being in or out of warranty the service is not that great.

(as a note dratek charge premium rate for their phone service, but considering I raraly spend more than 4 min on the phone with them the cost of the call is nothing compared to how much I am loosing in time on an issue).

Community Member

Hi everybody, exactly the

Hi everybody, exactly the same issue here RV042 (v4.2.3.07)

I definitely need a DNS to solve LAN server/workstation traffic and, at the same time, relay DNS traffic to the outside for Internet. 

Did anyone try another router that works? Any recommendation?


Community Member

Nope, no resolution. May

Nope, no resolution. May replace them soon.

Community Member

This has been an intermittent

This has been an intermittent problem for me for over a year on rv042g, currently running v4.2.3.07.  I saw other posts where folks snooped packets and confirmed that port 53 stopped responding, so seems like DNS process in unit may be crashing.

I need the DNS local database, so I can't get away from "Use DNS Proxy".

I have some evidence that the problem is related to DNS traffic, as this problem manifests more frequently when we are running a phone bank which involves more network connections and more DNS traffic.

I have also noticed that the problem can be cleared without rebooting by toggling dual stack operation.  This definitely clears out the DHCP client table, and it seems to restart the DNS process as well.

Community Member

I have this issue in the new

I have this issue in the new RV042G to replace a working RV042.

Does not propagate the DNS

Was working fine in the old router, which was at a different F/W version.

Community Member

This problem is solved on the

This problem is solved on the another side.

You must check stable AC power to the RV042 power supply.

In my building an unstable voltage - 200-212V and a have the same situation. 

After I connect RV042 via UPS - everything is fine!

(sorry for my terrible english)

Community Member

Re: RV042 DNS issues

I have figured this problem out, finally!

On the Setup | Network top section enter a "Domain Name" that matches the workgroup name for the computers on the network. On the Setup | Network | WAN Setting | Configuration (whatever interface your are configuring), let everything be dynamically assigned or enter in the information you wish to use. Remember one of the DNS entries from the setup for use in the next step.

Go to the DHCP | DHCP Setup | DNS section and enter in the "Static DNS 1" server IP as the IP of your RV042 (being used as a Gateway). This will allow the RV042 to dynamically assign the DNS to your DHCP clients that includes itself for lookup. Enter the DNS number remembered from the last step for the "Static DNS 2" server IP. Under DHCP | DHCP Setup | DNS Local Database enter your DNS entries for the static IPs you have set; single word. "Add to list" for each entry, and Save.

Go to System Management | Restart <-- Restart the RV042-->Give a few minutes for things to propagate.

For local network connections, typing the single DNS term into a browser should now resolve to the stored IP for the device. For PPTP VPN connections to resolve you must place the "Domain Name" used in step 1 behind the single-term DNS name you entered for the device; for example, device.domain

Another way to configure this, I have my PPTP VPN connection setup to automatically ad the "Domain Name". In Windows, this setting is in the Advanced TCP/IP Settings for the IPv4 connection. Add the "Domain Name" to the "DNS suffix for this connection:" section. This is working for me. I hope you have the same experience.

Alan Shields Jr


RV042 V03 : Firmware Version : v4.2.3.07

As Gateway/DHCP server

Non Active Directory network used, workgroup names for the PCs are used and configured to match, and to match the "Domain Name" from the first step.

CreatePlease to create content