Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RV042 - Time is not being set automatically using NTP

I have 4 RV042 routers with the latest firmware.  I cannot get the router to set its time automatically.  On the Setup->Time page I have a bullet next to "Set the local time using .. (NTP) automatically".  Time Zone is set to GMT-05:00 (Eastern).  I do have a checkmark next to Daylight Saving and have defined the from and to date range.  The default factory setting has "Set using NTP automatically" and a blank value for NTP Server.  The docs do not state if you have to type in your own NTP server.  Since the date was showing as 2002, I assumed it did not like a blank NTP server.  So, why do they make that the default?  And, if a value is required, why not warn the user when you click on Save Setting button?

Assuming it needed a value entered for NTP Server, I typed in - which works just fine on my Windows 2003 server.  Yet the time still remains stuck in 2002...

I also wondered whether NTP queries should appear in the system log (or on my SYSLOG server).  So far I do not see any hint of an NTP query occurring.

Any ideas?




Re: RV042 - Time is not being set automatically using NTP

Gidday Mike,

Try changing the NTP server to just

let me know how it goes

regards Dave

New Member

Re: RV042 - Time is not being set automatically using NTP

Hi Dave,

I tried a different NTP server, and still the time did not change (tried it on mutiple RV042 units too and none worked properly).  I started using RV042s back in 2007 and found them so buggy that Cisco swapped them all out for me (to RVL200 units)  a year later in 2008.  Recently Cisco swapped all the RVL200s and an RVS4000 back to RV042s because these models had bugs related to VPN connections.  I'm playing merry-go-round with routers, trying to find the least buggy ones...

The RV042's current firmware is certainly better than in 07, but seems to still have bugs.  You'd think 3 years would be enough time to debug these things, but I guess not :(

Oh well, I'll just set the time manually and hope the VPN connections work better than in past releases...

Oh, as an IT person I got to say I am amazed the routers have to be updated each year as to the Daylight Savings month and day settings.  Are we really supposed to remote into hundreds of routers and manually adjust them each year?  Come on Cisco, hire some better programmers!



New Member

Re: RV042 - Time is not being set automatically using NTP


We have 3 RV042's, all with the latest firmware and they too will not automatically set the time using the NTP option.  I have done an Internet search and this seems to be a common ailment with the RV042's over a number of different firmware versions.

In my case I am trying to get them to sync with an internal Windows 2003 Server which has been set up as an NTP server.  I have confirmed that the NTP service is operating correctly by using an NTP client application on another computer to get the time from the W2k3 Server.  I cannot use an external time reference such as as our corporate firewall blocks such requests from going out.

Reluctantly, I decided to use the set time manually option but have found that after only 3 weeks the time has drifted by more than 2 minutes - unacceptable for my application.  I am now stuck with having to make the NTP option work.

Has anyone found a solution to this problem and, if so, what is it?

If not, can someone from Cisco please comment whether or not this problem is being addressed in a new firmware release and when we can expect it.



New Member

Re: RV042 - Time is not being set automatically using NTP


Go head an add your local server providing NTP back to routers and add the rule in firewall allowing NTP traffic to server via  any any.

New Member

Re: RV042 Time - Some Progress

Since my initial post I have done a lot more testing and searching and have found:

1. I can get the RV042 to sync its time properly if I run Dillobits Software's SNTP Service application on my laptop and point the RV042 to use that as the time reference - works perfectly every time.

2. It does not matter if my laptop (running SNTP Service) is on a WAN port or the LAN port - so long as the RV042 has the IP address of the laptop it will find the time service  (I had a thought the problem may have been the RV042 was expecting to find the time service on a WAN port, not internally on the network)

3. I have checked and double checked all the registry settings on the W2k3 Server and I'm abolutely confident they are correctly set for it to provide a reliable NTP time service

4. I have found quite a number of posts on various forums regarding people having problems getting Cisco products to sync time with W2k3 Server.  From memory, these were all Cisco products running IOS and (also from memory) the ones I read were all resvolved, usually by tidying up some settings in one or the other of the products.  I have not found any solution for Linksys products and W2k3 Server.

5. At least a couple of people have had their problem resolved by changing the value of the Windows Time Service registry key LocalClockDispersion to 0.  I have tried this, along with using other values small and large but without success.

6. SNTP and NTP packets are identical - the difference between the two protocols being how much work the application using the time information does to process the data (eg: the amount and complexity of statistical processing done to determine the time accurately and the method of adjusting the clock)

The conclusion I have come to is that while the RV042 should happily sync to the W2k3 Server, there is something within the time packet sent by the W2k3 Server time service that the RV042 objects to (ie: it doesn't consider it to be a reliable time source or something) and therefore rejects it.

With that, I have exhausted every path I have found that may offer a solution so unless someone else can get to the bottom of this I will purchase Dillobits Software's SNTP Service and run that on the W2k3 Server.



New Member

RV042 - Time is not being set automatically using NTP

I was having this same exact problem and had the same levels of success/non-success as you.

My latest resolution was to use the IP address returned when I pinged (my was, ymmv) instead of using the DNS name of the pool. I  believe the RV042 isn't resolving the DNS names properly.Doesn't seem to matter what version IOS or hardware version to me. Simply by going to the IP address bypasses this problem.

Now of course if the server thats responding to the ping is removed from the pool, then you'll have to re-ping the latest pool response and change your IP accordingly.


CreatePlease to create content