Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RV042 VPN and iPad

Does someone have a working configuration to connect the iPad VPN-client (IPSEC) to the RV042?

Everyone's tags (3)
18 REPLIES
New Member

Re: RV042 VPN and iPad

I'd really love an answer to this also. Anybody got anything? or

maybe even the Cisco AnyConnect app?

New Member

Re: RV042 VPN and iPad

Hi Beowulf,

Someone on the Apple support boards was having a similar problem. This is the solution they came up with:

The key piece of software is a program called IPSecuritas from www.lobotomo.com. This has the same function as VPN Client, but includes a lot more options and settings.

IPSecuritas client settings are as follows:

General:
Mode of operation: Host to Network
Remote IPSec Device: router.company.com (note, this gives the "external" WAN IP address of my router, as hosted by DynDNS)
Remote Network: 192.168.2.0/24 (this is the numbering system of the LAN behind my RV042)
Local address: (Blank)
Exchange mode: Aggressive
Proposal check: Strict

Phase 1: 28800 sec, Mod 768 (1), DES, MD5

Phase 2: 28800 sec, Mod 768 (1), DES, HMAC MD5

ID/Auth:
Local Identifier: DN, user@company.com (I don't think this needs to be a valid e-mail address as long as it is the same on both devices)
Remote Identifier: (same)
Preshared secret:  (choose any password)
Options: IpSec DOI, SIT_IDENTITY_ONLY, MIP6, Initial Contact, DHCP Pass-through, Establish IKE Immediately, Auto Start are all checked.

Also, on the IPSecuritas Preferences menu, I have checked 'Replace DNS Settings on IPSec Activation' with our domain name and the internal IP address of our DNS, 192.168.2.134.

On my RV042 router, I have Tunnel 1 enabled as a Client to Gateway on WAN1. (This is with the latest firmware from July 2005, ver. 1.3.7.2)

Local Security Gateway Type is Dynamic IP + E-mail Addr. (USER FQDN) Authentication.

Email address: user @ company.com, matching the IPSecuritas setup on the Powerbook.

Local security type also matches the client settings: Subnet; 192.168.2.0; 255.255.255.0

Remote client is also Gateway Type Dynamic IP + E-mail Addr. (USER FQDN) Authentication and the same user@company.com.

Keying mode IKE with Preshared key.
Phase 1 DH Group: Group1, encryption DES, Authentication MD5, SA Lifetime 28800sec.  Perfect Forward Security-yes.

Phase 2: Group1, DES, MD5, 28800 sec.

Preshared Key: (your passsword, same as you chose in IPSecuritas)

Advanced: Aggressive mode is enabled and locked.  Dead Peer Detection 10 sec.  All else un-checked.

VPN Pass Through: All enabled.

VPN Client Access: Don't waste time with this; it is for the Linksys QuickVPN utility from Windows only.

This is working great. I have access to my whole internal subnet, all ports, with functioning internal DNS even though I didn't put it in Network configuration for my "Traveling" location on the PowerBook.

One thing I should note, after you set all your preferences and hit the Start IPSec button in IPSecuritas, it takes ten or fifteen seconds for the green check mark to replace the red X. Be patient. Check the System log and the IPSecuritas log to see if things are happening.

I assume this will also work for the other Linksys products in this line, the RV0041, RV082 and RV016.

I hope that helps!

Yours,

TST

New Member

Re: RV042 VPN and iPad

Great Info!! but it doesn't apply to the iPad connecting to a RV042.

New Member

Re: RV042 VPN and iPad

not yet, but if the router firmware is prior to 4.0.x,

then you can connect via the PPTP server

New Member

RV042 VPN and iPad

I'd like to know if that's possible as well, anybody??

RV042 VPN and iPad

The latest RV042 firmware supports PPTP Server, which works with the PPTP Client on iOS.

New Member

RV042 VPN and iPad

is there a tech note that walks us noob's through the setup of the RV042?

RV042 VPN and iPad

The config steps on the RV042 side are:

1) Enable PPTP Server in VPN>PPTP Server.

2) Add username and password for each PPTP user.

3) Save the configuration and that's it.

New Member

Re: RV042 VPN and iPad

does

not

work.

Consistent failure with every conceivable permutation. 

The iPwn will act like it is connecting.. then "VPN Connection   A connection could not be established to the PPP server...."

Ironically, the IPSec tab in the iPwn has a *Cisco logo*!!!  But the "Cisco" RV042 doesn't seem to support IPSec!

Re: RV042 VPN and iPad

The release note of firmware 4.0.3.03-tm has the following issue included in the list of issues fixed.

PPTP clients on iPhone/iPad/Mac cannot connect to the PPTP Server on RV0xx V3.

Below are the settings that are supported for iOS 4.3.1:

RSA SecurID—Off

Encryption level—Auto

Send all traffic—On

Proxy setting—Off

New Member

Re: RV042 VPN and iPad

thanks tekliu!

I updated my router to the latest firmware, now it works.

but I'm running into another problem,

I can connect to the VPN just fine over 3G, however when I try to access it from my home network it gives me an error that the PPP server isn't responding, my Mac Pro on the same network connects to the VPN just fine.

any idea's?

thanks in advance.

Re: RV042 VPN and iPad

What iOS version do you have on your iPad? What home firewall/router are you using?

You might want to give the Support Center a call to troubleshoot the issue.

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

New Member

Re: RV042 VPN and iPad

I've got iOS 5.0.1 on the iPad.

I'm using a Netgear DSL Modem (DG834G) and a Meraki Cloud Controlled MR58 connected to the DSL Modem.

I'm assuming it has something to do with the iPad since a Mac Pro connects to the VPN just fine and the iPad get a "A connection could not be established to the PPP server" error.

New Member

RV042 VPN and iPad

Well, it appears that the Cisco RV042 does NOT SUPPORT the *Cisco branded* IPSec VPN that iOS offers.  What???

The latest firmware (which removes telnet access that would have supposedly allowed us to enable IPSec) to the RV042, does at least enable the horribly buggy and insecure PPTP, but why would we want to keep using such a security risk?  Only a fool would run WEP or PPTP!  Any dedicated middle-school kid would have your entire network cracked during lunch.

Cisco, wherefore hast thou forsaken us?!?  This is incredibly frustrating.

Please correct me if by some miracle I am wrong, but I've beaten my head against the wall for weeks over this, and PPTP is the *only* VPN service I can get running on the RV042.

New Member

RV042 VPN and iPad

try IPSecuritas, it seems to work

http://www.lobotomo.com/products/IPSecuritas/

New Member

RV042 VPN and iPad

Please someone...anyone?  Has anyone gotten the ipad/ipsec/rv042 combo to work?  I've got the lastest rv042 firmware & ipad iOS, certificate installed.  Anybody? 

New Member

RV042 VPN and iPad

I have the same problem.

RV042 (latest firmware v4.2.1.02 (Jan 18 2012 14:10:55)) with fixed Public IP on WAN

Active PPTP server, username and password.

From windows PC I can connect,

From Iphone 4 ( IOs 6.0.1) I can not not work PPTP Client,

Someone found a solution?

thanks

New Member

RV042 VPN and iPad

Well I have several RV042 V03, with firmware v4.2.1.02 (Jan 18, 2012 14:10:55)

I finally managed to connect by PPTP on Iphone 4 and Ipad both iOS see 6.1.3 (10B329).

The settings in the iOS worked well:

Description (Name VPN)

Server: (IP or Domain of CISCO RV042)

Account: (User PPT created in RV042)

RSA SecurID: Off

Password: (password of the user created in RV042 PPT)

Encryption: Automatic

Send all traffic: Enabled

Works on both 3G Wifi like the only thing is already obsolete and insecure VPN.

I managed to set it up with iOS native IPSec and / or the CISCO VPN application that is available in App Store called Cisco "AnyConnect".

I have read forums related to the topic but none have found any clear answer from any user or by CISCO.

If someone could or know how, help is appreciated.

regards

17369
Views
34
Helpful
18
Replies