Cisco Support Community

Rv042 with Dyndns

I have Newly buy cisco Rv042 but VPN router Failed to update the dyndns and give this error


Dyndns Enabled : Dynamic DNS function is disabled or No Internet connection


I am confused about wan1 the internet port in VPN router is to make it PPOE or Static in different range m relay my ADSLmodem is in the range ,


what I understand that the Cisco Rv042 is not reaching internet so it can't update the Dyndns , so what is the required action due to make the Rv042 reach internet ,


My connection is


the internet port connected to adsl modem


and the lan1 connected also to the adsl modem


please advice in this case


any one please ??

any one please ??

Community Member

Good Afternoon,I would

Good Afternoon,

I would recommend restarting the router (or resetting if that does not work), and trying to reconfigure the DDNS setup. 

Refer to this article for information about how to do this:

Please contact me if you have any more questions, or if this did not solve your problem.




Hi Engelsamoly , My name is

Hi Engelsamoly ,


My name is Mehdi from Cisco Technical Support.


Regarding the Dyndns it will not updating if we have issue the wan which normal.


can you please share with us more information regarding the Modem connected to the WAN interface of RV042 , it is in Bridge mode ? or Gateway mode ?


it means the public IP address is on RV042 or on the modem ?


if the Public IP is on the modem so the WAN interface of RV042 with private IP and make sure is different network than the LAN of RV042


also I want to confirm from your note you have connect the internet port to the modem and from the modem (Lan port) to WAN of RV042 ?


Please share with us the topology


i have solved this problem by

i have solved this problem by setting the ADSL modem to be only Bridge , then RV042 has retrieve the public ip from ISP and the issue was been fixed

CreatePlease to create content