Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

RV042G Log Email and other issues

The RV042G manual said to use this site for support so here goes.  After owning and operating the RV082 for many years, I recently upgraded to the RV042G V01.  Overall the RV042G hardware appears to function pretty good.  The RV042G has faster throughput, but it is slightly slower in command/control response and boot than the RV082.  I have now owned the RV042G about two days and have found a number of issues.  Specifically, emailing logs doesn't work. 

- Emailing logs does not work.  RV042G does not appear to handle any type of connection authentication, it does not have a place for the senders user name or password.  I have tried SMTP servers that require no authentication and ones that do, none of them work.  RV082 worked fine with the Time Warner Cable (TWC) SMTP server, RV042G does not.  Additionally, there is NO output in the logs to show a failure.  So TWO bugs here.  I have checked settings to ensure no blocking rules, have rebooted, and even did a factory default with no luck and absolutely no mention in the logs anywhere of failure to send.

Email is my primary issue, any suggestions on getting this working would be appreciated.  I've also identified a number of other issues as well and included them here to avoid multiple posts.  These are:

- Port 0 apparently responds to interrogation and shows CLOSED (not STEALTH per grc.com).  This was NOT the case for the RV082 and is a potential security vulnerability as it cannot be redirected.

- Port 1 is CLOSED and apparently responds to interrogation.  This was NOT the case for the RV082.  Normally I would be good on the RV082.  I could redirect any OPEN or CLOSED ports to the bit bucket (192.168.1.254 for instance).  BUT, the RV042G Port Forwarding is NOT sending things to the bit bucket and instead decides to OVERRIDE the forwarding and respond to queries.  So there are TWO bugs here.  This is a potential security vulnerability.

- The ALL Logs tab shows nothing, but sub tabs do until AFTER you hit the clear button, then it works as expected. This happens every time you open the logs.  Another poster identified this problem so this is confirmation of that issue.  Also, once the dialog box for the log has closed, it will not open again until leaving the page and returning. 

- Authentication failures will show up in the System Log but not in the Access Log?

- HTTPS html interface works fine in Firefox.  However, turn it off and use just HTTP and there is a problem.  Can't see the forms and buttons, can only see the background image.  This isn't as much of a problem as I can just use HTTPS, however, with the RV082 when HTTPS was activated it would open the remote management portal regardless of whether the button was clicked or not. So really a non-issue but a bug none the less.

- RV082 could send 500 log events, RV042 can only send 100. Again, not a bug but a reduction in capability over the older RV082.

One last thing, your hardware version control numbers and firmware download page are confusing for the RV042G V01.  Found this when I checked if there was a newer version of the firmware than what the RV042G shipped with.  Here is what the firmware update page shows:

  "Cisco RV042G Dual Gigabit WAN VPN Router"

     "Firmware Release 4.2.1.02 - RV042, RV082, RV016 firmware 4.2.1.02-tm (V3 hardware required)". 

The problem is that you reset the hardware version in the RV042G (V01).  Just seems probable that someone will download the firmware for the RV042 V01 and try to put it on the RV042G V01. 

I like the RV042G overall and will wait for updates for these issues (email logs would be nice sooner rather than later as this is an advertised feature).  The RV082 was a great router for a long time ONCE most of the bugs were fixed, hoping the RV042G will be the same.

Everyone's tags (6)
5 REPLIES
New Member

Re: RV042G Log Email and other issues

Guess I spoke too soon.  If Remote Management = Disable and HTTPS = Enable, it will OPEN external access to port 443.  So have to use an access rule to kill it off.  Can STEALTH Port 1 as well with an access rule but have to block all traffic there.  Cannot block Port 0 (make it STEALTH) with an access rule and this needs to be fixed in firmware.

So port forwarding does work but not when sent to the bit bucket, have to use an Access Rule instead.  (You can see this by doing the following: turn off HTTPS and remote management and look at port 443 from the outside of the firewall.  No response at all.  Now enable HTTPS and keep Remote Management disabled and forward port 443 to an unused internal IP address.  The port still shows up as OPEN but won't connect.  Again, the RV082 did not exhibit this behavoir and would simply not provide any response to an external query if forwarded to an unused internal IP address.)

For clarity, I have the RV042G V01 with Firmware Version :   v4.2.1.02 (Jan 18 2012 14:10:55). 

New Member

RV042G Log Email and other issues

frobozzle,

I just wanted to confirm your results.  Thanks for the tip on using an access rule to stealth port 1.  I too noticed that forwarding was not working with either port 0 or 1.  It works fine with 443.

I upgraded from a v2 RV042 to the RV042G and another difference I am noting is some serious Log page issues.  I have had the router lock up on me multiple times when adjusting the Log page settings, after which I could not longer access the web admin page until I power cycled the router (while the admin page was locked up, the router continued to otherwise function normally).  The other Log page issue is that, the logs that are emailed out are missing a lot of information compared to what the older RV042 would send out, or even just comparing the email to the various Log pages in the web admin page.

New Member

RV042G Log Email and other issues

Hello Frobozzle,

just like Tim I confirm your results and I want to add another one,

In the cause of a week or so (give or take), the VPN connection gets lost and won't come back.

I also can not login with HTTPS, the browser is waiting in perpetuity for an answer from the router. Only after a reset everythings seems to work normaly again.

New Member

I bought the RV042G recently

I bought the RV042G recently and uploaded the most recent firmware v4.2.3.03 (Mar 19 2014 19:59:48). This is two years later and email is still not working. That's not good.
New Member

I did some additional testing

I did some additional testing this week on the above mentioned issues with the log and I'm also finding the same thing as frobozzle. I have not once seen an output or input log. In this release of the firmware, clearing the log does not appear to make the logs work. The system log is the only tab that works. I set up a VPN which seemed to do something to the firewall as many of my ports became open. I found attempts where people in Montreal were trying to figure out my user id and passwords to my asterisk server. They aren't supposed to even see my ports! Once I removed the vpn the firewall started behaving properly again. This is a huge security risk. What's going on Cisco? The RV042G has been out for 2 years. $200 is not a cheap router. It should be working better than this. Please get your act together!
2734
Views
0
Helpful
5
Replies
CreatePlease to create content