Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

RV220W with multiple Public IPs to single private

Hello everyone,

I am setting up a RV220W a client bought and have run into some issues.   They have Comcast Business with the SMC  8014 and a static IP block of 75.xxx.xxx.254/29.  Here is the layout:

75.xxx.xxx.254 - SMC

75.xxx.xxx.253 - Static IP on the WAN of the RV220W

75.xxx.xxx.249 - Configured on NIC of internal server (Private address of 10.1.10.17)

75.xxx.xxx.250 - Same as .249

75.xxx.xxx.251 - Same as .249

75.xxx.xxx.252 - Same as .249

10.1.10.17 is running II6 with 4 websites, each relating to .249 .250, .251 and .253. 

After getting the RV setup (prior to any ACL rules or NAT), I was able to get out to the internet via all devices on the network including 10.1.10.17.   I setup a One to One NAT with the private IP of 10.1.10.17 and the public IP of 75.xxx.xxx.249 with a range lenght of 4 and a default service of HTTP.  I then setup another ACL for HTTPS for inbound WAN to LAN to 10.1.10.17.

I tested the ports were open by telnet but the sites would not load.  I would get HTTP Bad Header pages when accessing the sites.  I went into IIS and added Header information to each site and then started to recieve Bad Gateway errors.

For troubleshooting, I disabled all the sites except the one residing on .250.  I modified the One to One NAT to be private 10.1.10.17 with a public of 75.xxx.xxx.250 and lenght of 1. 

I still got the same errors until I modified the IIS site and selected All Unassigned IPs after which time, the site loaded correctly.

What is comes down to, there is a single server, hosting 4 sites that are each tied to a public IP.  If IIS is configured to use the public IP, the sites do no work.

Do I need to dig around in IIS more or is there some sort of limitation/mis-configuration I am missing on the RV?

Thank you for any help!

1 REPLY
New Member

RV220W with multiple Public IPs to single private

Hi Brian, thank you for using our forum, my name is Luis I am part of the Small business Support community. What happen when you try to reach one of these web sites? Did you create ACL in order to gain access to these Web sites? In this case I think that will help you in order to gain access to them.

I hope you find this answer useful

Greetings,

Luis Arias.

Cisco Network Support Engineer.

307
Views
0
Helpful
1
Replies