Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RV320 Bug - Service Management Table (Port Forwarding)

I'm unable to add more than 16 entries for port forwarding.

It's a RV320 on v1.1.1.06 (newest to date) and it doesn't accept more than 16 entries in the "Service Management Table" required for port forwarding. As soon as I try to enter number 17 and hit save the window closes like it always does but you can see for a short time it says "Critical failure. Please contact support." Everything else works, except for the entry in the Service Management Table. I'm also unable to use it in the port forwarding section, it just doesn't save the entry. I'm unable to add any services to the list unless I delete others but it only works again until number 16.

Actually the "limit" is 37 because it comes with 21 services entered out of the box.

I couldn't find any bug reporting website that I could use without a contract. So I seek for help here.
Anybody else having this issue or is it just my device?

Everyone's tags (1)
24 REPLIES

Hi Pandabrain,  Please call

Hi Pandabrain, 

 

Please call the technical support line and open a ticket regarding this issue, here is the contact details : 

http://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html

 

Thanks

Mehdi

New Member

@mboukraa thanks for the fast

@mboukraa thanks for the fast reply and the usefull link.

I just used the chat support 5 minutes ago. The employee was very eager to help me and to find a solution asap. Since I don't need that many ports redirected at the same time right now, my workaround is to delete and re enter the needed services. I got a support ticket though.

So they are aware of the issue and need some time. He was talking about a few days to be able to look into that and to provide me with more information about what to do.

I'll keep you updated.

New Member

Good.!  Thanks for keep

Good.!  Thanks for keep updated the post.

New Member

Hi Pandabrain,I have exactly

Hi Pandabrain,

I have exactly the same problem with the same equipment with the same firmware. My service table is 37 rules too.

You are not the only one :)

if you found the solution, please share. i can not found yet.

Regards

 

New Member

Short Update, I got an email

Short Update, I got an email about an hour ago:

"This is regarding the -ticketnr- .RV320:Critical failure error while adding more than 17 entries on service.

We are still investigating on this issue. I will get back to you in a day’s time.

Thanks for your patience."

New Member

Hey, I have this bug too, but

Hey, 

I have this bug too, but in my case I have the RV325. I suppose its pratically the same software,

In my case its not just a limit of entries. I cannot actually delete existing entries to insert new ones.

I have the latest firmware 1.1.1.06.

Do you have any news? Does Cisco really needs a month to answer ? ....

Thank you,

A.Santos

New Member

Same problem here except i

Same problem here except i need more than 37 entrys.... is there any way round it?? need to get this forwarding working as have 2 new servers to forward ports for...

 

Cheers
Daz

New Member

ok have found another way,

ok have found another way, using port translation you can add a couple extras, still need this bug fixed though! (also generally the firmware on this needs work...)

New Member

Is there any update to this

Is there any update to this issue? Starting setting up a brand new RV320 yesterday and hit this bug, I need to get it rolled out into a live environment ASAP but this is a show stopper as I need to configure more than 16 extra service management rules in order to allow all required services for the company network. Hit the 16 limit and seeing the same issues as reported here already, cannot edit/delete/add services once 16 had been added.

New Member

that last firmware is old now

that last firmware is old now, im guessing that although this router is still on sale they are no longer fixing it....

 

very sad.. personally I would move over to draytek, (which i will have to do soon as this problem is causing us issues) 

 

Cheers

Daz

New Member

10 days ago a post was made

10 days ago a post was made in https://supportforums.cisco.com/discussion/12353771/cannot-manage-service-list-all-waited-unacceptably-long-fix  indicating there is a new firmware in beta test, I've contacted support to try to get a copy.

 

I'm moving off Draytek, have a 2830 with latest firmware and various weird issues that they've confirmed are bugs but cannot provide a due date for fix. DHCP randomly giving out wrong DNS server addresses, tagged VLAN support flaky and giving out DHCP details from wrong VLAN (worked around using 1 cable from switch per VLAN and using port based VLAN rather than tagged), App Enforcement for IM blocking causing SMTP and Live.com login issues. And that's just what cropped up last week with the unit at work here. Still using it for our live router as we can't put the RV320 in place until we can configure all the required ACLs which needs more than 16 service entries.

New Member

well that is promising! will

well that is promising! will have to see what they come back with, i had almost given up hope!

 

as for draytek that is a little unusual normally they are great, (I have one at home and a 2920 next to me here, only replaced it as it did not have enough throughput for our twin FTTP lines, 220mb on each!)

 

Cheers
Daz 

New Member

The throughput was one of my

The throughput was one of my worries too, we've got 75Mbps right now so the 90Mbps throughput of the 2830 is high enough, but there's a good chance we'll be on 150Mbps next year so would be held back by the 2830.

 

Prior to the latest firmware on the 2830 we had issues with the public DNS servers being given out to VPN users which meant they couldn't connect to anything inside the LAN by hostname, it was strange as it wouldn't do it all the time. After upgrading to the latest firmware we had the other issues, but at least two of them we could workaround and the other (random DHCP DNS set to wrong addresses) is solved by renewing the DHCP lease.

Hi, For RV320 - you need to

Hi,

 

For RV320 - you need to use IE and to have Compatibility view enabled in order to create more rows for Services. Also worth trying changing the view from 50 rows on a page (the default one) to 25, jump on page 2 and try adding 17th and so one services.

New Member

Hi , Changing it to view

Hi ,

 

Changing it to view fewer rows on a single page works - at least I now have managed to add a 17th entry. Didn't need compatibility mode. This is still a bug though, as it indicates an inability to deal with a fairly small number of form items in the code on the unit processing the data. Pretty sloppy not to have tested it with more than 16 rows worth of fields in the form.

 

I'd already opened a ticket with support, I sent a copy of my config and it has been passed it up to next level support for investigation, so it looks like they're still taking it as a bug and another Cisco employee had already posted that there was a firmware that fixes this in beta test.

 

If the SSL VPN ActiveX issues can be sorted out, most (if not all) of which require just a change to the user agent checks to deal with the changes in IE10/11, and replacing the controls with ones that don't have an expired certificate, I might be able to roll this RV320 out into production.

 

Dan

New Member

Given the reply I've had from

Given the reply I've had from Cisco support regarding the SSL VPN issue it looks like I'll be returning the RV320 for a refund and probably looking at a Netgear router instead. This is a copy from the email I received:

 

"Engineering has no plans to support SSL VPN on RV32x due to chipset limitations. Pretty much, it will work for old XP and Win7 32-bits."

 

So Cisco are falsely advertising that the RV320 has SSL VPN capabilities when there are no plans to update it so that it works with 64-bit Windows (which is now the major install base for Windows as most new systems are 64-bit based), and as the certificates have expired in the SSL VPN components they are not even useable on 32-bit systems without overriding a number of security settings.

 

Clearly Cisco are not the company they once were.

 

Dan

New Member

The RV320 has turned out to

The RV320 has turned out to be a sour lemon - the worst router I have ever owned.

And now they're downright saying they won't fix an advertised, but broken, feature? That's not even just bad customer service. That's borderline fraud.

Unfortunately, mine is a bit old now, as I was naive enough to wait for bugs to be fixed. Pretty much none of the selling points works as advertised :(.

New Member

I've had another reply from

I've had another reply from Cisco support overnight in response to a post I sent telling how to fix the SSL issue (change the user agent check for IE, replace the ActiveX controls), and the reply I got was unexpected but somewhat encouraging:

 

"Engineering have decided to add SSL VPN for RV320 in the roadmap for next MR (MR3) - tentatively scheduled for April. Thanks for your patience and cooperation."

 

I won't hold my breath, but it if they do fix this then there might be hope yet.

 

Dan

New Member

Well my previous reply was

Well my previous reply was premature, changing the number of rows did allow me to add another service but today when  I needed to add another it's not possible to change the number of rows - changing the value in the drop down menu results in the "Critical failure" message from the router operating system. Have tried every combination of compatibility mode and document rendering versions in IE11 to no avail, also tried IE9 (both normal and compatibility) on another PC and has the same issue. The service management part is definitely bugged, and renders the router unusable when you need more than 16 additional services entered.

 

I'm still waiting for a follow up on my Cisco support ticket, it was passed to "next level" on the 26th November and haven't had a response since. Chasing this up again by email to support as I have an expensive piece of junk on my desk that can't be put into production on my network.

 

Dan

New Member

Hi  Does anyone have info on

Hi 

 

Does anyone have info on this upgrade, having the same issue here with RV320 :( now 37 lines, cannot edit, delete, add.... terrible

New Member

Contact Cisco support,

Contact Cisco support, explain the problem, ask for the 1.1.1.19 beta firmware, this issue is fixed for me using this version.

 

Dan

New Member

Hi, no luck, first level

Hi, no luck, first level support has no access to beta firmwares... it was passed to next level and they promised to send an update soon. Havent got any so far.... :(

New Member

Took me a few days to get it,

Took me a few days to get it, but so far it seems to be stable.

New Member

Same here, beta firmware

Same here, beta firmware installed and seems to be stable so far. 

975
Views
5
Helpful
24
Replies
CreatePlease to create content