Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

RV320 port-based vlans

Hello fellow routing and switching enthusiasts.

I need to setup port-based vlans on my RV320, but I'm having a problem saving a simple change from factory setup.

The "before" VLANs-to-ports assignment (per Port Management -> VLAN Membership) is factory default, ie:

   a) VLAN ID 1    on ports LAN 1, LAN 2, LAN 3, LAN 4, untagged.   With IP subnet 192.168.1.0/24

   b) VLAN ID 25  on ports LAN 1, LAN 2, LAN 3, LAN 4, tagged.     With IP subnet 192.168.2.0/24

   c) VLAN ID 100 on ports LAN 1, LAN 2, LAN 3, LAN 4, tagged.   With IP subnet 192.168.3.0/24

The "after" VLANs-to-ports assignment setup I would like to achieve is as follows:

   a) VLAN ID 1001 on port LAN 1 only, untagged.   Will eventually become subnet 192.168.11.0/24

   b) VLAN ID 1002 on port LAN 2 only, untagged.   Will eventually become subnet 192.168.12.0/24

   c) VLAN ID 1003 on port LAN 3 only, untagged.   Will eventually become subnet 192.168.13.0/24

   d) VLAN ID 1004 on port LAN 4 only, untagged.   Will eventually become subnet 192.168.14.0/24

The "process" I tried, to make my first move, was as follows:

   The RV320 initially has IP address 192.168.1.1, accessible from all ports: LAN 1, LAN 2, LAN 3, LAN 4.

   My laptop is connected to port LAN 1, with IP 192.168.1.2

   I then tried to use Port Management -> VLAN Membership to exclude just VLAN 1 from port LAN 2  (seemingly trivial right ?).

But that always fails. I can indeed select this option via the dropdown menu, but every time I try to save this, I get an error:

   "A VLAN port can only be tagged to one VLAN ID (LAN 2)".

This implies that all ports must always be configured to accept default VLAN 1, untagged, so I can never assign different untagged vlans to any ports.

Alternatively I am missing something, but what is it ?

.

  • Small Business Routers
3 REPLIES
New Member

RV320 port-based vlans

Hi Peter,

Try to do the following steps:

1) Add all the Vlan's that you need (1001, 1002, 1003, 1004) and click Save.

2) Change the other Vlan's to Excluded, except the one that you need as untagged.

3) Do the same for the remaining Vlan's and it should work.

Hope this helps,

Let me know if you need further assistance.

Thanks,

Naresh Arjunan

New Member

Re: RV320 port-based vlans

You were half way there, and that encouraged me to experiment with different ways and determine the correct process, which was as follows:

The "before" VLANs-to-ports assignment (per Port Management -> VLAN Membership) is factory default, ie:

   a) VLAN ID 1    on ports LAN 1, LAN 2, LAN 3, LAN 4, untagged.   With IP subnet 192.168.1.0/24

   b) VLAN ID 25  on ports LAN 1, LAN 2, LAN 3, LAN 4, tagged.     With IP subnet 192.168.2.0/24

   c) VLAN ID 100 on ports LAN 1, LAN 2, LAN 3, LAN 4, tagged.   With IP subnet 192.168.3.0/24

The "after" VLANs-to-ports assignment setup I achieved is as follows:

   a) VLAN ID 1001 on port LAN 1 only, untagged.   Became subnet 192.168.11.0/24

   b) VLAN ID 1002 on port LAN 2 only, untagged.   Became subnet 192.168.12.0/24

   c) VLAN ID 1003 on port LAN 3 only, untagged.   Became subnet 192.168.13.0/24

   d) VLAN ID 1004 on port LAN 4 only, untagged.   Became subnet 192.168.14.0/24

PROCESS:

First relocate laptop-to-router ethernet connection from LAN 1 to LAN 4.

Access Port Management -> VLAN Membership  and reduce some complexity by deleting factory VLANs 25 and 100.  Leaves VLAN 1 Default on all ports, untagged.

Stick with  Port Management -> VLAN Membership  and add new VLANs 1001, 1002, 1003 and 1004.

Stick with Port Management -> VLAN Membership  and use simultaneous-2-vlan-editing explained below to replace VLAN 1 with a new vlan, on each port, untagged, ie:

    a) config both VLAN 1 on port LAN 1 excluded, and VLAN 1001 to port LAN 1, untagged  -> Save

    b) config both VLAN 1 on port LAN 2 excluded, and VLAN 1002 to port LAN 2, untagged  -> Save

    c) config both VLAN 1 on port LAN 3 excluded, and VLAN 1003 to port LAN 1, untagged  -> Save

    d) do not mess with vlan 1004 or port LAN 4 at this stage or you'll lose your connection, and it's not obvious how to get it back.

###################################################################################

#

# Simultaneous-2-vlan-editing is where you:

#

#    a) Check the box next to 2 vlans (VLAN 1 and VLAN 1001 for example) and then click edit.

#

#    b) Configure VLAN 1 "Default" to be excluded from port LAN 1,

#       and

#       configure VLAN 1001 to be  untagged on port LAN 1

#

#    c) Then click save.

#

# By saving both of the changes  to port LAN 1 simultaneously, we satisfy the requirement

# that there is  always an untagged vlan bound to port LAN 1.

#

###################################################################################

Configure  Setup -> Network -> Multiple Subnet Table  and change the default subnets which got auto assigned to new vlans, ie:

    a) IP 192.168.4.1 subnet 192.168.4.0/24 got auto assigned to vlan 1001 on port LAN 1.

                 Change IP to 192.168.11.1, change subnet to 192.168.11.0/24

    b) IP 192.168.5.1 subnet 192.168.5.0/24 got auto assigned to vlan 1002 on port LAN 2.

                 Change IP to 192.168.12.1, change subnet to 192.168.12.0/24

    c) IP 192.168.6.1 subnet 192.168.6.0/24 got auto assigned to vlan 1003 on port LAN 3.

                 Change IP to 192.168.13.1, change subnet to 192.168.13.0/24

Change laptop IP to 192.168.11.2, relocate my laptop-to-router ethernet connection from LAN 4 back to LAN 1, reconnect to router on 192.168.11.1

Finish up with:

Port Management -> VLAN Membership  to configure VLAN 1004 on port LAN 4 (using simultaneous-2-vlan-editing).

Port Management -> VLAN Membership  to delete VLAN 1

Setup -> Network -> Multiple Subnet Table change the auto assigned subnet from 192.168.4.1/24 to 192.168.14.1/24

###########################

###########################

###########################

Naresh - others might find it very helpful to find an article in your Knowledge Base for Small Business Routers, along the lines of: "How to replace the Default untagged VLAN 1 with a new untagged VLAN, on a port."

And include the less-than-obvious (to me) method of simultaneous-2-vlan-editing.

Thanks.....pete

New Member

Re: RV320 port-based vlans

I couldn't see a way to select that this question is answered.  If you can do it, that would be marvellous.

5642
Views
5
Helpful
3
Replies
This widget could not be displayed.