Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

RV320 "DNS Local Database" no function

I did setup a brand new RV320 today. Firmware is v1.1.0.09.

I am facing the following problem...

I filled the "DNS local database" with names and IPs and expected that

clients connected via DHCP will be able to use that names in the LAN

instead of IPs. DNS server mode is set to "Use DNS Proxy".

However, clients don't get the names resolved as expected.

Any idea, what does go wrong?

2 REPLIES
New Member

RV320 "DNS Local Database" no function

A bit more try&error solved the issue. The names you put in must have the domain name added, otherwiese they will not be translated.

Example: You have setup a DHCP LAN in your router with domain name "home", and you have a "printer" at "192.168.1.33" then it needs the entry "printer.home" "192.168.1.33" in DNS local database to make the clients in the LAN reaching out for the printer just by name "printer".

A hint in the manual about that would have been very helpfull.

New Member

I found the same issue after

I found the same issue after setting up a local hostname in the DNS table in my RV320 (firmware v1.1.0.06) about a week ago but I don't think the explanation in your "reply" is correct. What I noticed at first is that I couldn't ping the host by name from my Windows PC, but it worked fine from my Android tablet or Linux PC. Experimenting a bit more yesterday, I ran Wireshark while pinging from my Windows PC and discovered that if I used a host name, but not a domain, the PC sent a couple of LLMNR packets (destination IP 224.0.0.252), to which it got no reply, then gave up. If I pinged an external site from Windows, e.g. www.google.co.uk, it issued a single DNS query, destination 192.168.0.1, got a response either from the RV320's proxy cache or the ISP's DNS, and carried on with echoes. If I add a domain extension to the local hostname in the name table, e.g my router's default domain, router44fda0.com, and ping hostname.router44fda0.com, the PC also issues a DNS query, and gets an instant (well, 0.864 millisecs) response from the RV320. I set up my target host with Bonjour (the avahi daemon), and pinging hostname.local from my Windows PC, found that it began with a double multicast DNS (mDNS) query (destination IP 224.0.0.251) asking for the same nodename on IPv4 (type A query) and on IPv6 (type AAAA query), to which my target Linux system responded with hostname.local and the IPv4address, but not the IPv6 address. To my surprise,125 millisecs after the PC  received the IPv4 address, it issued a DNS query to the router, which responded  "no such name" (the hostname was still set up with the router's default domain extension). Even stranger, the PC then issued two LLMNR queries with just the hostname, not the .local extension, to which it got no replies, and finally a second mDNS query, this time a single IPv6 (type AAAA) request for hostname.local, to which it also got no replies. So only the first mDNS query got a successful response. I presume that if had got a successful response from any of the other queries, they would have superceded the first response, i.e. it is saying if the DNS disagrees with the multicast DNS, the DNS is right, if LLMNR disagrees with mDNS and DNS, then LLMNR is right, and if it gets an IPv6 response to the mDNS query, that trumps everything!

My point is that the RV320 does respond to a DNS request, even if it only has a host name in its table. The problem encountered above is that Windows does not issue a DNS request if you ask it to open a host name with no domain.

BTW, I understand that the only reason my PC issues an mDNS query is that Apple install an mDNS extension when iTunes is installed. The mDNS query is only issued if the domain is .local 

2838
Views
0
Helpful
2
Replies
CreatePlease to create content