Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RV325: EXTREMELY slow internet connection

(I apologise in advance for posting this as a separate topic while I initially replied in a similar one but this has since started to affect my business)

I have an internet connection that does 200mbps. My ISP has an internal speedtest (to guarantee that "nothing internet" comes in between and you are testing the "LAN" connection). With my laptop connected directly to the modem I get 185mbps. With my old router (100mbps port) I get 80mbps. 

Hoping for awesome results - since I specifically bought it for its gigabit wan ports - I ran the test again with the RV325 in between. The download speed stalled at 25mbps! (So for clarity: 1/8th of the max speed and 3 times slower than my previous router).

In bandwidth management I've changed both up and downstream numbers to 1.000.000 (it won't go higher) and I do not have any rules, so it should be disabled and hopefully deliver full bandwidth to any device. Unfortunately this does not help a bit. 

The port is connected @ 1gbps to my modem, my laptop is connected  @ 1gbps to the router and I'm running firmware 1.1.1.06

I really hope there is something I missed here, because I'm greatly disappointed so far. 

Everyone's tags (1)
24 REPLIES
New Member

Hi SteveG,The RV32x (fw - 1.1

Hi SteveG,

The RV32x (fw - 1.1.1.06) has demonstrated capability of 800+ mbps WAN to LAN throughput in testing. If you are not getting full throughput from your WAN connection, there are other possible causes.

Have you:

1 - Tried lowering the MTU on the WAN interface?

2 - Checked the speed and duplex settings on the provider device and verified they match the RV32x?

New Member

Thank you for your answer.The

Thank you for your answer.

The modem is connecting at 1Gbps full duplex, which is the correct setting according to the ISP.

However: I tried restarting the router and it now seems to utilise the full speed (minus about 5Mb/s).

Can you tell me if the values you need to enter in bandwidth management are in kiloBYTE per second or kiloBIT? The prefilled values seem to indicate its kbytes, but the unit used is official for BITs (kB/s would be kbytes).

I suppose they don't really matter since I have the management disabled, but correct values are cool :)

edit: So the max throughput only lasted a couple hours and since I haven't been able to get it back. Its been 30Mbps ever since

New Member

Hi SteveG,Glad to hear the

Hi SteveG,

Glad to hear the throughput issue is solved.

The values for upstream and downstream in Bandwidth Management are entered in kilobits per second (kb/s)

Thanks.

New Member

Another thing you could

Another thing you could always also try is disabling SPI, DOS under firewall. Basically disabling everything there except Firewall itself and Upnp.

New Member

Everything that can be

Everything that can be disabled is disabled. But then I think, if that were the solution, what good would a device of that price be if you had to disable all security to actually make full use of your speed?

New Member

Im running a RV320 myself and

Im running a RV320 myself and Im getting upto 896Mbps from WAN <> LAN so i have no clue why you are not getting that.

New Member

So obviously because you don

So obviously because you don't have an issue, nobody else should have one either right? Have you even looked at the other replies in this thread before posting something like that?

New Member

Who says im saying that

Who says im saying that nobody else could have an issue?
Im purely telling what I have set and that it seems to work for me.

Also FYI, i did reply already 27 days ago so yes i have read the full discussion.

Now the next step is to create a support ticket on this and get Cisco to look at it.

New Member

Michiel I apologise for

Michiel I apologise for misreading your response. I am just pretty pissed at cisco because it's not one of the cheapest routers out there and usually it is very good material. Still that is no excuse for reacting so hostile.

Cisco won't have whining from my end anymore, I put it in a box somewhere and replaced it by a simple home router as I posted below.  

New Member

respect to the effect on

respect to the effect on business.  same here with my wrvs4400n that proudly displays gb wan/lan connections.  so frustrating.  make sure ips is disabled as mine can evaluate (if elected) http, ftp, telnet and rpc data which can have a dramatic effect on flow.  you said bandwidth is disabled, so that's out of the way.  are you blocking any cookies, java or activex?  how about the L2 switch/port settings, i tell it what i want and eliminate the auto-negotiation (maybe no effect but, i do it) because i view it as unnecessary chit-chat!  try flashing the latest firmware again, reset to factory defaults and reboot to see if that helps... it can't hurt.  if it improves, leave it alone until the next issue.  if you must, add back any changes you made previously from the defaults one at a time, to determine functionality, until you change something to create your bottleneck again.  just ideas.

it's the standard security features of the router, even at the minimal settings it has to converse with everything (almost).  someone knocks on the door, it has to think, make decisions, find it's weapon of choice and examine your request for the guest.  no ticky no laundry.  maybe it needs new eye wear so it's not so fuzzy looking through the peephole!  just like humans, some days they perform better than others.   heaven help us all with the advancement of technology.  wish i'd be around for the star trek era, when technology flattens out, can't get any faster and runs perfect?  the humor helps me live through it.

New Member

Hello,Just purchased and am

Hello,

Just purchased and am trying to install an RV325 which is intended to replace an RV082.  I am using a single WAN cable with Comcast with a dynamic IP.  My issue is slightly different from SteveG's in that my download speeds with RV325 are averaging around 1-1.5 Mbps on a connection that gets 30 Mbps when connected directly to a pc or a different router.  The odd thing is my upload speed is completely typical at 5 Mbps.Thus on my asymmetrical connection I am getting 5x faster upload speeds than download speeds, when it should be the other way around. 

I have installed the latest firmware. 1.1.1.06. and gone back with factory defaults and the basic set up wizard thinking that I blew a setting somewhere, but still no luck. Ultimately this router would be setup with static WAN address, but before I set that and LAN side up I wanted to put it through it's paces and right now I am stumped.

Thanks, Doug

New Member

Just curious if anyone has

Just curious if anyone has come up with solution to this problem. I also recently purchased the RV325 and connected it to a network with a modem in bridge mode and download speeds just plummeted. I have done in the past with several different routers and have never had this issue. When I connect back to a different router,connect directly without bridge mode speeds are normal. I even tried a new modem and the same thing happened. I have followed all of the previous discussion recommendations and have essentially eliminated all other services on the router including the firewall and can not get speeds at the same rate before using this router. The firmware is up to date, and I've even tried it with only one device on the network so there were no bandwidth issue. Any thoughts would be helpful prior to possibly returning the router.

 

 

 

New Member

I sure as hell haven't... for

I sure as hell haven't... for me it is still 35mbps via the router vs 195mbps directly connected to the modem. This thing is a major piece of cr*p and I'm probably going to throw it out pretty soon.

New Member

Congratulations CISCO...

Congratulations CISCO... because of your excellent support and smb devices you've just been replaced by an Asus Gigabit router... One that does about 95% of my max internet speed without all the hassle!

New Member

Hello all,

Hello all,

i've done fixed this problem by Max Bandwidth & speed and duplex settings.

now its is giving me the accurate speed from the ISP.

Thanks

Kumaran-R

India

 

We have the same problem and

We have the same problem and i don't understand your solution ... 

Can you explain ?

Best regards

Thomas

France

New Member

Hello m8s,

Hello m8s,

I'm experiencing the same issue with RV325, very low speed over a PPPoE connection.

With the old router (Asus RT68AC) the speed was around 835/200 Mb/s (down/up) but now, with RV325 I only have 160/130 Mb/s.

The problem seems to be the PPPoE protocol. If I use Asus router to connect to FO modem (in bridge mode) and RV325 as router, everything is fine, the speed is normal for a gigabit connection.

I checked all the ideas from this topic (1.000.000 kb/s, max allowed), connection with ISP is 1000Mbps full duplex etc.

I upgraded the firmware to the latest version ... nothing changed ...

Any other idea, please?

Daniel

New Member

Please, any ideas?

Please, any ideas?

New Member

This could be the device

This could be the device issue, please call the cisco support and they will replace if the device is bought from cisco authorized resseller.

-Thanks

Kumaran-R

India 

New Member

Hello,

Hello,

I am experiencing something very similar to the above. We have just upgraded to a FTTP line capable of 330/30 from BT (UK).

When using an RV325 connecting with ppoe to the ONT fibre modem the download speeds do not go over 160Mb/s. Using the router supplied from BT we can consistently get a max 330 download speed.

If i connect the RV325 into the ISP router on the wan port and setup static ip/routing then i get full speed from WAN <=> LAN. This is not a solution in my opinion as i do not want to have two routers.

Things i have tried and checked:

* MTU settings match ISP

* disabling firewall options (got increased speed slightly to 175-190Mb/s)

* checked all port connections (connect at 1Gbp/s and full duplex to match ISP)

* Bandwidth management set to max for download / upload

* updated to latest firmware (1.3.2.02)

Any other help would be appreciated before we consider purchasing different equipment!

New Member

This doesn't sound like the

This doesn't sound like the same issue I am having, perhaps a PPPOE issue? Try reducing your MTU by 8. For example if it was 1500, make it 1492.

New Member

Hi, I was referring to D_A_N

Hi, I was referring to D_A_N_I_E_L_74 about similar problem.

I have also played with the MTU settings somewhat (auto/manual set to 1500/1492). Doesn't make a notable difference in terms of missing around 120Mb/s of bandwidth.

New Member

I have the same issue with an

I have the same issue with an RV320 connected to an optimum online static IP gigabit Cisco modem/router combo. The link is 101 down/35 up. When I leave the WAN port on auto negotiate, it detects gigabit, but does about 32 down and about 36 up. When I switch to 100Mb full duplex, I get about 7 or 8 Mb/s down and up. When I switch to 100Mb/half duplex I get the best performance of about 70Mb/s down and 36Mb/s up. VERY weird that half duplex outperforms full unless there's a mis-negotiation. I asked Optimum if they could hard set speed and duplex but they said they couldn't. There is clearly some sort of Gigabit/Duplex compatibility issue in certain scenarios. 

I called Cisco support but after 2 hours plus on the phone, they were no help and offered to replace it if I sent it in. Ridiculous! I went out and bought another Cisco RV320 and it exhibited the exact same issue. Interestingly enough i tried a linksys LRT224 which had the same issue as well. (Linksys used to be owned by Cisco but was sold to Belkin a few years back, I wonder if this issue carried over)

A Netgear r6250 wifi router did close to the full 95Mb/s down. My laptop directly connected to the Optimum router with a static IP did as well. 

Ideas anyone? 

I need a reasonably priced VPN router with good throughput. 

New Member

Hi!

Hi!

I also went along this route.
The last update brought some results, but not enough. (The speed of provider : 500/200Mbit behind the router  : 410/110Mbit)
The choice of Ubiquiti edgerouter. (The speed 540/210)

5183
Views
30
Helpful
24
Replies
CreatePlease to create content