Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RVL200 VLANs Cannot access the internet

Hi Everyone

I have a RVL200, Firmware Version: v1.1.7 and i cannot get my clients on a VLAN to access the internet.

I currently have port 3 on the router set to Access mode with untagged VLAN #4.

I have Multiple VLAN subnets setup and i am using the DHCP server on the router, it is correctly distributing the IP addresses.

The clients on VLAN #4 can see other clients on the same VLAN but they cannot contact the router ip(192.168.1.254) or any website

Any suggestions, questions etc.

Everyone's tags (3)
14 REPLIES
New Member

Re: RVL200 VLANs Cannot access the internet

What IP address do you have assigned for VLAN 4?

I assume you have a switch connected to the port assigned for VLAN 4.  If so, what is the default gateway assigned to that switch?

Lastly, your other VLAN's, are they having any issue connecting to the router or internet?  Are those VLAN's on the same switch as VLAN 4, or a different switch?

David L. Barrett, Jr.
New Member

Re: RVL200 VLANs Cannot access the internet

I have one client machine attached running under VLAN 4. all the other VLANs cannot access the internet nor the router.

The client on VLAN 4 is given the address 192.168.4.100. the gateway is 192.168.4.1. I had the idea that the gateway address was the issue but under the panel for changing the gateway for the subnet it will not allow me to change it to 192.168.1.254.

New Member

Re: RVL200 VLANs Cannot access the internet

Alastair,

One weird thing about these routers is they give dhcp to every vlan, BUT they do it all from the same subnet. For example, Vlan1 and 2 will both pull a 192.168.1.x ip address if connected via DHCP. Their default gateway will be the same. If you do not allow routing between the vlans, then they should only be able to access the internet. I think this is your desired result. Try setting each client to dhcp, set the router to manage vlans on a port by port basis, and then you should be able to access the internet/default gateway/dhcp server without pinging the other hosts on the other vlans.

Just remember that the dhcp server will give the same scope to every vlan, but will filter the traffic at the router based on what port it came in on.

If you are still having issues, please post your results.

Bill

New Member

Re: RVL200 VLANs Cannot access the internet

I have gone back to basis.

I have 2 VLANs. 1=Default VLAN, 2=Test VLAN.

I have DHCP->Multiple VLAN's option turned on, it is assigning VLAN 1 with addresses 192.168.1.x, VLAN 2 with address 192.168.2.x.

Port Managment->Port Setting has all ports set to "Access" mode.

Port Managment->VLAN Membership has VLAN 2 set as untagged on Port 4 and VLAN 1 set to Default settings


The Client is connected to Port 4, it has recieved the ip address 192.168.2.100 from the DHCP server. I cannot ping 192.168.1.x(including the router @ 192.168.1.254) addresses or contact the internet.

Where is the issue?

Silver

Re: RVL200 VLANs Cannot access the internet

I read the post and was wondering are you wanting the different vlans to conversate between themselves. If that is the case, then enable vlan routing on the router.  It seems like you got the vlans created correctly.  Is the other vlans able to get out on the internet?

New Member

Re: RVL200 VLANs Cannot access the internet

I simply want my user created VLANs that site on different subnets to access the internet. The default vlan can access the internet fine. the user created vlans cannot

Silver

Re: RVL200 VLANs Cannot access the internet

If your pc's are getting an ip address from that different vlan then the vlan and dhcp are working.  I would check the dns and verify that you have a dns address from the router.  That could be the underlying issue.  I would run some ping test to an external ip address and see if you can get out.  But it sounds like an DNS issue.

New Member

Re: RVL200 VLANs Cannot access the internet

The client on the VLAN cannot ping the router itself. its scope is only other clients in the VLAN. I have mentioned this in my orignal post here

Silver

Re: RVL200 VLANs Cannot access the internet

I saw that your receiving an 192.168.2.100 address from your router now on the port 4.  If that is the case, the routers ip address for that vlan is 192.168.2.1, not 192,.168.1.1.  For up to 4 vlans the router will have 4 different gateway addresses while it is supporting those 4 vlans.

Silver

Re: RVL200 VLANs Cannot access the internet

If you have 4 vlans by default the vlan's gateways will be 192.168.1.1 for the first one.  192.168.2.1 for the second, 192.168.3.1 for the third and 192.168.4.1 for the fourth.  You can assign the vlan to the ports and your router will act as if it has four separate networks coming off of it.

New Member

Re: RVL200 VLANs Cannot access the internet

I understand what the VLAN system is doing. its the reason why i am using VLAN's i simply cannot access the internet from within the VLAN. thats what i need help with

I have tried to ping google.co.uk on the ip: 216.239.59.104 from within the VLAN. all i get in return is Destination host unreachable

Silver

Re: RVL200 VLANs Cannot access the internet

Just wanting to make sure of what you have.  Is the router giving out dhcp or do you have a dhcp server giving out dhcp?  If it is a server giving out dhcp I would make sure that the servers gateway that it is giving out is 192.168.2.1 for the second  subnet.  If the router is giving out the dhcp and not allowing it to get out on the internet, I would call the cisco support there in the UK and open up a support ticket and let them do some troubleshooting with you.

New Member

Re: RVL200 VLANs Cannot access the internet

Problem fixed. It needed to be turned off and turned back on at the wall. the DHCP server will not use its updated configuration till it reboots. If you have a bugzilla at cisco i recommend it being noted.

Also could you add support for other browsers. running a VM with windows and IE6 is annoying and time consuming

Silver

Re: RVL200 VLANs Cannot access the internet

I was glad I could help you fix your issue.  If you have any further issues feel free to give us a post or a call and we will assist you in any way.  Thank You.

2498
Views
0
Helpful
14
Replies