Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

RVS4000 Losing configuration

Hello,

I'm using a RVS4000 router since a few months, but yesterday I had a weird problem. I haven't had any problem yet, but suddently the router lost his configuration.

I was able to login using the web interface with my normal user/password, but configuration was all reset. I did a full reset of the router and I'm gonna try to restore the configuration using a backup.

I'd like to know if anybody has ever experienced this kind of issue with this router ??

N.b. I think I'm having version 2, with firmware 2.0....

Thank you.

Everyone's tags (3)
9 REPLIES
New Member

RVS4000 Losing configuration

Make sure to refresh your browser.  I have seen some weirdness with Chrome if you are using it.  Also, these sometimes take (a long) time to refresh and fill the configuration forms for some reason. 

The GUI loads the default configuration items, then goes to some onboard database and refreshes the GUI with the current information.  If it doesn't refresh fast enough, you might think the config was lost and back to the default.

I've seen this when using Remote Desktop as well, although that may not be your situation.

Remember that it kept your user id and password.  If it lost those and went back to the factory default, then I would say yes, there is a problem.

I hope this helps.

New Member

RVS4000 Losing configuration

Thanks for your reply. Your explanaition related to GUI is right.

But when the problem came, my PC got from DHCP an IP address that is in the same range as default IP settings. So, it makes me believe it's not only due to a GUI effect...

New Member

RVS4000 Losing configuration

Have you had any more problems with this?  I work for a company where I do PLC programming and have recently started using this router.  Unfortunetly I have seen the excact problem occur many times.  We are now shipping this router with some of our equipment and I have been seeing this occur.  I have tried to rule out power issues by using UPS.  I am gong to contact support 2morrow to see if they have anything else to resolve the problem.  Thanks!

New Member

RVS4000 Losing configuration

And yes,  I have upgraded the firmware.

Silver

RVS4000 Losing configuration

What Web Browser do you use?

Regards Simon
http://www.linksysinfo.org

Regards Simon http://www.linksysinfo.org
New Member

RVS4000 Losing configuration

I use IE anytime I am dealing with networks/routers.  We have a test site with 5 static IP's.  I have the RVS set to use one of the static IP's.  Works great sometimes for a week, 2 weeks and sometimes longer.  Just out of the blue I can not connect to the site using the VPN.  I remote into the router and what was once set as static changes to dynamic (WAN)and all of the VPN info is wiped clear.  Almost like someone hits the reset.  It still has some of the info in the router.  Example the router network address is the same but after you cycle the power it is reset to the defaulted 192.168.1.1.  I have tried antoher router here.  I have seen the same issue at one other site.  I am also using one on my home network with no problems.  The difference is it is set to dynamic (WAN) on the home net.  Never had a problem with it dumping everything. 

Thanks for the response.

New Member

RVS4000 Losing configuration

MIke,

The firmware update leaves configuration breadcrumbs, which need to be cleared out with the factory reboot.

As far as your config, you set your WAN to a static address and later it goes to DHCP?

That is weird.

So you have 5 static IPs reserved at a site.  You put 1 RVS4000 in there to take up 1 of the static IPs.  You setup a VPN (from another router or a client?).  This works for a while and then defaults back to DHCP and you can't get to the subnet via VPN, but you can use the static IP to administrate the RVS4000 router, at which time you see the WAN config went back to DHCP.

Am I understanding it correctly?  I have a similar setup, although I go (1)RVS4000 => (3)RVS4000 via 3 subnets, each with its own VPN.  It was a pain to setup, but it does work reliably so far...  Are you using a client for the VPN or another router?  What modem or device is in front of your RVS4000 (providing the 5 static IPs) ?

New Member

RVS4000 Losing configuration

Thanks for the replies.  I have a ATT Uverse modem.  I will get the exact model the next time I am on site.  5 Static IP's (###.###.###.49 - ###.###.###.54) with .54 being used by the Uverse modem/router.  .50 is for the Cisco with two credit card readers and two Allen Bradley Industrial PLC's.  .51 is a camera/dvr system  .52 is some other industrial HMI equipment.  For security reasons we keep the credit card and PLC's behind the firewall of the Cisco with no port forwarding set in the router.  We connect remotely to this router using the Cisco QuidkVPN. 

In the Uverse the firewall to .50 is disabled allowing full access to the Cisco.  Port forwarding is used for .51 and .52 static IP's.

Yes,  the weirdest thing is to log into the router and see the WAN set to DHCP.  My LAN is set to use 192.168.10.1.  I log into the router using the 192.168.10.1 gateway address and discover the WAN is set to DHCP and the LAN is set to 192.168.1.1.  If I cycle the power at this time I will then need to log in using the 192.168.1.1 (DEFAULT)  address.

It's like the memory gets dumped or reset but the router never does a reboot.

I've talked to a few IT guys and there feeling are the same.  The Cisco should not just dump settings.  We are tring to rule out power issues now.  I have removed the Cisco from a Industrial control cabinet and powered it from a different source.  I will be installing a UPS tommorrow. 

New Member

RVS4000 Losing configuration

Hi Mike.

Ok, there is plenty of information there.  Based on what you are reporting, it sounds to me like the router is defective.  I suggest getting another and swapping.  That is probably the easiest and most cost-effective path because your time is worth more than this trouble.  If that works and the original one is under warranty, return it for r/r and keep it as a spare, which you should have anyway.

Now, some comments/suggestions in the meantime...

Just for giggles.... reflash the current one with the latest firmware first (did it before?  do it again anyway...)  Do a factory reset.  Reconfig and change the default user and password too.  See it that fixes the dropped config problem.

As far as the firewall, I would enable it.  You may also want to consider using a different browser (chrome?) for the config.  I know I could have done a better job on the parser and gui on that device if I was blindfolded, especially the user-specified form stuff like LAN rules and VPN password.  Their parser is braindamaged.  The hardware seems pretty good though, but you must make sure it's well ventilated or it can croak from heat.

If you enable remote administration, you should be able to browse to your router using the dot 50 WAN ip.  From what you say, you have been going to it when at the remote site when you use a PC on your dot 10 subnet (LAN) and you see the router has changed WAN address to DHCP and the LAN address to the 1 dot 1 default.  That really indicates that the device is not storing the config in persisent memory.  It would be interesting to see if it also reverted to the default user and password after you changed it.  If it does... defective.  If it doesn't.... something in the config is hosed and I would definitely reflash, factory reset and then reconfig again.

Just to give you an idea of how another setup is config'd, on mine, there is a cisco cable router feeding the RV ciscos (5 static which 3 are currently used).  I have each router going into an HP managed giga switch.  The subnet mains are attached there as well.  Each device line power runs through an iBootbar which is fed from a big UPS.  I also put a PC on one of the subnets. On the routers, I open & forward 3389 to the PC  As a backup, I run VNC server on the PC.  dot 254 forwards to the iBootbar.

One thing I have though is in my office there is another RV cisco.  That has the VPN defined for each of the 3 subnets I use.  The office is sub 0.  Remotes are 1, 2 and 3.  I didn't see you mention anything about a client or router.  If you are using a softwre client, there may be an issue. You might want to consider router-to-router for your VPN.

Because of the way I have mine setup, I can remote access 2 ways, remote reboot hardware, cross subnets and more.

One thing I would recommend... for security purposes, put routers between your AT&T and the attached devices (controller, video, etc).  Don't go right out of the AT&T into the device.  IMHO, that is a lot of exposure.

I hope this somehow helps.  Kieep us posted.

1673
Views
0
Helpful
9
Replies