Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Slow Internet Speed - RV042 v1.2

IT professional needs help with slow internet speed due to RV042 router:

Testing my interenet speed to determine bottleneck and it is my Lynksys RV042 Router.

     Summary:

          Cable modem only:                57.7Mbps DL speed

          RV042 and Cable modem         2.2Mbps DL speed

Equipment Details:

ISP: Comcast Cable "Blast" "Up to 50 Mbps"

Cable modem:

Cisco Model: DPC3008

DOCSIS 3.0

S# 241985600

Mfg Date: 11/2011

Lynksys Router:

Model: RV042 v1.2

S# NKS10095371

Mfg Date: 03/2010

Firmware 1.3.13.02-tm  (latest firmware that I could load)

Testing:

Connected Win 7 laptop directly to cable modem

Recycled power on cable modem

disabled/enabled laptop NIC

Speedtest.Net Results (average over 5 tests);

   Ping:  25ms    DL:  57.73Mbps   UL:  11.48Mbps

Powered off Cable Modem

Powered off RV042

Connected RV042 to Cable Modem

Connected Win 7 laptop to RV042

Powered up cable modem

Powered up RV042

disabled/enabled laptop NIC

Speedtest.Net Results (average over 5 tests)

   Ping:  25ms    DL: 2.2Mbps    UL:  10.7Mbps

Tried adjusting various RV042 configuration settings:

     Set bandwidth management to highest setting (100000)

     Disabled SPI & DOS

     Minimum Access Rules (Allow all LAN traffic/Deny all WAN traffic)

     No content filters

Changing these configuration parameters had virtually no effect on DL speed.

Everyone's tags (3)
1 REPLY
New Member

Slow Internet Speed - RV042 v1.2

Testing Update:

Additional follow on testing last night:

Reset RV042 to Factory Defaults.

Set Router Parameters to what I needed.

Speedtest.Net:  Again very slow DL speed:  2.3Mbps

Reset RV042 to Factory Defaults.

Rebooted cable modem.

Rebotted RV042.

Disabled/enabled laptop NIC.

IMPROVEMENT !

Speedtest.Net:  Ping:  25ms  DL:  32.0Mbs  UL:  10.7Mbps

Configured RV042 with for personal parameters

Rebooted cable modem, RV042, and reset NIC

Speedtest.Net: Again very slow DL speed:  2.3Mbps

But now I know it is someting within my configuration !!!

Backed config changes one at a time & retest each time.

Problem found!

I had set the ports to Full Duplex/100Mbs and disabled "Auto Negotiate"

Default is Auto Negocite enabled.

Enabled Auto Negotiate.

Rebooted cable modem, RV042, and reset NIC

Speedtest.Net:  Ping:  25ms   DL:  32.0Mbs  UL:  10.7Mbps

Much better than 2.2Mbps but much less than direct attach to the cable modem of 57.7Mbps !

Can't the RV042 come closer to the 57.7Mbps of the cable modem ???

I could see a 10% hit on performance due to router functionality, but not almost 50% !

2004
Views
0
Helpful
1
Replies
CreatePlease to create content