Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SR520 - DSL, PPTP, and the ESW500.

Hi folks. I'm new to this community.

I have an sr520 router/dsl modem combo device that I configured via the CCA. I had all of its configuration set (so I thought) until I plugged it into the ESW500 switch.

It said it had not configured the proper switchport role and recommend I select it as a 'router' on the fe1 port. After it switched to 'router', the IP address configuration all disappeared and I lost communication to the device.

nO serial ports around and all the systems networked and domained, I could not reconfigure it onsite. Also, I did not get the DSL uplink rolling properly.

Anyone care to point me in the way of help? I could use it. I will reply w/ a copy of my current config soon. Essentially we have a 'sticky static' IP thru AT&T.

Everyone's tags (4)
8 REPLIES
New Member

Re: SR520 - DSL, PPTP, and the ESW500.

Alexander,

There is a factory reset button on the front of the ESW switches. It is on the bottom left of the front panel and is easily reached with the point of a paper clip. It is best to push and hold it for ~30 seconds for the switch to be factory reset. It would be best to configure it and the SR via CCA.

HTH

Bill

New Member

Re: SR520 - DSL, PPTP, and the ESW500.

Alexander,

After reading your post a few more times, I think I misunderstood the first time. I actually believe you meant you could not get back into the SR520. There is a console port on the back of the device. It is accessible via a rollover cable with hyperterminal. The settings for the hyperterm session are 9600,8,none,1,none. This should get you back to the IOS form of the SR so you can factory reset it.

To do this log into the SR via the console port. Get into privledged mode and do a

show flash:

This will display the contents of the devices flash memory. You then look for the file that has SR and factory in the title and highlight the entire file name. Copy that file name and then type

copy flash:(paste file name) startup-configuration

Once you have done this press enter and it will ask you if you want to name the file startup-configuration. Press enter again, and it will say it copied successfully. Once it is to that point, type

reload

It will ask you if you want to save the configuration and you should say no. It will reload at this point and be back to factory defaults.

Please let us know how it goes.

Bill

New Member

Re: SR520 - DSL, PPTP, and the ESW500.

Hi Bill.

I thank you very much for the response.

Here's what happened - as soon as I set the 'router' type on the port, I lost full communication to the device. I did it again (off the switch) as a test, only I was prompted for which vlan - I took 75. Still lost communication. Thinking I'm not understanding all of what's happening here. ;)

Thanks for the term settings!

For the update, after the router had been unplugged, moved, etc, I was able to get into it again, which is how I did that switchport test again.

Should I still do a factory reset?

New Member

Re: SR520 - DSL, PPTP, and the ESW500.

Ok, so I said I'd post the full information and here it is.

My IP setup is 67.118.230.193/29, gateway .198. Physical topology:

DSL modem/router (SR520) -> ESW 500 switch -> all my systems/wireless

67.118.230.193, internal to 192.168.0.50, switch @ .250, wireless AP at .245, SBS 2003 server at .2.

I am using remote desktop and the sbs pptp VPN connection, server as DNS & dhcp server, althogh I can remove its dhcp role if need be.

Included is my config script. I know it's extensive, I believe that's from teh security audit I ran (it recommended I do so). All was configured in CCA, except the switch which is configured via http.

As I mentioned, I want this to be used as dsl modem and router, combined with the esw500 switch, and the only other specific thing I need is to have my VPN working (pptp thru sbs 2003).

Anyhelp would be appreciated. the issue I ran into is that after I configure a switchport role on fe1 as a router, I lose all connectivity with the device.

Thoughts/comments/help?

Cisco Employee

Re: SR520 - DSL, PPTP, and the ESW500.

OK just want to make sure I completely understand.

You are connecting the SR via RJ11 for DSL using PPPoA (connecting directly to ATM line or POTS) I do beleive this is what you are doing.

With this in mind there are a couple of things we need to change on the router:

You created the Dialer1 interface which was needed but you did not bind that to the ATM interface. You still need to configure the ATM interface with the applicable protocols of the connection, such as pvc.

As for PPTP you have the port forward '1723' but we also need to forward the protocol GRE 47 to your SBS box. Once you do this you will be up and running.

Remote desktop is fine, typically I prefer to start on the Outside port of 3500 translated to 3389 inside. This keeps people guessing but also gives me a way to track all my RDP connections to different boxes. You may want to remove the UDP forward as it is not needed, eventhough 3389 runs on both. We just need to map the TCP portion.

I would not remove DHCP from the SBS box primarily because this is not causing any of the problems you are having. It would be best for your domain to leave the DC as DHCP and DNS server. When the SBS box hands out DHCP you can also configure it to assist with controlling DNS record creation and deletion when DHCP lease expires.

And lastly for your ESW switchport; this is tricky and confusing because the ESW only understands that fe1 is a router, but really we are just connecting to another switch (4 port switch). So what is happenning when you place that port into Router role it is expecting an IP address configuration, and its just not needed. Leave fe1 as an access port.

and just in case you have not downloaded this yet..... take a look at the configuration guide attached.

New Member

Re: SR520 - DSL, PPTP, and the ESW500.

I am having the same issue as the original poster.  I had setup my SR520, and during the process it seems the LAN has become unavailable.  in am unable to get an address, ping, or connect via CCA.  I tried to reset the router to the default startup configuration as you outlined above thorugh the console port but am having issues....

- i connected through hyper terminal.

- i went into privelaged mode:

SR520> Enable

- i ran the show flash command:

SR520# Show Flash

- it printed out the default config file, i attempted to run the copy command:

SR520# Copy Flash SR520-FE-factory.cfg Startup-Configuration

but it gives me the following error:

"SR520#copy flash SR520-FE-factory.cfg Startup-Configuration
                                                             ^(this carrot is under the S in startup)
% Invalid input detected at '^' marker."

im not sure where to go from here, i also tried using startup-config instead of startup-configuraiton but it doesnt seem to like that syntax either.  what am i missing?

Cisco Employee

Re: SR520 - DSL, PPTP, and the ESW500.

Hi Jason,

I think the location of the caret may be misleading if you are not using a fix width font like courier.

The command that you need to copy the default configuration is missing an important colon, as follows:

copy flash:SR520-FE-factory.cfg Startup-Configuration

Once you have copied this file, power cycle the SR520 and it will return with the default settings.

Regards,

Andy

New Member

Re: SR520 - DSL, PPTP, and the ESW500.

Andrew,

thanks for the response.  You are correct in that the issue with the copy command was the syntax.  I tried going through your unstructions again, however it seems to have been successful in solving the issue.  Here is a list of commands and prompts that where entered, with my entries in bold:

get itno privelaged mode...

SR520> enable

password:

enter show flash command...

SR520#show flash:


36864K bytes of processor board System flash (Intel Strataflash)

Directory of flash:/

    2  -rwx    18608800   --- -- ---- --:--:-- -----  sr520-advipservicesk9-mz.124-20.T5.bin
    3  -rwx        3795   Mar 1 2002 00:04:21 +00:00  SR520-FE-factory.cfg
    4  -rwx         600   Mar 1 2002 23:47:26 +00:00  vlan.dat
    5  -rwx        3795  Mar 21 2002 23:01:22 +00:00  Startup-Configuration

35868672 bytes total (17244160 bytes free)

enter copy command...

SR520#copy flash:SR520-FE-factory.cfg Startup-Configuration


Destination filename [Startup-Configuration]? (i hit ENTER)


%Warning:There is a file already existing with this name


Do you want to over write? [confirm] (i hit ENTER)
Copy in progress...C
3795 bytes copied in 0.052 secs (72981 bytes/sec)

i enter the reload command...


SR520# reload

it then rebooted.  when it came back up i was still unable to connect to the router or get an ip address from it.  i tried assigning a static in the 192.168.75.x range but still would not connect.  i also could not connect to the router with the configuration assitant.  not sure what to do next, this is an out of the box router so i was just trying to do the initial configuration.  any help would be appreciated!

3107
Views
0
Helpful
8
Replies
CreatePlease to create content