Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ssh login to RV320?

Is there a way to login via SSH to the RV320?

9 REPLIES
Gold

ssh login to RV320?

Hi Boris,

The Cisco Small Business routers do not have SSH access.

- Marty

New Member

actually,since the last two

actually,

since the last two firmware updates, there is an ssh login.

I have not managed to login though, since my admin password is not acceopted through the ssh login.

New Member

Hello tutenchamun,Thank you

Hello tutenchamun,

Thank you for using the Cisco Small Business forums! My name is Kevin, I am an eContent developer and I am part of the Small Business Support Community. I'm sorry that you are having troubles logging in through SSH.

It would be helpful if you could provide me some more information such as: what type of SSH client you are using to log in? Do you have SSH/Remote SSH enable in the Firewall > General page? What firmware version are you using? I am currently using Putty and I am able to log in through SSH.

I hope you reply back with any questions or concerns!

Sincerely,

Kevin Yen

Cisco eContent Developer

New Member

Well, it does not seem to be

Well, it does not seem to be related to any firewall issues, since I am able to connect and recieve a login prompt (I am using my OSX/MAC ssh client).

The problem is, that my admin user password (that I use on the webpage as well) is not accepted.

So I have three tries until the rv320 ssh disconnects me.

New Member

Hello,I'm trying to narrow

I'm trying to narrow down the possible problem, have you tried it on any other devices such as PC?

Sincerely,

Kevin Yen

New Member

I tried a putty client on

I tried a putty client on Win10 with no success either.

I am prompted for my "admin" account,

but using the known web-passwd results in "Access denied"

New Member

Same here. Using Firmware v1

Same here. Using Firmware v1.2.1.13.

Local SSH via Putty doesn't work -> Access denied

The same with SSH Term Pro on iPad (iOS 8.4.1) -> Invalid Password

Using standard Admin password, same as Web Interface, checked three times

Please help.

Thanks,

thiesy

New Member

Hi, thiesy!I'm using same fw

Hi, thiesy!

I'm using same fw and it works OK - I can connect locally via ssh from a linux box.

Haven't tried putty on windows.

From my experience RV320 is a very mean box. Sometimes U need to reboot it using a power switch (restart from web interface doesn't refresh the whole configuration).

The second issue I've encountered - if U use some special chars in the password, it can prevent U from logging. f.ex: chars # and & in a password blocks user login via PPTP, even if he/she can log in to the web interface.

It took me about a week to find out the reason why some users can log in via PPTP and some others can not!

My advice: create a new user in local db with a short simple password having only letters an try to log in via ssh.

But IMHO it isn't worth a try, being logged in U can do nothing, U do not have a shell, only a useless subset of it:

pawel@dell:~$ ssh -l cisco 192.168.1.1
cisco@192.168.1.1's password:
RV32X> help
CLI command support following function:
access-list        Add/modify/delete access rule or change access rule's priority.
interface vlan        Add/modify/delete vlan setting or set vlan membership.

you may see the detail setting with command help by following setting:
<command> help

EXAMPLE:
If yout want to see how to set access-list:

EXAMPLE COMMAND:
access-list help

 

 

And that's all....

Gimbus

 

 

 

Cisco Employee

Hi Tutenchamun;Since this is

Hi Tutenchamun;

Since this is actually a new thread, I would've proposed opening a new discussion since the initial thread is over two years old. We will keep it this way for this thread, but in the future for sake of confusion I would request a new thread.. Just an observation.

Thanks

Glenn

 

3173
Views
0
Helpful
9
Replies
CreatePlease to create content