Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

TFTP timeout over WAN

I am trying to copy a file on to the flash of a router over the WAN using TFTP. After some time it gets timed out. Even if I try to copy the file using the windows command over  the WAN using TFTP it does not complete. Is it that TFTP does not support large file downloads over the WAN?


If I do a debug on the router, i get replies only till the 3rd or 4th block of data. Then, only the requests are send. I used two different TFTP servers suspecting an issue with TFTP. The router was Cisco 1841 and the link 512Kbps. The IOS file size 22MB.

1 REPLY

Re: TFTP timeout over WAN

Hi,

If I recall going way back a few years ago,  I tried something very similar with a Allied Telesis TFTP server software on my PC trying to upgrade IOS on a remote router.

Wireshark indicated that my PC was actually at fault and not streaming the UDP traffic to the router.  The UDP stream just stopped, go figure :-)

My resolution was to try another freeware TFTP server, in my case it was the freeware 3COM TFTP server, and all worked ok. Wireshark capture confirmed that the new server streamed fine to the remote router.

So what i got out of that experience was;

1. I learnt how to use wireshark.

2. replaced my old faithful TFTP server software and try another TFTP package and try the upgrade again.

regards Dave

1005
Views
0
Helpful
1
Replies
CreatePlease to create content