Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

wrv210 - can not enable ddns

I purchased 2 wrv210 routers, had a VPN tunnel set up and working OK.
Had DDNS working OK, VPN tunnel working OK, no problem.

I had some problems, and needed to exchange the locations of the routers. So I proceeded to change settings.
When I changed the DDNS settings, the DDNS refused to ´´Enable´´. It always stays disabled.

I tried resetting factory default settings, then enabling DDNS, but the DDNS status remains disabled.
I tried resetting (hold reset button 30 seconds), then enabling DDNS, but DDNS status remains disabled.

I read a forum where someone had a linksys router (another model) with the same problem.
They found the solution by backing up the setting to a config file, then editing the config file in notepad, then restoring to the router.
But WRV210 config file is .BIN, I can´t edit it.

I restored a previous config file I had, and the DDNS is set up and enabled, but it is the wrong user name, etc. So I try to make changes, and the DDNS always gets disabled (DDNS status:disabled)

The forum suggested backing up the setting first thing, as soon as you get the router.
But for me it is too late. Is there any one who can send me a WRV210 config.bin file, with the settings saved from a factory default, where there was never any DDNS set up? Then I can restore from config.bin file, and enable the DDNS.

It seems the WRV210 lets you set up DDNS the first time OK, afterwards it does not accept any changes.
~My mistake was I should have backed up the router settings as soon as I bought the router.

Any suggestions from the experts?

my firmware is 1.17

Re: wrv210 - can not enable ddns

Hi Daniel,

I am not a  Post sales support expert, but will offer a suggestion.

If the current problem  is a issue with 1.17 software,  then why not  upgrade to the latest firmware WRV210_2.0.0.11.img.

After the  software upgrade, reset the unit to factory defaults, via software GUI  or via the reset button.

Or has your manipulation of the bin configuration file ruined the machine .

Also i noticed a change to DDNS which may be affecting you,   they left a message for me that stated.

"Changes To Dynamic DNS Service

We are making some changes to Dynamic DNS accounts, including:
limiting each account to 2 Dynamic DNS hostnames and
limiting the number of domains we offer for the free services."

Hope this helps

regards Dave

New Member

Re: wrv210 - can not enable ddns


Thanks for your reply.

I did your suggestion: upgraded to firmware ver 2, restored factory

defaults, then entered the DDNS settings, but the DDNS status remains

DISABLED. It shows the DDNS settings, my IP address, but DDNS status


I read 3 forum articles about DDNS problem:

#1- on WRV54G router, the DDNS status remains disabled. (Linksys replaced

the unit, but same problem)

#2 - on WRV54G router, someone discovered that if the router had an

existing configuration, DDNS

could not be changed. Problem solved by factory reset

#3 problem solved by saving config, editing in notepad, then restoring.

(I will include these forum articles below.)

In my case, with my WRV210 router, because config file is .BIN, it can´t be

edited in notepad.

So I did not even think of trying that idea.

I do have a config file I saved early after the purchase, I restore it, and

the DDNS status is ENABLED. But the user name, etc is wrong (it was at early

stages of learning, and I did not fill in the correct user name, host

name,etc). So I need to change it. When I save changes, status becomes


My only thought is to ask someone with a new WRV210 which has never been

configured with DDNS to send me a config file, and try loading that into my

router, and try to change the DDNS settings.

This problem I have with both of my routers (I bought 2 routers, both


Please let me know any suggestions, I appreciate the help.


(here are the forum articles I found),9703388

WRV54G DDNS Disabled!!!!!

Does anyone else have the same problem I am encountering? Look

under the setup, DDNS tab where your dyndns info is and find that

the Status of the DDNS is disabled? Linksys sent me a second unit

and both of them have the same problem. Linksys swears they haven't

heard of this problem before.

DDNS Disabled

While trying to change a DDNS identity on a clients WRV54G the

status always appeared as DDNS is Disabled, indicating that the

router was not communicating with the DDNS server.

I found that if the router had an existing configuration, DDNS

could not be changed.

Fix was to reset router to Factory Settings and configure DDNS as

first step. When saved , Status came up as DDNS is Enabled -

working OK.

All other settings were restored manually.

New Member

Re: wrv210 - can not enable ddns

Dear Dave,

Thanks for your suggestion.

I found the problem, I log in to DYNDNS.ORG with my username, but my actual

DYNDNS account has another name. Something I did not realize when setting up

the DYNDNS account, as it was my first time. (stupid me!)

The problem was that I was using the wrong name in DDNS setup, and the

router was not logging in OK to the DYNDNS. That is why the DDNS was always


Now is working OK.

Thanks for taking time to help me find the answer.

I am now using the firmware ver 2, and all is well.

best regards,


CreatePlease to create content