Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP running between Router and ASA via Switch

Hi, 

Is that possible I can running a EIGRP between router and ASA via  switch?

Both router and ASA connected to the switch with static route.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Hi Tommy Chin,

Hi Tommy Chin,

It is possible, we need to advertise the route between router and ASA,

Please provide your connectivity diagram for better explain. 

Example...

interface GigabitEthernet0/0

description Links to WAN Router

nameif OUTSIDE

security-level 50

ip address 10.1.1.1 255.255.255.192 standby 10.1.1.2

summary-address eigrp 100 10.1.0.0 255.255.0.0 1

!

Eigrp Protocol Confiuration

access-list eigrpACL_FR standard permit any

!

router eigrp 100

distribute-list eigrpACL_FR in interface OUTSIDE

neighbor 10.1.1.3 interface OUTSIDE

neighbor 10.1.1.2 interface OUTSIDE

network 10.1.1.0 255.255.255.192

redistribute connected

redistribute static

!

Regards,

Srinivas. 

Note :If it resolves your problem flag it as Resolved.

Thanks & Regards, Srinivas. N.
1 REPLY
New Member

Hi Tommy Chin,

Hi Tommy Chin,

It is possible, we need to advertise the route between router and ASA,

Please provide your connectivity diagram for better explain. 

Example...

interface GigabitEthernet0/0

description Links to WAN Router

nameif OUTSIDE

security-level 50

ip address 10.1.1.1 255.255.255.192 standby 10.1.1.2

summary-address eigrp 100 10.1.0.0 255.255.0.0 1

!

Eigrp Protocol Confiuration

access-list eigrpACL_FR standard permit any

!

router eigrp 100

distribute-list eigrpACL_FR in interface OUTSIDE

neighbor 10.1.1.3 interface OUTSIDE

neighbor 10.1.1.2 interface OUTSIDE

network 10.1.1.0 255.255.255.192

redistribute connected

redistribute static

!

Regards,

Srinivas. 

Note :If it resolves your problem flag it as Resolved.

Thanks & Regards, Srinivas. N.
267
Views
0
Helpful
1
Replies
CreatePlease to create content