Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Windows 7 - "failed to determine valid temporary file folder"

I have a user that is off-campus, and recently has become unable to get AnyConnect to connect to our universities network.  He has been able to connect for years till recently.  We have had some odd issues lately after Java 8.144 came out and we upgraded the AnyConnect to 4.5.00058.

We have found that in a few cases, we have to completely uninstall Java and reinstall, before uninstalling the older version of AnyConnect and installing the new version while in Internet Explorer 11.

In this case, this solution did not work.  The reinstall kept throwing up an issue with "the-file-manifest-tool-exe-is-not-marked-for-installation", and backing out of the install.  I went in to the Registry and removed any trace of Cisco and AnyConnect after confirming that there were no programs installed in Programs and Features.  The program appears to have successfully installed now, but starting it pops up a different message now, anyconnect "failed to determine valid temporary file folder", and I can't get past that.  I have found some posts about this relating to Mac PCs, but not Windows PCs.

Any thoughts would be appreciated...

Everyone's tags (1)
3 REPLIES
New Member

Re: Windows 7 - "failed to determine valid temporary file folder"

Hello, I just have the same error message on a students' windows computer: failed to determine valid temporary file folder. I checked the file and folder permissions on the whole c:\ drive and made sure the local USERS group has write permission on every folder. I got the hint out of another post here which deals with the same error message on Mac OS X.

Could someone help please ?
New Member

Re: Windows 7 - "failed to determine valid temporary file folder"

found this solution. Verified that a user with this issue did this and it fixed the problem.

 

from a command prompt type echo %temp%

delete the %temp%\Cisco directory

 

Since the error did say “temporary file folder”, I went to %temp% and deleted the Cisco directory — an action that requested elevation for some reason.  After deleting the %temp%\Cisco directory, everything worked again.

 

At some point during the upgrade, the %temp%\Cisco folder was modified so that only elevated processes could successfully read/write — something that broke the AnyConnect VPN client until I resolved it.

 

From

https://tjinit.com/?p=94

New Member

Re: Windows 7 - "failed to determine valid temporary file folder"

had same issue and deleting the cisco folder in the temp directory as you mentioned did the trick

1028
Views
0
Helpful
3
Replies
CreatePlease to create content