Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

How to configure Cisco SMB Sx300 & Sx500 Series Switches for Shoretel IPT DHCP Opt 156

It is possible to configure Shoretel DHCP option 156 on a Cisco Sx300 & Sx500 SMB Switch. However the configuration is subtly different from Cisco IOS classic configuration. For example below (on Cisco classic):

 

 

option 156 ascii "configservers=172.16.1.7, ftpservers=172.16.1.7, country=7, language=4, layer2tagging=1, vlanid=2"

PLEASE NOTE: Custom options are supported from 1.3.5.x on the Sx300 & Sx500 Series

 

  • Updated DHCP Server to add support for user-defined options for Sx300 and Sx500

 

Here's what happens if you try to add ASCII strings to Option 156 on Cisco SMB Switches.

 

Input:

 

ip dhcp pool network 172.16.1.0

option 156 ascii "configservers=172.16.1.7, ftpservers=172.16.1.7, country=7, language=4, layer2tagging=1, vlanid=2"

 

Output:

 

switch4221e7(config-dhcp)#$7, language=4, layer2tagging=1, vlanid=2"

DHCP server option parameters mismatch. This code 156 must be from other type.

 

Solution:

 

Simply convert the DHCP Option 156 ASCII data to HEX and all works perfectly! The Sx300 will not accept ASCII format although it has the option in CLI.

 

Here's an example for Voice VLAN 2. (Data on VLAN 1)

 

ASCII - HEX Convert.JPG

 

Switch Config: (Important sections only)

 

vlan database

vlan 2

exit

!

ip dhcp server

ip dhcp pool network Data

address low 172.16.1.11 high 172.16.1.100 255.255.255.0

default-router 172.16.1.6

option 156 hex 667470736572766572733d3137322e31362e322e372c20636f756e7472793d372c206c616e67756167653d342c206c617965723274616767696e673d312c20766c616e69643d32 description Shoretel

exit

ip dhcp pool network Voice

address low 172.16.2.11 high 172.16.2.100 255.255.255.0

default-router 172.16.2.6

option 156 hex 667470736572766572733d3137322e31362e322e372c20636f756e7472793d372c206c616e67756167653d342c206c617965723274616767696e673d312c20766c616e69643d32 description Shoretel

!

!

interface vlan 1

ip address 172.16.1.6 255.255.255.0

no ip address dhcp

!

interface vlan 2

name Voice

ip address 172.16.2.6 255.255.255.0

!

interface fastethernet1

switchport trunk allowed vlan add 2

!

interface fastethernet2

switchport trunk allowed vlan add 2

!

 

The same theory should apply to other custom options on Sx300 & Sx500 Series switches.

 

Hope it helps

 

Matt

 

This document was generated from the following discussion: Will a Cisco SMB SG300 Switch support DHCP Option 156?

Comments

Very good.  Thanks for sharing.

749
Views
5
Helpful
1
Comments