Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

How to set up Port Mirroring (SPAN) on the ESW 500 switch

Steps to setup Port mirroring on the ESW 500 switch

Comments
Cisco Employee

Great document Maulik,

The note about setting the SPAN receive port to smartports role "Other" saved me a bunch of time. I didn't understand the error messages that kept on popping up when attempting to configure SPAN. As soon as I changed the role to Other, my SPAN config worked and I was able to capture traces.

As you mention, once a port is assigned a role of Other, the port cannot be used for regular network traffic. If like me, readers use their computer to make this change to Other, they will immediately lose network connectivity and can no longer manage the switch.

I now use 2 ports on a 24-port ESW-540. Port 1 for Wireshark traces and port 13 which is directly below port 1, for normal use.

My computer is connected to port 13 for normal work and I setup everything for a trace, then move my computer's LAN cable to port 1 to start tracing. Once done, I move back to port 13.

Regards,

Patrick

-----------

New Member

Hello, even though this post is over 5 years old, it helped me today! However, when I tried to change my destination port, there was some other port 'stuck' in that field.

I changed the destination port properties on g19 to 'other'. I then deleted any existing span configuration, did a save, and when I tried to add dest port g19 the old span port was still there, and I was unable to modify. So I moved my laptop to port 22 and did a capture from there. (the "unmodifyable" existing destination port)

 

Any advice would be greatly appreciated. Thanks

Cat

Cisco Employee

Hi Cat,

Can you share with me your running config. You may use private message for this.

Regards,

Aleksandra

New Member

I'm not sure how to do that since the device is menu driven, or http only. No command line on this switch.

Cisco Employee

Hello,

Please download running configuration from the web interface. It is a txt file and looks pretty similar to IOS commands.

Aleksandra

 

New Member

Hi Aleksandra,

I was able to get only partial config from the switch. There were errors on trying to download the configuration, and the file kept coming thru same file size, only partial config. but here it is:

interface range ethernet g(11,13-14,16,18)
port storm-control broadcast enable
exit
interface ethernet g11
port storm-control broadcast rate 100000
exit
interface ethernet g13
port storm-control include-multicast
exit
interface ethernet g14
port storm-control include-multicast
exit
interface ethernet g16
port storm-control include-multicast
exit
interface ethernet g18
port storm-control broadcast rate 100000
exit
spanning-tree priority 0
interface ethernet g18
spanning-tree portfast
exit
interface ethernet g16
spanning-tree link-type point-to-point
exit
interface ethernet g18
spanning-tree bpduguard
exit
interface port-channel 1
description WLC
exit
interface ethernet g18
description Ihiji
exit
interface ethernet g18
port security mode max-addresses
exit
interface ethernet g18
port security discard trap 60
exit
interface port-channel 1
switchport mode trunk
exit
interface range ethernet g(11,16)
switchport mode trunk
exit
vlan database
vlan 10,15,20,25,30,35,40,45,50,55,60,65,70,75,80,100,501-505
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 10
exit
interface port-channel 1
switchport trunk allowed vlan add 10
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 15
exit
interface port-channel 1
switchport trunk allowed vlan add 15
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 20
exit
interface port-channel 1
switchport trunk allowed vlan add 20
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 25
exit
interface port-channel 1
switchport trunk allowed vlan add 25
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 30
exit
interface port-channel 1
switchport trunk allowed vlan add 30
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 35
exit
interface port-channel 1
switchport trunk allowed vlan add 35
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 40
exit
interface port-channel 1
switchport trunk allowed vlan add 40
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 45
exit
interface port-channel 1
switchport trunk allowed vlan add 45
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 50
exit
interface port-channel 1
switchport trunk allowed vlan add 50
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 55
exit
interface port-channel 1
switchport trunk allowed vlan add 55
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 60
exit
interface port-channel 1
switchport trunk allowed vlan add 60
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 65
exit
interface port-channel 1
switchport trunk allowed vlan add 65
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 70
exit
interface port-channel 1
switchport trunk allowed vlan add 70
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 75
exit
interface port-channel 1
switchport trunk allowed vlan add 75
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 80
exit
interface range ethernet g(13-15,17-18,20-21,23)
switchport access vlan 100
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 100
exit
interface port-channel 1
switchport trunk allowed vlan add 100
exit
interface range ethernet g(1-2)
switchport access vlan 501
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 501
exit
interface range ethernet g(3-4)
switchport access vlan 502
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 502
exit
interface port-channel 1
switchport trunk allowed vlan add 502
exit
interface range ethernet g(5-6)
switchport access vlan 503
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 503
exit
interface range ethernet g(7-8)
switchport access vlan 504
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 504
exit
interface range ethernet g(9-10)
switchport access vlan 505
exit
interface range ethernet g(11,16)
switchport trunk allowed vlan add 505
exit
interface vlan 60
name VM60
exit
interface vlan 65
name VM65
exit
interface vlan 70
name VM70
exit
interface vlan 80
name wired
exit
interface vlan 100
name Management
exit
interface range ethernet g(12,24)
channel-group 1 mode on
exit
interface ethernet g22
port monitor g18 rx
exit
interface vlan 100
ip address 192.168.100.3 255.255.255.0
exit
ip default-gateway 192.168.100.1
qos advanced
wrr-queue cos-map 4 0
wrr-queue cos-map 4 1
wrr-queue cos-map 3 2
wrr-queue cos-map 1 5
wrr-queue cos-map 2 6
wrr-queue cos-map 2 7
qos map dscp-queue 0 to 4
qos map dscp-queue 1 to 4
qos map dscp-queue 2 to 4
qos map dscp-queue 4 to 4
qos map dscp-queue 5 to 4
qos map dscp-queue 6 to 4
qos map dscp-queue 7 to 4
qos map dscp-queue 8 to 4
qos map dscp-queue 9 to 4
qos map dscp-queue 10 to 4
qos map dscp-queue 12 to 4
qos map dscp-queue 13 to 4
qos map dscp-queue 14 to 4
qos map dscp-queue 15 to 4
qos map dscp-queue 16 to 3
qos map dscp-queue 17 to 3
qos map dscp-queue 18 to 3
qos map dscp-queue 20 to 3
qos map dscp-queue 21 to 3
qos map dscp-queue 22 to 3
qos map dscp-queue 23 to 3
qos map dscp-queue 40 to 1
qos map dscp-queue 41 to 1
qos map dscp-queue 42 to 1
qos map dscp-queue 44 to 1
qos map dscp-queue 45 to 1
qos map dscp-queue 46 to 1
qos map dscp-queue 47 to 1
qos map dscp-queue 48 to 2
qos map dscp-queue 49 to 2
qos map dscp-queue 50 to 2
qos map dscp-queue 52 to 2
qos map dscp-queue 53 to 2
qos map dscp-queue 54 to 2
qos map dscp-queue 55 to 2
qos map dscp-queue 56 to 2
qos map dscp-queue 57 to 2
qos map dscp-queue 58 to 2
qos map dscp-queue 60 to 2
qos map dscp-queue 61 to 2
qos map dscp-queue 62 to 2
qos map dscp-queue 63 to 2
qos map policed-dscp 18 to 0
qos map policed-dscp 24 to 0
qos map policed-dscp 26 to 0
qos map policed-dscp 34 to 0
qos map policed-dscp 40 to 0
qos map policed-dscp 46 to 0
ip access-list 2140
permit any any any
exit
ip access-list 2141
permit any any any dscp 46
permit any any any dscp 40
exit
ip access-list 2142
permit any any any dscp 24
permit any any any dscp 26
exit
ip access-list 2146
permit any any any
exit
mac access-list nonip
permit any any ethtype 806
permit any any ethtype 836
exit
priority-queue out num-of-queues 0
class-map general-class match-any
match access-group 2140
exit
class-map general-switch
match access-group 2140
exit
class-map general-router
match access-group 2140
exit
class-map VoIP-data-class
match access-group 2141
exit
class-map VoIP-Control-class
match access-group 2142
exit
class-map general-VoIP
match access-group 2140
exit
class-map general-nonip
match access-group 2140
exit
class-map video-surveillance-class
match access-group 2146
exit
class-map nonip-class
match access-group nonip
exit
policy-map general-map
class general-class
set dscp 7
police 30000 80000 exceed-action policed-dscp-transmit
exit
exit
policy-map switch-map
class general-switch
trust cos-dscp
exit
exit
policy-map router-map
class general-router
trust cos-dscp
exit
exit
policy-map voice-map
class VoIP-data-class
set dscp 46
police 3200 8000 exceed-action policed-dscp-transmit
exit
class VoIP-Control-class
set dscp 26
police 640 8000 exceed-action policed-dscp-transmit
exit
class general-VoIP
set dscp 7
police 30000 800000 exceed-action policed-dscp-transmit
exit
exit
policy-map video-surveillance-map
class video-surveillance-class
set dscp 40
police 50000 800000 exceed-action policed-dscp-transmit
exit
exit
policy-map guest-map
class general-nonip
set dscp 8
police 30000 800000 exceed-action drop
exit
class nonip-class
exit
exit
wrr-queue bandwidth 10 10 35 45
interface ethernet g11
service-policy input router-map
traffic-shape queue 1 100000
exit
interface ethernet g16
service-policy input switch-map
traffic-shape queue 1 100000
exit
interface ethernet g18
service-policy input general-map
exit
hostname ESW-CORE
name *** password *** level 15 encrypted
snmp-server engineID local 80000009038cb64ffc3757
snmp-server location Mezzanine
snmp-server contact "my company"
snmp-server community *** ro 192.168.100.5 view Default
snmp-server host 192.168.100.5 ***** traps 2
clock timezone -8
clock summer-time recurring usa
banner login 
~~banner~~

snmp-server set rlSmartPortsTable ifIndex 1  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 2  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 3  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 4  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 5  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 6  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 7  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 8  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 9  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 10  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 11  rlSmartPortsMacro Router
snmp-server set rlSmartPortsTable ifIndex 12  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 13  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 14  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 15  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 16  rlSmartPortsMacro Switch
snmp-server set rlSmartPortsTable ifIndex 17  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 18  rlSmartPortsMacro Desktop
snmp-server set rlSmartPortsTable ifIndex 19  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 20  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 21  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 22  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 23  rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 24  rlSmartPortsMacro Other

 

Cisco Employee

Hello,

Thank you for the effort however there is nothing about port 19 which is the object of our discussion. What I would like to recommend you to delete all VLANs from the port 19, leave only VLAN 1 untagged and PVID untagged and try to make change. Near in mind port which is a SPAN port is excluded from network traffic so your PC on port 19 cannot be used to make those changes.

I hope it helps a bit :-)

Aleksandra

8163
Views
0
Helpful
7
Comments