Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

SPA112: Set Static IP (INTERNET PORT) 111: Invalid option

Device: SPA112

Firmware: 1.3.2

 

SPA112 accepts 101 to set internet addressing method from dynamic to static but does not change the actual value. 

 

Error message - Set Static IP (INTERNET PORT) 111: Invalid option.

 

Resolution Summary:

 

.         Step 1 : Press ****

 

.         Step 2 : Press 100 (Check the Internet addressing) Should be DHCP(0)

 

.         Step 3 : Press 101 (Set Internet Addressing Method) 

 

.         Step 4 : Enter Value 1 (Static)

 

.         Step 5 : Press 1 to save the value.

 

.         Step 6 : Keep the phone headset down and the SPA122 should reboot.

 

.         Step 7 : Once the SPA122 is back up, go back to the configuration menu (****) and press 100. (Should be changed to 1)

 

.         Step 8 : Verify  that the internet addressing is changed from DHCP to Static on the GUI

 

.         Step  9 : On the configuration menu press 111 and enter the IP Address statically.

 

.         Step 10 : Press 1 to save the value. 

 

.         Step 11 : Keep the phone down and let the SPA122 reboot.

 

.         Step 12 : Once rebooted check the IP address using the GUI and the IVR option 110 .

 

 

  • SPA112 needs time to reboot to reflect changes.
  • Generally we miss the Steps 6 & 11.
  • Also the SPA112 needs to be connected to a network router in order for the options to operate.
Comments
VIP Gold

As static IP address is set in steps 9-11 it's not so clear how to access the GUI (on which address) in step 10. But if you can access such GUI, then it's easier to reconfigure the SPA112 to static address using GUI instead of IVR.

New Member

Hello Dan

"it's easier to reconfigure the SPA112 to static address using GUI instead of IVR"

But how to using it when the IP still 0.0.0.0

 

I'm using SPA112

Error message still hear : INVALID OPTION

 

VIP Gold

You missed the condition "if you can access such GUI ..."

If can't use GUI and even IVR method doesn't work for you then DHCP is the best option to assign IP address (then use GUI to reconfigure device according your wishes, including STATIC IP if requested).

 

New Member

YEACHHHHH

 

Nice Info , thanks so much 4 u, its work,

1. Connect Directly from Eth my laptop with DHCP ( didn't work )

2. Connect Using Wireless VODAFONE HG553 ( SET IP DHCP ) than connect cable to SPA112 ( ITS WORK )

3. Change IP SPA112 to STATIC than ABACADBRA  reply ....

 

Thankyou DAN

VIP Gold

Glad to hear it helped.

Rate useful advices and/or mark them as "correct answer". It will help others to found solution.

Connect Directly from Eth my laptop with DHCP ( didn't work )

It's no longer important, but did you used cross-wired cable for such kind of connection ? Casual straight Ethernet cable will not work here.

 

New Member

So, it sounds like the SPA 112 has to be connected to a DHCP server initially?  Otherwise it won't work at all?  There's no way to just open the box, plug in a phone, and set a static IP?

VIP Gold

just open the box, plug in a phone, and set a static IP?

It works for me this way. Well, on ATA device with latest firmware.

Never tried on device with an ancient firmware like 1.0.2 or so. It may or may not work. Device with such firmware is not suitable for production deployment at all.

 

New Member

Hello everyone, 

I've been through the same problem few days ago and fell on this topic that really helped me understanding this particular configuration.  I got the same message when i tried to configure through SPA112:

 Error message : INVALID OPTION

I did same as renakuramadani but little bit different, i.e

1. connect the SPA122 and pc through a switch (don't have a crossover cable!) 

2. configure the ATA with DHCP through SPA112

3. Install TFTPD V 4.5 on pc and use it as DHCP server to assign an IP address to the ATA. 

4. Connect to the ATA through web interface with the new IP address and it's done! 

New Member

This problem has resurfaced for me, for the second time now.

First time was with firmware V1.0.2.  After a fair bit of messing about and figuring out what to do in what sequence, I configured static IP addressing on the ATA via the phone.  This needed about four ATA reboots, but worked.  Then I could connect with a browser and do the rest more easily.

After that, I upgraded to 1.3.5p and reset to factory defaults.  Now, on the latest firmware, what I did before doesn't work, and in fact nothing I have tried allows me to set up my static IP parameters.  I spent a whole evening on it without success.

All I can now do is change the Primary DNS from 1.1.1.1 to a value I choose.  Option 101 doesn't work: the parameter value of 1 is accepted, to select static IP addressing, but doesn't actually save to flash memory.  When I hang up, the ATA doesn't reboot.  If I force it to reboot using the REBOOT code, it hangs after reboot and is inaccessible either via network or by phone (then a factory reset is needed).  Of course, the other static IP address values are all rejected until the Option 101 parameter has been properly set, so this is a show stopper.

It seems to me that setting up static IP addressing by phone using the latest firmware release just hasn't been tested by the developers.  I've no doubt that the default (DHCP) still works, and that's what I'll have to set up (at some inconvenience to myself) to get my ATA configured.  But why should I have to do this?

I think there is scope for improvement in the way static IP addressing is set up by phone.  With firmware V1.0.2, setting this up was a frustrating experience, but at least it worked.  Now it seems completely broken.

4866
Views
5
Helpful
9
Comments