Cisco Support Community
Community Member

ARP reply problem on my ESW520-8P-K9


I've started having problems with one of my ESW520-8P-K9 recently. I can't access its web interface anymore. I've done a factory reset on it but it is still the same.

After doing some tests trying to pinpoint the problem, I've find out that when trying to access the switch web interface from my web browser, the ARP reply that were sent by the switch were quite weird:


10:16:33.226002 90:fb:a6:47:eb:bd > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 42: Ethernet (len 6), IPv4 (len 4), Request who-has tell, length 28

10:16:33.227671 55:75:d1:6e:3a:6a > 91:fb:a6:47:ef:bf, ethertype ARP (0x0806), length 60: Ethernet (len 6), IPv4 (len 4), Reply is-at 54:75:d1:6e:3a:6a, length 46


If you look carefully at the MAC addresses in the ethernet part of the ARP reply and request, you see that the switch doesn't reply to my machine's MAC address (which is "90:fb:a6:47:eb:bd") but is instead replying to "91:fb:a6:47:ef:bf" (which does not exist). You also see that the source MAC address of the reply (i.e. "55:75:d1:6e:3a:6a") is different from the MAC address written on the switch's label (i.e. "54:75:d0:6a:3a:6a") and the MAC address that is inside the ARP reply. I've tried by plugging the network cable on other port, still the same.

Except from this important problem (!), the switch seems to work correctly. The other ESW520 I have on my network works fine. Someone has any idea why would this happens ? Is the hardware failing ? Should I return the switch ?

CreatePlease to create content