Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AUTOSMARTPORT-F-DEV_CALC_FAILED

Hello,

The company I work for has some Cisco hardware in the plant and, as our team has no expertise on configuring Cisco switches I hope you can help me and my team to get this problem solved. I will make a brief comment on what is going wrong here:

I own two SG300-28 and they are connected using LAG over 2 interfaces (GI27 and GI28) but this is not the problem, I think, just the scenario. So I have two sides:

CSC <--- LAG ---> TOO

At CSC I have no problem and the switch is running fine for 38 days (we had a hard reboot back there).

On the other hand, at TOO, we are facing a soft reboot problem and we are not able to fix it. The only message we got, just before the reboot is:

2147476226          2013-Dec-09 06:20:05          Emergency           %AUTOSMARTPORT-F-DEV_CALC_FAILED: XDP device type calculation failed: interface gi21 - capability 2 ***** FATAL ERROR *****  Reporting Task: NCDP. Software  Version: 1.3.5.58 (date  10-Oct-2013 time  17:15:41) 0x16adbc 0x166f28 0x6df2b0 0x48fad8 0x4903e8 0x490608 0x6e8490 0x6e8528 0x6e8d90 0x82eb24 0x831 7b8 0x837a88 0x1223f0 ***** END OF FATAL ERROR *****

After reboot:


2147483510          2013-Dec-09 06:26:29          Warning           %CDP-W-NATIVE_VLAN_MISMATCH: Native VLAN mismatch detected on interface gi21.

And the switch reboots. This is causing us a lot of problems. As an emergency exit (and it's not fully working) we disabled AutoSmartPort (which is a functionality we will never use in the network layout so we don't need it).

Is there anything you can tell me to do? I am attaching running config for TOO. Befero someone ask we already tried to change the hardware (we own a spare SG300) and the same problem is there.

Best regards,

Nataniel Klug

Everyone's tags (3)
1 REPLY
New Member

AUTOSMARTPORT-F-DEV_CALC_FAILED

It's on another post, sorry for this duplicate post:

https://supportforums.cisco.com/message/4112232#4112232

282
Views
0
Helpful
1
Replies
CreatePlease login to create content