Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco SG200-26 (1.3.5.58)

I have a problem.

Here is some lines from config:

default-vlan vlan 2

interface vlan 1

no ipv6 dhcp client stateless

!

interface vlan 2

name Management

ip address 10.0.4.103 255.255.252.0

no ip address dhcp

ipv6 address autoconfig

ipv6 dhcp client stateless

!

interface vlan 100

name Administrators

!

interface vlan 101

name Users

!

interface gigabitethernet1

switchport mode access

!

interface gigabitethernet2

switchport mode access

switchport access vlan 100

!

...

access vlan 100

...

!

interface gigabitethernet23

switchport mode access

switchport access vlan 100

!

interface gigabitethernet24

switchport mode access

switchport access vlan 101

!

interface gigabitethernet25

switchport trunk allowed vlan add 100-101,201-202

!

interface gigabitethernet26

switchport trunk allowed vlan add 100-101,201-202

!

exit

ip default-gateway 10.0.4.1

But switch cannot ping 10.0.4.1. And all devices from vlan2 cannot ping it too, but when I connect to gi1, I can ping switch and cannot ping another devices in vlan 2. If I connect to gi24 and try to ping any device from vlan2 it will works (for testing I've turn on data forwarding between vlan101 and 2).

When I change default vlan to 1 and binds gi2 (access port) to vlan2, and added vlan2 to trunk ports (gi25,gi26)  it will works! And I can ping any devices from vlan2.

I think I've found bug in firmware.

2 REPLIES
Green

Cisco SG200-26 (1.3.5.58)

Hi Roman, this switch is a layer 2 device meaning it cannot and will not route IP connectivity. This would be decided by your router.

So if you connect Host A to VLAN 1 that Host A will only communicate to device in the VLAN 1 so long as it follows a correct IP schema. Conversely if you connect Host B in to VLAN 2, Host B will only communicate to devices in VLAN 2 that follow the same IP schema. Host A and Host B will never communicate to each other due to different VLAN and different IP subnet.

To make these VLAN communicate, your router device must support either the VLAN trunk carrying both VLAN to send response back OR a static route to forward the request to the "unknown subnet".

Lastly, there is port based VLAN. Essentially this means assign a host to a specific untagged VLAN then make trunk links with multiple untagged members. This will permit intervlan communication as well.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Cisco SG200-26 (1.3.5.58)

Thanks for answer. I've solve my problem. As someone say: "The devil is in the details".

!

interface gigabitethernet25

switchport trunk allowed vlan add 100,201-202

switchport default-vlan tagged

!

After that my switch stay available from vlan2.

332
Views
0
Helpful
2
Replies
CreatePlease to create content