Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connecting 886va <-> sg200-08p via access ports: Port Type Mismatch

Hi.

We recently bought a SG200-08P to replace our older switch.

After a hassle to configure / clone our configurations (e.g. defining a different Vlan than Vlan1 as the management Vlan without "losing" a precious port ;)) via GUI, we were finally able to switch the switches.

However, I ran in a problem in connecting a 886VA Router to the SG200-08P Switch:

I want vlan 105 on the Router to receive an IP Address via an existing DHCP-Server in vlan105 that's trunked through a port at the SG200-08P (g8).

Fa0 <-> g5 - Both are configured as Access Ports and the SG200-08P still seems to be in trunking mode?

I keep receiving the following messages on the Router:

%SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0 VLAN105.

%SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0 on VLAN105. Inconsistent port type.

See also:

VLAN105 is executing the ieee compatible Spanning Tree protocol

  Bridge Identifier has priority 65535, address X

  Configured hello time 2, max age 20, forward delay 15

  We are the root of the spanning tree

  Topology change flag not set, detected flag not set

  Number of topology changes 0 last change occurred 00:01:43 ago

  Times:  hold 1, topology change 35, notification 2

          hello 2, max age 20, forward delay 15

  Timers: hello 1, topology change 0, notification 0, aging 300

Port 1 (FastEthernet0) of VLAN105 is broken (Port Type Mismatch)

   Port path cost 19, Port priority 128, Port Identifier 128.1.

   Designated root has priority 65535, address X

   Designated bridge has priority 65535, addressX

   Designated port id is 128.1, designated path cost 0

   Timers: message age 3, forward delay 14, hold 0

   Number of transitions to forwarding state: 0

   BPDU: sent 51, received 0

Is it safe to say, that this is a problem with the SG200-08P?

If configured as trunking ports, vlan105 receives an IP Address - but that isn't what I am looking for. I need fa0 to be an access port.

Relevant configurations of the 886VA and 200SG-08P are pasted below.

Lots of thanks in advance!

Greets,

Patrick

886VA:

spanning-tree vlan 105 priority 65535

interface FastEthernet0

switchport access vlan 105

no ip address

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

interface Vlan105

ip address dhcp

###

FastEthernet0 is up, line protocol is up

  Hardware is Fast Ethernet, address is X (X)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 3000 bits/sec, 3 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     38458 packets input, 3527192 bytes, 0 no buffer

     Received 28616 broadcasts (9782 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     4414 packets output, 341492 bytes, 0 underruns

     0 output errors, 0 collisions, 13 interface resets

     50 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     5 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

##########################################

SG200-08P (backup configuration):

interface g5

spanning-tree edgeport

no spanning-tree auto-edge

no spanning-tree port mode

switchport mode access

switchport access vlan 105

exit

Everyone's tags (7)
1 REPLY
Bronze

Connecting 886va <-> sg200-08p via access ports: Port Type Misma

Dear Patrick,

Thank you for reaching the Small Business Support Community.

I see nothing wrong with the actual configurations, there should not be any Port Type Mismatch in my opinion and I am afraid I have nothing to suggest you but to contact the Small Business Support Center directly and have a TAC engineer figure this out with you;

https://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

Please do not hesitate to reach me back if there is anything I may assist you with in the meantime.

Kind regards,

Jeffrey Rodriguez S. .:|:.:|:.
Cisco Customer Support Engineer

*Please rate the Post so other will know when an answer has been found.

Jeffrey Rodriguez S. .:|:.:|:. Cisco Customer Support Engineer *Please rate the Post so other will know when an answer has been found.
818
Views
0
Helpful
1
Replies
CreatePlease login to create content