Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connectivity issues between Cisco 2901 and Cisco SG300-52

Hello,

I am having some serious connectivity issues between the hosts in my LAN.

My LAN is based on a Cisco 2901 router and a Cisco SG300-52 port switch.

The issue that has been happening is that connections between hosts on the LAN (remote desktop, extended ping, etc) is very unstable, at some point I can see a 35% lost packets on an extended ping. This happens at any time of the day and from any host.

All hosts are on the same Vlan(default Vlan) and on the same subnet. Some hosts have fixed IP addresses (servers and network equipment) and others obtain their IP address trough a DHCP reservation  established on the router (reserved with the MAC address of every host).

I can provide further details if needed, because this issue is very serious and I would really appreciate any insight or support.

 

Many thanks in advanced.

Sair Amer

 

EDIT:  After doing every test we could think of, we finally found the reason behind this problem.

 

It turns out that the switch has problems handling communications between clients at different speeds, because most of the hosts connected were working at 100 Mbps but the servers were working at 1000 Mbps (and the communication between host and servers wasn't stable).

 

After manually setting the speed on all ports to 100 Mbps the problems have stopped.

 

Many thanks for you help on this issue. 

Everyone's tags (3)
8 REPLIES

Do you see loss of pings if

Do you see loss of pings if you ping from 2901 to your switch IP address? Check logs and see if any errors are there.

New Member

Hi Michael, Thanks for your

Hi Michael,

 

Thanks for your quick reply.

 

There is some ping loss if I ping from the router to the switch. However the loss percentage is a lot smaller  that if I ping between hosts in the network.

I reviewed the error logs, and there are no errors in the router's log.

On the switch I found some errors but only in the flash memory error log, the message is the following:

%CDB-E-VARNOTSUPPORTED

This error is repeated many times with different values of the MIB variable.

What do you think this could mean?

I should also mention that I tried to update the firmware of the switch via HTTP but I got the following error:

illegal software format.

I tried to update the boot loader first but gave the same error mentioned above.

 

Many thanks in advanced for your input.

Sair Amer

 

Were you having issues before

Were you having issues before trying to upgrade? It may be best to contact Cisco Small Business Support. Whatever is generating those log messages could be overloading that switch causing dropped packets. Do you have another switch you could test with?  

http://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html

New Member

Michael, This issue has been

Michael,

 

This issue has been going on before the attempt to upgrade the firmware.

 

I have tried to contact Cisco support but their telephone number does not work(I am currently in Chile) and their live chat also does not work.

I tested with another switch (non-cisco) and the error continues.

Do you have any suggestions on how to test if the router is the faulty equipment? (I do not have any other cisco router, only a small household type router).

 

Thanks again for your help.

Sair Amer

 

Post your running

Post your running configuration and I will take a look. If it is some sort of hardware issue on the router your best bet is calling TAC.

New Member

Building configuration...

Building configuration...

 

Current configuration : 4123 bytes

!

! Last configuration change at 12:06:16 PCTime Sat Jul 19 2014 by ccp

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Foninsa

!

boot-start-marker

boot-end-marker

!

!

no logging buffered

enable secret 5 $1$BDbJ$HN3VP8nmywrGB55RCxPd30

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local 

!         

!

!

!

!

aaa session-id common

clock timezone PCTime -4 0

clock summer-time PCTime date Apr 6 2003 2:00 Oct 12 2003 12:00

!

no ip cef

!

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.10

ip dhcp excluded-address 192.168.1.151 192.168.1.255

!

ip dhcp pool FONINSA

 network 192.168.1.0 255.255.255.0

 default-router 192.168.1.1 

 dns-server 8.8.8.8 8.8.4.4 

!

ip dhcp pool Laptop-Sporta-Wifi

 host 192.168.1.10 255.255.255.0

!         

!

!

ip name-server 8.8.8.8

ip name-server 8.8.4.4

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

crypto pki trustpoint TP-self-signed-213585710

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-213585710

 revocation-check none

 rsakeypair TP-self-signed-213585710

!

!

crypto pki certificate chain TP-self-signed-213585710

 certificate self-signed 01

  30820229 30820192

  quit

license udi pid CISCO2901/K9 sn

license boot module c2900 technology-package securityk9

!

!

username ccp privilege 15 password

!

redundancy

!         

!

!

!

!

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

 no ip address

 shutdown

!

interface GigabitEthernet0/0

 ip address 190.196.21.98 255.255.255.248

 ip nat outside

 ip virtual-reassembly in

 duplex auto

 speed auto

!

interface GigabitEthernet0/1

 ip address 192.168.1.1 255.255.255.0

 ip nat inside

 ip virtual-reassembly in

 duplex auto

 speed auto

!

no ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

!

ip nat inside source list 1 interface GigabitEthernet0/0 overload

ip nat inside source static tcp 192.168.1.3 21 190.196.21.98 21 extendable

ip nat inside source static tcp 192.168.1.3 80 190.196.21.98 80 extendable

ip nat inside source static udp 192.168.1.8 1194 190.196.21.98 1194 extendable

ip nat inside source static tcp 192.168.1.4 3389 190.196.21.98 3389 extendable

ip nat inside source static tcp 192.168.1.9 3389 190.196.21.98 10000 extendable

ip nat inside source static tcp 192.168.1.3 3389 190.196.21.98 20000 extendable

ip route 0.0.0.0 0.0.0.0 190.196.21.97

!         

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

!

!

!

control-plane

!

!

!

line con 0

 password $

line aux 0

line 2

 no activation-character

 no exec

 transport preferred none

 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

 stopbits 1

line vty 0 5

 access-class 23 in

 privilege level 15

 password #

 transport input telnet ssh

!

no scheduler allocate

!

end

I don't see anything jumping

I don't see anything jumping out. You may try upgrading the IOS and see if that helps. If you have the ability I would open a TAC case.

Silver

Hi SairHave you done basic

Hi Sair


Have you done basic troubleshooting?
1. Check speed duplex
       -on router do "show interfaces <port>" in the SG, navigate throug GUI and change that port
       -Make sure devices are in their optimal setting, ex: 100Mbps/Full-Duplex

If speed and duplex are different try hardcoding it


2. Check the cable

       -The problem might be in the cable, try replacing it

3. If issue still persist, 
      -Try allocating another port on the switch to the router

 

213
Views
0
Helpful
8
Replies
CreatePlease login to create content