Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ESW-500 & SPA525G CDP issue

Hi, I have an ESW-500, a SPA525G (also tried 504G), Polycom IP330/670 phones, and a Switchvox (Asterisk-based IP-PBX) and CDP causes some issues.

Both the SPA5xx and Polycom phones support CDP but it appears to operate differently between the phones. And, surprisingly, worst of all on the SPA's.

In short:

* Switch - CDP enabled (VLAN 100), DHCP disabled (Option 82 enabled) which is basically how it comes out of the box

* Polycom phones - CDP enabled (default)

* Cisco phones - CDP enabled (default)

* DHCP/TFTP server on port 1

* Phones on ports 7,15,19 - default as smartports for Desktop & Phone

* Switchvox on port 17 - port configured as General (not Trunk) with 1U & 100U VLANs. This was required to get Polycom phones to appear in Switchvox config

With that configuration the Polycom phones work perfectly. They appear in the switch web-GUI under CDP, they present in Switchvox and can be configured.

But with that configuration although the Cisco phones appear in the CDP screen they do not get DHCP. My DHCP server can see 'DHCP Discover' messages but it just goes around in circles. Disabling CDP on the switch will allow the phone to get an IP but disabling CDP on the phone still has the same problem. When I saw "around in circles" this is what I mean....

Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:25:84:06:12:46 [10/08 13:51:27.031]
DHCP: proposed address 192.168.100.16 [10/08 13:51:29.000]
4064 Request 2 not processed [10/08 13:51:29.062]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:25:84:06:12:46 [10/08 13:51:30.093]
DHCP: proposed address 192.168.100.16 [10/08 13:51:31.593]
4064 Request 2 not processed [10/08 13:51:31.656]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:25:84:06:12:46 [10/08 13:51:56.125]
DHCP: proposed address 192.168.100.16 [10/08 13:51:58.000]
4064 Request 2 not processed [10/08 13:51:58.062]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:25:84:06:12:46 [10/08 13:51:58.171]
DHCP: proposed address 192.168.100.16 [10/08 13:51:59.671]
4064 Request 2 not processed [10/08 13:51:59.734]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:25:84:06:12:46 [10/08 13:52:01.234]
DHCP: proposed address 192.168.100.16 [10/08 13:52:02.734]
4064 Request 2 not processed [10/08 13:52:02.796]

Polycom phones show the following....

Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:04:F2:1E:9E:DE [10/08 13:54:54.656]
DHCP: proposed address 192.168.100.12 [10/08 13:54:57.000]
4064 Request 2 not processed [10/08 13:54:57.062]
Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:04:F2:1E:9E:DE [10/08 13:54:58.000]
Previously allocated address 192.168.100.12 acked [10/08 13:54:59.500]
4064 Request 2 not processed [10/08 13:54:59.562]
Rcvd DHCP inform Msg for IP 192.168.100.12, Mac 00:04:F2:1E:9E:DE [10/08 13:55:00.000]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:04:F2:1E:9E:DE [10/08 13:55:22.187]
DHCP: proposed address 192.168.100.12 [10/08 13:55:23.687]
4064 Request 2 not processed [10/08 13:55:23.750]
Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:04:F2:1E:9E:DE [10/08 13:55:24.687]
Previously allocated address 192.168.100.12 acked [10/08 13:55:26.187]
4064 Request 2 not processed [10/08 13:55:26.250]
Rcvd DHCP inform Msg for IP 192.168.100.12, Mac 00:04:F2:1E:9E:DE [10/08 13:55:26.687]

With the difference being there's a 'DHCP Inform Msg' which there never is from the Cisco.

I have tried many options regarding DHCP Relay, DHCP Server addresses, DHCP VLAN Interfaces, smartport settings etc but with CDP enabled the Cisco phone just will not get DHCP.

Any ideas why not?

2 REPLIES
Community Member

Re: ESW-500 & SPA525G CDP issue

This describes my situation as well.

My polycom phones will not get DHCP.

Even weirder, with just an ESW switch even plugged into a port on one of my unmanaged 3com switches causes the Polycoms I have to not get and IP via DHCP, and they go into a reboot loop.

Did you find a solution?

We are currently using a switchvox as well, but its outside our firewall. 

We are switching to the UC560 soon.

Thanks!

Ben

Community Member

ESW-500 & SPA525G CDP issue

Yes, You will run into this problem due to CDP.

Easier way to fix this is to Turn off CDP in ESW 500.

Go into Cisco ESW 500 (While SPA Phone is not connected)

On the left side:

Monitor & Device Properties

SNMP and Than CDP

You will notice CDP (Cisco Discovery Protocol) is enable and routing all Voice Traffic to VLAN 100

You can turn off CDP and your SPA will start working with ESW 500.

Or

You will need to properly configure and route the VLAN traffic.

1133
Views
0
Helpful
2
Replies
CreatePlease to create content