Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ESW-520-24p not able to connect to a Catalyst 3560G + compatible with SPA942?

Hi all,

a customer purchased a ESW-520-24p to be used in a VoIP project. Today we had difficulties connecting it to a Catalyst 3650G switch; We've tried setting the port to trunk, general, customer and access and changed all sorts of VLAN settings on the 3560G switch to no avail: the switches just wont interconnect. While sniffing we saw that ARP requests are even not answered, so something is wrong on a low level, probably with VLAN-ing.

Anyone any idea if these switches should be able to be interconnected and if yes, what needs to be done to do so?

Secondly; voice will be on seperate VLAN and the client will use SPA942 phones, which have an internal switch that allows to connect a PC to it. I've used this phoned successfully with Catalyst Express switches and I didn't have to do anything for VLAN-ing, this worked "out of the box". Can anyone confirm that these phones work with the Small Business switches as well?

Thx!!

Bart

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ESW-520-24p not able to connect to a Catalyst 3560G + compat

Hi Bart,

I quickly set up the simulation.  It took me longer to write this than actually do the work.

I grabbed  my handy Cisco 3560 catalyst switch.  I plugged FastEthernet  port 23 plugged into my UC520.  My Uc520 is my voice system and DHCP server.

I have FastEthernet port 24 plugged  from my Cisco 3560  into my ESW540-24P.  On port 3 of my ESW540-24P  switch I plugged a SPA962 phone..

I guess my simulation is close enough to your hardware.  Configuration should be identical I would guess.

Here is the configuration of my Cisco 3560 switch;

interface FastEthernet0/23

switchport trunk encapsulation dot1q

switchport autostate exclude

switchport mode trunk

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport autostate exclude

switchport mode trunk


interface Vlan1

ip address 192.168.10.3 255.255.255.0

!

interface Vlan100     (VLAN100 is terminated on my UC520 and has the DHCP scope)

no ip address

!

interface Vlan200

no ip address

!

Check that spanning tree isn't blocking any uplink ports with the command show spanning-tree. I ask you to try this as i must admit that that uplink to my UC520 was in a BLK state on the default VLAN.  THIS I HAD TO FIX .

I plugged my SPA962 phone onto my ESW switch, it powered up.

Since VLAN 100 is my voice VLAN, I had to manually adjusted what VLAN the SPA phone will reside in.  Otherwise it will try to pick up a IP address from the default VLAN.

  • On the SPA phone I manually pressing the setting key (underneath the envelope button)
  • Scroll down and selected  'Network'
  • Scroll down again  to the VLAN option  and select  edit.
  • I altered the setting  to select Enable VLAN  Yes.
  • Select the OK button.
  • I then scrolled down to the VLAN ID option.
  • Selected  the edit softkey to edit the VLAN ID information.
  • I inputed 100 in  and selected OK.

My phone received a IP address from my VLAN 100 a 10.1.1.X address.

Luckily the ESW520  has a pretty good GUI , whereby you can add a new vlan and trunk it to all ports.

Here is an example of how I added vlan 200 to the ESW switch and started to add the switch ports as Tagged ports.  I have to do this to all ports where you need the VLAN.

I then as seen below add my new VLAN as a Tagged port to all switch ports.

You can see from my screen shot below that I was adding VLAN 200 to interface G2  as a tagged interface.

REMEMBER TO SAVE YOUR CONFIGURATIONS ON BOTH THE 3560 and the ESW520

hope this helps

regards Dave

4 REPLIES

Re: ESW-520-24p not able to connect to a Catalyst 3560G + compat

Hi Bart,

I quickly set up the simulation.  It took me longer to write this than actually do the work.

I grabbed  my handy Cisco 3560 catalyst switch.  I plugged FastEthernet  port 23 plugged into my UC520.  My Uc520 is my voice system and DHCP server.

I have FastEthernet port 24 plugged  from my Cisco 3560  into my ESW540-24P.  On port 3 of my ESW540-24P  switch I plugged a SPA962 phone..

I guess my simulation is close enough to your hardware.  Configuration should be identical I would guess.

Here is the configuration of my Cisco 3560 switch;

interface FastEthernet0/23

switchport trunk encapsulation dot1q

switchport autostate exclude

switchport mode trunk

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport autostate exclude

switchport mode trunk


interface Vlan1

ip address 192.168.10.3 255.255.255.0

!

interface Vlan100     (VLAN100 is terminated on my UC520 and has the DHCP scope)

no ip address

!

interface Vlan200

no ip address

!

Check that spanning tree isn't blocking any uplink ports with the command show spanning-tree. I ask you to try this as i must admit that that uplink to my UC520 was in a BLK state on the default VLAN.  THIS I HAD TO FIX .

I plugged my SPA962 phone onto my ESW switch, it powered up.

Since VLAN 100 is my voice VLAN, I had to manually adjusted what VLAN the SPA phone will reside in.  Otherwise it will try to pick up a IP address from the default VLAN.

  • On the SPA phone I manually pressing the setting key (underneath the envelope button)
  • Scroll down and selected  'Network'
  • Scroll down again  to the VLAN option  and select  edit.
  • I altered the setting  to select Enable VLAN  Yes.
  • Select the OK button.
  • I then scrolled down to the VLAN ID option.
  • Selected  the edit softkey to edit the VLAN ID information.
  • I inputed 100 in  and selected OK.

My phone received a IP address from my VLAN 100 a 10.1.1.X address.

Luckily the ESW520  has a pretty good GUI , whereby you can add a new vlan and trunk it to all ports.

Here is an example of how I added vlan 200 to the ESW switch and started to add the switch ports as Tagged ports.  I have to do this to all ports where you need the VLAN.

I then as seen below add my new VLAN as a Tagged port to all switch ports.

You can see from my screen shot below that I was adding VLAN 200 to interface G2  as a tagged interface.

REMEMBER TO SAVE YOUR CONFIGURATIONS ON BOTH THE 3560 and the ESW520

hope this helps

regards Dave

New Member

Re: ESW-520-24p not able to connect to a Catalyst 3560G + compat

David,

awesome thx!

While applying your solution I noticed that the data network on the 3560 was configured by someone else to be located on VLAN 10, instead of VLAN 1 (which was in my head). After adjusting that and adding this VLAN to the trunk ports, things were all right.

Thx again for your efforts!!!

B.

Re: ESW-520-24p not able to connect to a Catalyst 3560G + compat

Hi B.

Pleasure.  .Glad my posting acted to get you thinking about what you were seeing on the Cisco 3560.

regards Dave

New Member

ESW-520-24p not able to connect to a Catalyst 3560G + compatible

Hello David,

I'm wanting to have port "g12" on my ESW-520 to be a trunk port, on which need to have VLANs 1, 2 and 100 flowing through it.

First of all, a question besides this: how do I remotely check (GUI or CLI) if that port is not connected?

Then, back to my quest...

The VLANs are already setup.

I went to "Port to VLAN" and went through every VLAN ID, editing g12 interface and selecting "Tagged" for each VLAN.

Then I went to "VLAN to Port" and I saw that g12 already was defined as "Trunk" and when clicking on the drop-down list I was seeing 1U-2T-100T...

Should this be sufficient?

Thanks and kind regards,

F.

3173
Views
0
Helpful
4
Replies