Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Faulty firmware on newer SRW2048

Hi,I have huge problems with webinterface and general stability with the following switch:Model Name    SRW2048Hardware Version     00.03.00Boot Version Version     1.2.1I have tried to contact linksys but that footballed me to cisco.So I am asking here...First problem:when you try to access the swtich in FF web interface does not work, as far as I can see you cannot configure VLAN via console.It barely works with konqueror (amasingly) so I could just pull the hardware info out of it to put it here. I am yet to try Opera.Our environment is Windows-less. But we found a MS machine wich leads to second problem:If the switch is accessed via IE8 it, and we try to configure VLAN it would go into endless cycle of crashes.The stability of web interface is another issue:it will stop working (even IP not pinging) after certain time (couple of days to a week).We have 4 of these swithches configured to different IP address.Another point is that we have an "older" SRW2048, which amasingly works fine with Firefox (or any other real browser), also it is stable and does not crash.The good switch in question is the following:Model Name     SRW2048 , 48-Port 10/100/1000 Gigabit Switch with WebView System Object ID Hardware Version     00.03.10 Software Version Your feed back is appreciated.Thanks.Sergei.P.S. the forum is barely functional when trying to post from Firefox (editor is useless, I had to compose this externally and paste it).
Everyone's tags (1)
New Member

Re: Faulty firmware on newer SRW2048

I am sorry for lack of new lines, but it seems this editor is windows only.I have tried in konqueror and opera and in both I can't even edit my post.This is beyond hysterically funny, this forum is as functional as switches :D
New Member

Re: Faulty firmware on newer SRW2048


       I just checked and there is a newer firmware version, 1.2.2 available.  Your post said you were on 1.2.1.  I would upgrade to the newer firmware and see if the upgrade solves the issues.


New Member

Re: Faulty firmware on newer SRW2048


thank you for fast reply, I have seen that firmware, but I am affraid to apply it as I could not find the changelog, and what exactly has been fixed, as I don't want to break it further more, and reverting back to original is difficult.

I also found reports that firmware still does not function properly :  .

Where can I find the changelog for that firmware (1.2.2)?

I am very cautious with cisco and firmware.

New Member

Re: Faulty firmware on newer SRW2048

SRW2048 Firmware Revision History
Software version 1.2.2 01/01/2007
Boot version 08/09/2005
Known Issues
1. ACL --> MAC Based ACL
Creating a MAC ACL with to permit ethertype 0800 causes all traffic to be forwarded. Configuring a MAC ACL to permit ethertype 86DD causes all traffic to be denied.
Recommended Workaround: To avoid these situations, add a rule to deny any any.
2. Admin --> Cable Test
When testing cable with advanced test only (without simple test before), the results are incorrect.
3. QoS --> Advanced Mode
When configuring a policy with police - exceeded action - out of profile dscp, the policy must have an action: trust cos-dscp or set dscp. If you configure a policy with police - exceeded action - out of profile dscp without an action - the device configures the action to trust cos-dscp. If you configure a policy with police - exceeded action - out of profile dscp with an action set cos/queue, the device configures the action to set dscp 0.
4. Setup --> Time
The prioritization between servers is not maintained when two servers are configured simultaneously.
5. SNMP --> Group Membership
It is not possible to modify the user name after it has been entered.
Recommended Workaround: Delete the user and reconfigure.
6. VLAN Management
When a port is a member of Dynamic VLANs and Static VLANs, there may be errors in configuration using the Join VLAN pop up.
Recommended Workaround: Use the Ports to VLAN screen to join ports to VLANs.
7. Timestamps
(a) The order of the month and day in the dates presented in syslog messages is the European fromat (dd/mm/yy), and not the US format.
(b) SNMP traps are sent with a timestamp different from the actual time on the device, since the timestamp depends on the NMS configuration. The sequence is preserved.
8. HTTP port configuration
It is possible to modify the HTTP port to an already used port (e.g., 443). No error message is generated at this point.
9. Illegal characters in web inteface
Use of the following characters should be avoided when configuring using the web based interface: \ / : * ? < > |
10. Menu CLI
(a) Disable Active Management Access Profile - this software version does not support Management ACL, so this option is irrelevant to the user. It is reserved for future use.
"disable active mgmt access profile" is not working in menu console
(b) One cannot change the "admin" password in the Web GUI, but through menu CLI it is available.
GUI doesn't work only if there is only one user "Admin"
If you change the username to Admin1 or anything else, it works.
If you have another user name or names in addition to Admin, then it works too.

Hope this helps.