Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Getting disconnected when adding a VLAN interface

Hi,

I am trying to configure an SF302-08MP switch in a test environment with a couple of VLANs. From a default state I have configured the unit to be in L3 mode, added a VLAN then added an IP interface for that VLAN. The problem I have is that as soon as I add the IP interface for the VLAN I create I immediately lose connection to the switch and either have to reconfigure the interface via the CLI or reboot the unit to lose my changes.

I realise I can configure the box via the CLI to regain my connection and complete the configuration for my VLANs, but I'm trying to get a good process down for configuring these all via the web interface (apart from the initial L3 mode setup of course).

For this I am connecting to the default IP address on VLAN 1 (192.168.1.254). The steps taken are as follows:

1. Access the CLI and set L3 mode

2. Reboot

3. Access the switch via a web browser on 192.168.1.254 and login

4. Add VLAN 2 (VLAN Management / Create VLAN)

5. Add the IP Interface (IP Configuration / IPv4 Interface, selecting VLAN2 when completing the add interface dialog)

6. Lose connection to 192.168.1.254 when you click Apply

I've done this on other 300 series switches in the past in the same way with no issue but for some reason this 8 port switch is giving me problems.

Any advice would be much appreciated.

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Getting disconnected when adding a VLAN interface

Hello Craig,

On the 300 series switches, when you add the first IP interface it will delete the 'generic/default' interface. This will of course remove your access as you have seen.

Easiest way around this problem is to create a new interface for vlan 1 first. You can set this to the 192.168.1.254 or set it to whatever you plan on using.

Once done you should now be able to create interfaces for other vlans without the problem.

4 REPLIES
Bronze

Getting disconnected when adding a VLAN interface

Hello Craig,

On the 300 series switches, when you add the first IP interface it will delete the 'generic/default' interface. This will of course remove your access as you have seen.

Easiest way around this problem is to create a new interface for vlan 1 first. You can set this to the 192.168.1.254 or set it to whatever you plan on using.

Once done you should now be able to create interfaces for other vlans without the problem.

New Member

Re: Getting disconnected when adding a VLAN interface

Hi Robert,

Apologies, you posted just as I was posting some further information.

I will do exactly what you have suggested and post back. Thank you for your advice.

Craig

New Member

Re: Getting disconnected when adding a VLAN interface

Hi Robert,

That worked perfectly. Thank you for coming back to me so quickly and for the solution.

Craig

New Member

Re: Getting disconnected when adding a VLAN interface

In addition to the above I've just performed a 'show ip interface vlan x' command before and after my changes within the web config and it appears that the switch is dropping its VLAN1 IP address once a new interface is added:

Before:

switch27b42e#show ip int vlan 1


    IP Address         Type     Directed   Precedence   Status
                                Broadcast
------------------- ----------- ---------- ---------- -----------
0.0.0.0/32          DHCP        disable    No         Not
                                                      received
192.168.1.254/24    Default     disable    No         Valid


After:

switch27b42e#show ip int vlan 1


    IP Address         Type     Directed   Precedence   Status
                                Broadcast
------------------- ----------- ---------- ---------- -----------
0.0.0.0/32          DHCP        disable    No         Not
                                                      received

switch27b42e#show ip int vlan 2


    IP Address         Type     Directed   Precedence   Status
                                Broadcast
------------------- ----------- ---------- ---------- -----------
192.168.2.251/24    Static      disable    No         Valid

1121
Views
0
Helpful
4
Replies