Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

illegal software format while trying to upgrade fw in sg200-26

hi all,

I own 2 cisco switches small business switches.

they are both SG200-26 26-port  gigabit smart switches. One has fw ver. 1.0.0.19 , while the other has version 1.1.1.8. 

I am now trying to upgrade their firmware to the latest version 1.4.0.88, found here http://software.cisco.com/download/release.html?mdfid=283771818&flowid=24301&softwareid=282463182&release=1.4.0.88&relind=AVAILABLE&rellifecycle=&reltype=latest

I go the http management interface from google chrome and select "upgrade firmware from http". I choose the .ros file and try to carry out the update. 

Unfortunately, the system informs me that the copy has failed and that the software is of "illegal format". 

I have double checked that the file is the correct one. what could be wrong? Do I need to update the bootloader first? is there a guide for that? 

7 REPLIES
Silver

Can you chekc the extension

Can you chekc the extension of the file?
If it is in *.tar format and you directly upload it to your switch, you may need to extract it to get to the *bin file

Upload the *.bin file

New Member

it is neither a bin file nor

it is neither a bin file nor a tar. it is a ros file that came in a .zip compressed archive..

if bin is the fw file, where can i get it?

Silver

Hmm...probably the image of

Hmm...probably the image of the device is not of .bin file
Anyway, checked the docs, and *.ros is the image file of the SG200

Since you got a zip file then you probably downloaded the latest version.

Question:

1. Did you extract it? If you did, try to upload the zip file itself. 
2. If it still does not work, try to download the firmware again. Download it from Cisco

New Member

ok release notes gave the

ok release notes gave the solution in the end.

had to upgrade to intermediate version 1.3.7 first (both boot and fw) and then go to fw version 1.4.

 

Hi asislis, where have you

Hi asislis, where have you got the 1.3.7. , because on the cisco downloadpage is only the 1.4.x available.

Thx,

Chris

Problem solved I found it under: https://software.cisco.com/download/release.html?mdfid=284645418&softwareid=282463182&os=&release=1.4.1.03&relind=AVAILABLE&rellifecycle=&reltype=latest&i=!pp

after entering 1.3.7. in the search box (see picture enclosed)

 

New Member

This worked for me as well. I

This worked for me as well. I was trying to go from version 1.3.something to the latest 1.4.something and it would give me this error. I upgraded to the latest 1.3.7.18 firmware AND boot code first. Then upgraded to the 1.4.2.4 build afterwards.

zac
New Member

Not sure why this comes up as

Not sure why this comes up as unanswered.

Simply put, you need to upgrade your firmware in smaller jumps.

I needed to go to 1.4.502 and was running 1.3.0xx

upgraded to sx200_fw-13558.ros
THEN
upgraded to sx200_fw-14502.ros

5065
Views
10
Helpful
7
Replies
CreatePlease to create content