Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

need basic Help - SG300 with vlan and routing

Hi,

i need some basic help with configuring vlan/routing.

Situation:

DSL Router - Cisco 300 - XenServer

192.168.1.253 - 192.168.1.19 - 192.168.1.10 (mgmt ip)

goal is, to reach from inside xenserver vms the internet.

vms = 192.168.2.x

gateway ip = 192.168.2.1

what i did:

- configured vlan 102, tagged, with the xenserver port

- configured on xenserver a network with vlan id 102, attached to the vm

- this network is conntected to an external bond

- configured ipva4 interface: vlan102 - Static - IP 192.168.2.1 (this is the gateway ip of the vms)

- automatic configured IPv4 Route: 192.168.2.0/24 next hop 0.0.0.0, Directly connected

So at the moment i cant ping from inside a vm to the DSL Router (192.168.2.2 to 192.168.1.253)

any ideas what i misconfigured or whats wrong?

cheers,

-Marco

5 REPLIES
Green

need basic Help - SG300 with vlan and routing

Hi Marcus, a route on the switch shouldn't be needed, that is redundant. You are missing a route on the router pointing back to the switch SVI.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Re: need basic Help - SG300 with vlan and routing

Hi Tom,

ok, that make sense. I can ping the router now inside vms from 192.168.2.x network.

But i cant ping external adresses, error: Destination net unreachable.

My other problem i have, i cant reach any server from outside over router portforwarding.

How do i have to configure the upload port to the dsl router? Is it a access port or a trunk

port with all vlans (tagged or untagged?) At the moment ive a tagged Trunkport with all vlans.

IPv4 Interface Table

InterfaceIP Address TypeIP AddressMaskStatus
VLAN 1Static192.168.1.19255.255.255.0 Valid

Should the VLAN1 ip adress not the router ip adress ? Do i need an additional vlan for

the router ? At the end i like to change the switch ip from dhcp to static (change automaticly

when switching to layer 3 mode), but ive to look for the ios commands first.

What else do i missing ?

Thanks a lot,

Marcus

Green

Re: need basic Help - SG300 with vlan and routing

Hi Marcus, please reference this post it should template everything you need for success.

https://supportforums.cisco.com/thread/2123434

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

need basic Help - SG300 with vlan and routing

Hi Tom,

ok, i managed to reconfiger VLAN 1 to a ip adress i want to.

I can see, when i add a ipv4 Default Route through cli and System Configuration Menu

it works. I can ping from inside vms over the dsl router to internet. But for some reasons,

also when i try to save the running config via web gui or clie (copy run start) after a reboot

this default gateway is gone. Also iam not sure, is this configuration is common.

Thanks a lot again,

-Marcus

Green

need basic Help - SG300 with vlan and routing

Hi Marcus, gone in the sense it is broken or gone in the sense that it's a cosmetic issue?

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
427
Views
0
Helpful
5
Replies
CreatePlease login to create content