Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problems with upgrading Bootloader to 13506 on SG300-20

Some time ago I had the firmware of our SG300 Version 1.1.2.0 updated to version 1.3.5.58. Unfortunately I had not read the description, and so the boot code not updated (I suspect that the boot code was version 1.1.0.6 on the switch). That I was there probably not the only one struck me right the through googling the Internet for solution suggestions for subsequent update.
https://supportforums.cisco.com/sites/default/files/attachments/discussion/firmware_tftp.doc). ">So I found in the forum a little further down a manual of "mohabdel" (see link https://supportforums.cisco.com/sites/default/files/attachments/discussion/firmware_tftp.doc).
I have the whole processed as described and it also everything works without problems. Unfortunately, the firmware version is still 1.1.0.6 after this operation. What surprised me, however I was able to update the firmware version 1.3.7.18 although this should work only with the current boot code.
When you first start Kahmen several error messages such as "% CDB-e-VARNOTSUPPORTED: MIB variable 3603 not supported" and the like.
Is there another option for the boot code update?
Everyone's tags (2)
4 REPLIES
Green

Hi Wieshuber, there is not

Hi Wieshuber, there is not any options for the boot code updates. With the newer firmware you need to use the newer boot versions. Any other way is not supported.

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

I have also tried in which I

I have also tried in which I have been playing an older firmware and then the boot code update did. Unfortunately, without success.
Is there a possibility to observe this process? Because as I said. There is unfortunately no error moment during the upgrade.

Green

Hi Wieshuber, you should be

Hi Wieshuber, you should be able to monitor the progress through the GUI when performing the action. When the device says it is finished, make sure to click the 'done' button. After the bootcode is complete, reboot the switch. Assuming all is done correctly it's all that should be needed.

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Silver

Hello,The newer versions of

Hello,

The newer versions of the boot code are backwards compatible with the older firmware versions, but not the other way around.  Old bootcode with new firmware tends to cause lots of odd issues.

There is also nothing in the switch that will stop you from having mismatched firmware and bootcode versions, although it may exhibit some odd behavior.  If I understand correctly you have already uploaded the firmware and boot code, but if you only do one of those the switch won't complain or stop you.

It sounds like you did everything correctly, but perhaps you did not change your active image?

The SG300 has the ability to hold two firmware versions, and once you upload the new version you will need to go to Administration >> Active Image and make sure the new version is selected.  Then reboot the switch and it should come up with the new version.  You can also do this through the CLI with the boot system image-1 command (or image-2 if that is where the new firmware is).

It is possible to view the process the switch goes through when you first reboot after upgrading the boot code, but only through a console connection.  That will show you the progress of the file system changes the boot code makes.

As for that message it looks like it has something to do with SNMP, so I would guess that whatever OID you are trying to retrieve either doesn't exist on the switch, or there is some other issue with that MIB.  Is that message from the switch itself or from your logging message, because I have never seen that message in the switch logs.

If you are still having any issues feel free to give us a call at the SBSC and we can verify that everything is being done correctly.

Cisco Small Business Support Center Contact Numbers

Hope that helps some,

Christopher Ebert - Advanced Network Support Engineer

Cisco Small Business Support Center

*please rate helpful posts*

570
Views
0
Helpful
4
Replies
CreatePlease to create content