Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SF-300 'interface range' command BUG

Hello!
I have number of SF300 switches in production and have found bug with command "interface range".

When I reconfigure interfaces previously configured with "interface range" to different VLAN interface change VLAN, but after reboot it move back to vlan configured with "interface range".

SW2#sh ver
SW version    1.1.2.0 ( date  12-Nov-2011 time  23:34:26 )
Boot version    1.0.0.4 ( date  08-Apr-2010 time  16:37:57 )
HW version    V01

...

SW2#sh int switchport gi4
Port : gi4
Port Mode: Access
Gvrp Status: disabled
Ingress Filtering: true
Acceptable Frame Type: admitAll
Ingress UnTagged VLAN ( NATIVE ): 11

Port is member in:

Vlan               Name               Egress rule Port Membership Type
---- -------------------------------- ----------- --------------------
11                User                Untagged          Static

...

SW2#sh run
interface  fa10
description WiFI(1)
exit
vlan database
vlan 2,4,11
exit
interface  gi3
switchport default-vlan tagged
exit
interface range  fa14-20,fa22-24
switchport access vlan 2
exit
interface range  fa10,fa13
switchport access vlan 4
exit
interface range  fa1-2,fa21,gi4
switchport access vlan 11
exit...

SW2#conf t
SW2(config)#int gi4
SW2(config-if)#switchport access vlan 11

...

SW2#sh int switchport gi4
Port : gi4
Port Mode: Access
Gvrp Status: disabled
Ingress Filtering: true
Acceptable Frame Type: admitAll
Ingress UnTagged VLAN ( NATIVE ): 4

Port is member in:

Vlan               Name               Egress rule Port Membership Type
---- -------------------------------- ----------- --------------------
4                 WiFI                Untagged          Static

...SW2#sh startup-config
interface  fa10
description WiFI(1)
exit
vlan database
vlan 2,4,11
exit
interface  gi3
switchport default-vlan tagged
exit
interface range  fa14-20,fa22-24
switchport access vlan 2
exit
interface range  fa10,fa13
switchport access vlan 4
exit
interface range  fa1-2,fa21,gi4
switchport access vlan 11
>!!!!!!!!!!?????????????????????????

SW2#write mem

...

SW2#reload

...

==============

!!!!!DOWNTIME!!!!

==============

SW2#sh int switchport gi4
Port : gi4
Port Mode: Access
Gvrp Status: disabled
Ingress Filtering: true
Acceptable Frame Type: admitAll
Ingress UnTagged VLAN ( NATIVE ): 11

Port is member in:

Vlan               Name               Egress rule Port Membership Type
---- -------------------------------- ----------- --------------------
11                User                Untagged          Static

Now the only way to fix it:

copy run tftp://XXXXXXX

copy  tftp://XXXXXX start

reload

Please let me know if this bus will be fixed in next software releas!

Regards

Sergiy A. Pyvovaroff (CCNP).

2 REPLIES

Re: SF-300 'interface range' command BUG

Hi Sergry,

Thank you for the explanation, but to fix software, someone has to open a Service Request .  It may have been noticed and scheduled for fix.

I would you ask you to  please be  kind enough  to goto  www.cisco.com/go/sbsc  and call by phone or click to chat with the folks at the small business support center (SBSC) and  open a case. They will give in response a service request (SR) number. 

It doesn't take long to open a SR,  and someone at SBSC is then responsible for feedback to you to let you know what's happening.

The SR will ensure that;

  1. our technicians verify your findings  and
  2. escalate the case up into development.
  3. if this problem has been observed previously  and there is a resolution, you may be asked to even try,  if you wish  a pre-release  version of firmware.

Since you have a CCNP, I am guessing that this process is not foreign to you.

It can be annoying opening a case, especially when you have documented  the issue in the post,   but at least you can point the technician to this posting, where you have almost explained everything needed to get development to look at the problem.

Sergry, it's a interest observation,  I just use the 300 series GUI to add Gig2 as a access port to vlan 2,  the following script was created;

interface gigabitethernet2

switchport mode access

switchport access vlan 2

switchport general pvid 2   -  this is a error I guess as the switch port is in access mode.

exit

Did you use the GUI to generate the CLI. or just use the CLI  without reference to the CLI manual?.

This CLI is not identical to a Catalyst CLI. see the following URL for the 300 series CLI manual;

http://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/CLI_Nikola300_1.1.pdf

Again, please be so kind to spend a little  time to open a SR.

I will be tomorrow,  on a issue I highlighted in red. It is a minor issue for me,  as the switch still leaves GiG2,  in access mode,   as a untagged interface in VLAN2.

regards Dave

New Member

Re: SF-300 'interface range' command BUG

  Now I have no free SF300 switch to recreate problem. All my SF300 run in production environment. I'll create ticket when I get unused SF300 for new branch office. No service contract like "Smart net" needed for ticket creation?
  I always use CLI to configure switches and routers. Even now, when I have break right arm, typing command faster for me then web GUI.

The nature of error is the following:
When I configure real catalyst whith the command “INTERFACE RANGE” all parameters  changing for interfaces but command “INTERFACE RANGE” never left in run or start text config of the switch.

When I configure SF-300 with legal by documentation command “INTERFACE RANGE”

SW#conf t

SW(config)#interface range fa1-24,gi1-2

SW(config)#switchport mode access

SW(config)#switchport access vlan 11

this strings left at the top of the run conig

sh run

interface range fa1-24,gi1-2
switchport mode access
switchport access vlan 11

...

even when I change parametr of individual intefaces from range

SW#conf t

SW(config)#interface gi1

SW(config)#switchport mode access

SW(config)#switchport access vlan 4

the command

interface range fa1-24,gi1-2
switchport mode access
switchport access vlan 11

left in top of the run conf

and after write mem + reload overwrite parametrs of individual interfaces.

regards Sergiy.

1485
Views
0
Helpful
2
Replies
CreatePlease to create content