Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SF 300 Vlan Config

Hi

need help with Vlan's config on a SF300, i have created 5 vlans, the switch is dhcp enabled, created network pools, i assigned one port for testing to vlan 20, but cant get an ip address, dont know if i'm missing something (switch is in layer 2)

basically what i am trying to achieve is that each vlan can obtain an ip address via dhcp and have access to the Internet

any help much appreciated, current config below


switch0ec151#sh run

config-file-header
switch0ec151
v1.3.5.58 / R750_NIK_1_35_647_358
CLI v1.0
set system mode switch

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 10,20,30,40,50
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
                                                     

voice vlan oui-table add 00d01e Pingtel_phone___________
                                                     

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

ip dhcp server

ip dhcp excluded-address 192.168.168.200 192.168.168.254

ip dhcp excluded-address 192.168.168.24 192.168.168.24

ip dhcp pool network DATA
address low 192.168.168.10 high 192.168.168.252 255.255.255.0
lease infinite

domain-name 192.168.168.254

default-router 192.168.168.254

dns-server 192.168.168.254
exit

ip dhcp pool network Offce B

address low 192.168.170.1 high 192.168.170.254 255.255.255.0

lease infinite
domain-name 192.168.170.254

default-router 192.168.170.254

exit
ip dhcp pool network Office A

address low 192.168.169.1 high 192.168.169.254 255.255.255.0
lease infinite

exit

hostname switch0ec151

no passwords complexity enable

username cisco password encrypted 55c2f525a1900b76e8c633c118ffc2ea8a012277 privilege 15

snmp-server server

ip name-server  192.168.168.254

ip telnet server
!

interface vlan 1
ip address 192.168.168.253 255.255.255.0

!

interface vlan 10
name DATA

!

interface vlan 20
name "Office A"

!

interface vlan 30
name "Office B"

!
interface vlan 40
name "Office C"
!

interface vlan 50
name "Office D"
!

interface fastethernet11
switchport trunk native vlan 20

!

exit
switch0ec151#


switch0ec151#

Everyone's tags (3)
4 REPLIES
New Member

SF 300 Vlan Config

anybody any ideas where im going wrong it my config?

Green

SF 300 Vlan Config

Hi speedboat, the DHCP feature is for layer 3 mode only. It is why that doesn't work. The additional VLANs not working on the internet would be because whatever the gateway router is, does not understand the VLANs or because they've not been configured correctly.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SF 300 Vlan Config

Hi Tom

thanks, i will change it to layer 3, if i configure the switch to give out dhcp, just on one range (192.168.168.x) can i assign dhcp pools to each vlan for example

vlan1      192.168.168.2 - 50

vlan2     192.168.168.51 - 70

vlan3     192.168.168.71 - 100

vlan4     192.168.168.100 - 200

or does each vlan have to have a seperate range and does i have to create a static route for each vlan to my router (draytek 2830n)?

thanks

Green

SF 300 Vlan Config

Hi Speed, each VLAN should have it's own respective DHCP.

With that scenario, if your Draytek doesn't support the VLAN, then your Draytek will need the static routes, not the switch.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
615
Views
0
Helpful
4
Replies
CreatePlease to create content