Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SF300-24P with Avaya phones

Greetings Everyone,

I am having a Cisco Small Business SF300-24P Switch and I'm trying to connect it to an avaya phones and it's giving me the headache of a lifetime for 3 days now. I've tried all sorts of switchports and Voice Vlan settings and LLDPs and everything. I think I've even messed up with the data vlan after it was working fine and I probably a weird configurations now would anyone please try to help me out with it.

Thanks a lot

Here are the configs:-

User Name:cisco

Password:***********

switch0a1172#

switch0a1172#

switch0a1172#

switch0a1172#

switch0a1172#sho run

config-file-header

switch0a1172

v1.2.9.44 / R750_NIK_1_2_584_002

CLI v1.0

file SSD indicator encrypted

@

ssd-control-start

ssd config

ssd file passphrase control unrestricted

no ssd file integrity control

ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0

!

vlan database

vlan 9,13,20

exit

voice vlan id 20

voice vlan state auto-enabled

voice vlan oui-table add 0001e3 Siemens_AG_phone___

voice vlan oui-table add 00036b Cisco_phone________

voice vlan oui-table add 00096e Avaya______________

voice vlan oui-table add 000fe2 H3C_Aolynk_________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_

voice vlan oui-table add 00d01e Pingtel_phone______

voice vlan oui-table add 00e075 Polycom/Veritel_pho

voice vlan oui-table add 00e0bb 3Com_phone_________

voice vlan oui-table add 3475c7 Avaya

lldp med network-policy 1 voice-signaling vlan 20 v

hostname switch0a1172

line telnet

password c8e383b1dd7be99f878a387d87766e875404e0b3 e

exit

username cisco password encrypted c8e383b1dd7be99f8

lege 15

ip telnet server

!

interface vlan 13

ip address 192.168.11.1 255.255.255.0

!

interface vlan 20

no ip address dhcp

!

interface fastethernet1

spanning-tree portfast

switchport mode access

switchport access vlan 13

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet2

spanning-tree portfast

switchport mode access

switchport access vlan 13

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet3

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet4

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet5

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet6

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet7

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet8

spanning-tree portfast

spanning-tree link-type point-to-point

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

macro description switch

no macro auto smartport

!next command is internal.

macro auto smartport dynamic_type unknown

!

interface fastethernet9

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet10

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet11

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet12

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet13

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet14

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet15

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet16

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet17

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet18

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet19

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet20

spanning-tree portfast

spanning-tree link-type point-to-point

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

macro description switch

no macro auto smartport

!next command is internal.

macro auto smartport dynamic_type unknown

!

interface fastethernet21

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet22

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet23

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface fastethernet24

spanning-tree portfast

switchport mode general

switchport general allowed vlan add 13 untagged

lldp med enable

lldp management-address automatic

no macro auto smartport

!

interface gigabitethernet4

switchport mode access

switchport access vlan 9

!

macro auto disabled

switch0a1172#

1 ACCEPTED SOLUTION

Accepted Solutions
Green

SF300-24P with Avaya phones

Hi Abdulrahman, the config seems kind of weird.

I'd just default the switch and follow this document-

https://supportforums.cisco.com/docs/DOC-27005

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
6 REPLIES
Green

SF300-24P with Avaya phones

Hi Abdulrahman, the config seems kind of weird.

I'd just default the switch and follow this document-

https://supportforums.cisco.com/docs/DOC-27005

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SF300-24P with Avaya phones

my dear friends thanks for the help

i restored it to factory settings and did as says in the link

but what about switchport ? what about assigning data and voice vlans

Green

SF300-24P with Avaya phones

Abdul, all of this would be automatically done through the macro of the switch. There is not any additional configuration needed. If the phone is not working, I'd double check to see if CDP or LLDP is enabled.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SF300-24P with Avaya phones

Bro how about if i have many data vlans how would i assign ports to vlans ??!!!

Green

SF300-24P with Avaya phones

Depending how you'd like. Per example

vlan 1 = default

vlan 2 = data 1

vlan 3 = data 2

vlan 20 = voice

config t

int fa06

switchport trunk native vlan 2

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SF300-24P with Avaya phones

One thing was missing

Port to vlan selecting the voice vlan and selecting tagging on the ports

(also when we select the voice vlan we should click on "go" cause it's tricky it shows you the vlan you selected without actually selecting it unless u click on go)

other than that all what you mentioned helped a lot so thank a zillion bro

900
Views
0
Helpful
6
Replies