Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SF300 switch cannot detect desktop

Hi all,

i've installed switch SF300 48 ports for IP phone environtment, i configured it as guide, if i attach ip phone it works normally,

but when i plug laptop to switch port, it cannot connect to anywhere, then i tried to change native vlan for smartport when detect desktop, but still same problem, i look into smartport properties, there is no desktop detection feature (pic attached)

please advice

7 REPLIES
Green

SF300 switch cannot detect desktop

Hi Kabiru, host is the desktop connection. But this probably doesn't matter much.

Can you display the port configuration for a port you're connecting your computer to?

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SF300 switch cannot detect desktop

Hi Kabiru,

Please let me know the running-configuration of your switch and also can i know what is the OEM(original equiptment manufacturer) of your desktop which you are trying to connect and firmware version of the switch. under administration -->discover LLDP --> LLDPneighbour information were you able to see Desktop connected, If you try disbaling the smart ports and re-configuring the switch also fix the issue but if you still want to configure the switch with smart ports enabled then please attach screen shots of your port configuration settings and running config.

Regards,

Phanikrishna

New Member

Re: SF300 switch cannot detect desktop

Hi Tom and Phani,

thanks for your help, i attached the sh run config in the switch also LLDPneigh info, i reproduce the problem use port number 19 which i connect to my laptop (Lenovo). i look into LLDP neigh info, but i only see Gi1 as trunk to another switch, i don't see any port which Phani asked.

1.2.7.76

Please advice,

Regards,

Kabiru

Switch config :

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.07.02 11:54:18 =~=~=~=~=~=~=~=~=~=~=~=

   [D   [D   [Dsh run

config-file-header

Switch-lt7

v1.2.7.76 / R750_NIK_1_2_584_002

CLI v1.0

file SSD indicator encrypted

@

ssd-control-start

ssd config

ssd file passphrase control unrestricted

no ssd file integrity control

ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0

!

vlan database

vlan 7,80,254

exit

voice vlan id 80

voice vlan state auto-enabled

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

[0mMore: ,  Quit: q or CTRL+Z, One line:

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

hostname Switch-lt7

ip telnet server

!

interface vlan 7

name "lantai 7"

no ip address dhcp

!

interface vlan 254

name console

ip address 192.168.254.17 255.255.255.0

!

interface fastethernet19

[0mMore: ,  Quit: q or CTRL+Z, One line:

switchport trunk allowed vlan add 7,80

!

!

interface fastethernet46

storm-control broadcast enable

storm-control broadcast level 10

storm-control include-multicast

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

switchport trunk allowed vlan add 7,80

macro description ip_phone_desktop

!next command is internal.

macro auto smartport dynamic_type unknown

!

interface fastethernet47

storm-control broadcast enable

storm-control broadcast level 10

storm-control include-multicast

[0mMore: ,  Quit: q or CTRL+Z, One line:

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

switchport trunk allowed vlan add 7,80

macro description ip_phone_desktop

!next command is internal.

macro auto smartport dynamic_type unknown

!

interface fastethernet48

switchport mode access

switchport access vlan 254

!

interface gigabitethernet1

switchport trunk allowed vlan add 7,80,254

!

macro auto enabled

macro auto processing type host enabled

macro auto built-in parameters desktop $max_hosts 10 $native_vlan 7

macro auto built-in parameters host $max_hosts 10 $native_vlan 1

macro auto built-in parameters ip_phone_desktop $max_hosts 10 $native_vlan 7

ip default-gateway 192.168.254.1

[0mMore: ,  Quit: q or CTRL+Z, One line:

Switch-lt7#exit

Cisco Employee

SF300 switch cannot detect desktop

Kabiru,

The way the switch learns the connected device is through a dynamic discovery protocol such as CDP (Cisco Discovery Protocol) or LLDP (Link Layer Discovery Protocol). That's how it is learning the attached phones. Unless you specifically installed an app on your laptop which is sending out CDP or LLDP discovery messages, it is not making itself known to the network. That's why the switch does not "see" the laptop.

Ivor

New Member

SF300 switch cannot detect desktop

Hi Kabiru,

Try disabling smartport and see if this fixes your problem. If not, install the latest firmware (Click Here to download the latest firmware) and let us know if your problem is solved.

New Member

SF300 switch cannot detect desktop

OK thanks for help, i will try it ASAP when i go to customer

New Member

SF300 switch cannot detect desktop

Hi,

Can anyone please provide me SNMP MIB files for cisco SF 300-48 48-Port 10/100 Managed Switch?

I need it urgent.I am able to get it from cisco site also.

thanks

Ram

998
Views
0
Helpful
7
Replies