Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SF300 switches with dissimilar firmware will not connect via Gigabit ports

I have a client with a large number of switches running 1.3.0.62 and a new switch running 1.4.0 or 1.3.5 (I've tried both versions). I am unable to run between the two switches over their gigabit ports; the link shows that it is down (Administratively it is up). On the switch running 1.3.0.62,  after changing the speed on the gigabit port from autonegotiate to 100/full duplex, the link comes up (I also tried setting both statically to Gigabit speeds, but the link would not come up until I removed the setting on both switches). 

 

I read the latest release documentation http://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbss/sf20x_sg20x/release_notes/R_1_4_RN.pdf

In which it notes:

Downgrading from 1.4.0 to Versions Earlier than 1.3.5 The downgrade copy operation process takes a few minutes, as the file system must be converted before the copy operation itself. The user is notified (using “…..” progress on CLI or a message on the WEB GUI) that the conversion process is ongoing. When the conversion process is complete, the image download begins automatically. The device will automatically reboot after the copy is complete.... After the downgrade, only downloaded image file will remain on the Flash (the 1.4.0.x image is deleted during this process). Note that there’s no need to downgrade the boot file, the boot file supports both file systems. The boot file cannot be downgraded while 1.4.0.x is active.

However, when I load Sx300_FW_1.3.0.62.ros on the new switch I get the following error:

Bytes Transferred: 0
Status: Copy failed
Error Message: Copy: Illegal software format

 

Which I understand is an error that occurs when the boot loader is not correct. It would seem that the documentation is incorrect ("Note that there’s no need to downgrade the boot file, the boot file supports both file systems. The boot file cannot be downgraded while 1.4.0.x is active.")

 

Can someone please tell me, then, how the heck I can downgrade this switch? There's far too many switches running 1.3.0.62 to upgrade all of them on their budget. 

 

Thanks in advance.

2 REPLIES
New Member

HiIs it in building cabling

Hi

Is it in building cabling between the switches? If so, please have the cable run tested. It may not actually support gigabit.

Have you tried connecting a good patch cable between the two switches when they are side by side each other?

I have seen this happen were the switches negotiate gigabit but the cable does not support it.

Please let us know. Good luck.

New Member

It might not even be cat5e,

It might not even be cat5e, for that matter. I will have the local admin test it and update. Thanks for your help!

86
Views
0
Helpful
2
Replies
CreatePlease to create content