Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SG200/300 Changes not commiting after reboot - LAG - Yes im saving config.

Hi there,

I've noticed on both a SG200-26 and SG300-28 that once I've completed a configuration change and save the running config to the start up config that it reverts after a reboot. It seemed very weird to me so I started downloading the configuration prior to the reboot to confirm that the running config is the same as the start up and it is verified but once I reboot a different config is there. The second I login to the switch it's also flashing the save icon at the top.

Has anyone experienced this is? both switches are running the current firmware, and I've tried different web browsers and different pc's to confirm it wasn't a caching issue.

couple things to add, I noticed it when creating a LAG group. I'll removed the target ports from any vlans and add then to the LAG, and the vlans to the lag. save and reboot and then it reverts back to the ports not being in a LAG and being in the existing vlans. if I do remove the ports from the vlans and save and reboot the settings hold oddly enough.

As well when removing the ports from the LAG I get the following error "Configuration Database locked by terminal 0 application - please try later." I need to do one by one, and the odd thing is these ports revert back to the previous vlan's they where on.

1 REPLY
Silver

Hello,What you are describing

Hello,

What you are describing definitely isn't normal.  I see a lot of people who's VLAN configuration change around after a reboot, and that is usually because of smartport macros, but that isn't really what your issue sounds like.  I would try disabling smartport on the LAG members anyway (or globally if you aren't using it for anything else, just note on earlier firmware this will set all your ports back to trunk with VLAN 1 untagged when you first do it)

One thing I can say is the individual ports retain their own settings once you add them to the LAG, they just ignore them since the LAG settings are what matters at the point.  Once you remove the from the LAG they will revert back to whatever their settings were before you added them.

You mention the latest firmware, did you also upgrade the bootcode on the switches?  Odd things like your error message crop up when the bootcode is not updated as well, since we changed around some of the filesystem for newer firmware versions.  

The fact that this happens on both of them indicates to me that it probably isn't a hardware problem, especially since it is two different models.

You mentioned that when you log in your save icon is flashing, I am wondering does the switch make you change your password when you login again?  If so it sounds like they are being reset to factory somehow.

Speaking of that, I would recommend once you upgrade the firmware to factory default them and reconfigure them manually.  

Where do you see that error message, in the GUI or in the CLI?  It sounds like you have tried both, but I cannot really tell.  Posting your log files may be useful too, you can usually see there if your configuration save went through properly or not.

If the reset and reconfigure and bootcode all check out, go ahead and give us a call at the SBSC and we can get  case opened and take a look at what is going on here.  I have set up lots of LAGs in the lab and on customer's equipment, and haven't run across this issue before.

Hope that helps a bit and thank you for choosing Cisco,

Christopher Ebert - Advanced Network Support Engineer

Cisco Small Business Support Center

*please rate helpful posts*

296
Views
0
Helpful
1
Replies
CreatePlease to create content