Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SG200 to 2960 Switch

I am using a SG200 to expand a small office area.    It will run to computers and Cisco 7960 IP phones.   I have attached a simple topology diagram for reference.

PD Squadroom - Network general.png

The 2960 port configuration is as follows:

interface GigabitEthernet1/0/14

description Squadroom LNHPDSW3 - Jack D04

switchport trunk native vlan 5

switchport trunk allowed vlan 1,5,10,50

switchport mode trunk

switchport voice vlan 50

priority-queue out

mls qos trust cos

spanning-tree portfast

On the SG200, the ports look like this:

screenshot1.png

screenshot2.png

PC work just fine and are on the correct VLAN.   The IP PHONES will not switch to the voice vLAN, which is vLAN 50.   The phones don't have any PC connected to them, if that would make a difference.    Have I missed a configuration on the SG200 to all for the voice vlan to be assigned to the IP Phone connected to ports 1 and 2.

Also, if there are any other recommendations for this configuration, please do recommend.

Thanks in advance,

John

2 REPLIES
New Member

SG200 to 2960 Switch

Hi,

On Your 2960,config should be like this

interface GigabitEthernet1/0/14

switchport mode trunk

switchport trunk native vlan 5

switchport voice vlan 50

priority-queue out

mls qos trust cos

spanning-tree portfast

On Cisco sg-200,login through GUI,enable telnet service and access through cli and type this command

inter gi 14

switchport mode trunk

swithport trunk native vlan 5

switchport trunk allowed vlan add 1,10,50

no lldp transmit

exit

also in global config mode type

(config)#voice vlan id 50

** this will create vlan 50

(config)#voice vlan state auto-enabled

now both ip phone and pc will work on same port.

Regards,

Guru

New Member

SG200 to 2960 Switch

Guru,

The SG200 doesn't have CLI access; unless I am missing something.   So how do you do this via the GUI?

John

308
Views
0
Helpful
2
Replies