Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.

Sg300-10 <> C3500XL trunk issue

Hello,

Recently I bought a Cisco SG300-10 switch and I encounter an issue with my trunk connection between my SG300-10 and C3500XL.

To clarify easy I add my schematic layout and configuration settings.

Cisco SG300-10 config

Layer 2 setup

Management VLAN : 254

IPv4 : 172.16.254.164/27

Default VLAN : 254

Port VLAN membership :

Interface   Mode       Admin VLAN           Oper. VLAN      LAG               comment

GE1         ACCESS         66UP                   66UP                                ISP connection

GE3         ACCESS         253UP                  253UP                               PC D

GE4         ACCESS         254UP                  254UP                               PC C

GE10       TRUNK       66T, 253T, 254T    66T, 253T, 254T                       trunk to C3500XL

Cisco C3500XL config

interface FastEthernet0/1

description ORANGE to Router

switchport access vlan 252

!

interface FastEthernet0/2

description GREEN to router

switchport access vlan 254

!

interface FastEthernet0/3

  description BLUE to router

  switchport access vlan 253

!

interface FastEthernet0/4

  description RED to router

  switchport access vlan 66

!

interface FastEthernet0/5

  description GREEN to PC A

  switchport access vlan 254

!

interface FastEthernet0/6

  description BLUE to PC B

  switchport access vlan 253

!

interface FastEthernet0/48

description trunk to SG300

switchport trunk encapsulation dot1q

switchport trunk native vlan 254

switchport trunk allowed vlan 66,253,254

switchport mode trunk

sh vlan br

66         RED          Fa0/4

252       ORANGE     Fa0/1

253       BLUE         Fa0/3,Fa0/6

254       GREEN       Fa0/2,Fa0/5      

My ISP provides an Ip address for my Router/firewall and this works fine.

The trunk from SG300-10 to C3500XL works but not from C3500XL to SG300-10

On my router I run a DHCP server for VLAN 254 and VLAN 253.

My clients PC A and PC B, connected on the switch C3500XL, gets their IP addresses but for the clients PC C and PC D , connected on the switch SG300-10, not.

I upgraded my firmware for SG300-10 to version 1.1.1.8 but still the same issue.

When I change the setting for GE10 like :

GE10       TRUNK       66T, 253T, 254UP    66T, 253T, 254UP                       trunk to C3500XL

then the client PC C gets an Ip address but still not the client PC D and it's not possible to link 2 PVIDs on the same port.

Does someone else encounter the same issue?

Or are my settings incorrect?

Kind regards,

Christophe

1 REPLY
Bronze

Sg300-10 <> C3500XL trunk issue

Hello Christophe

For the SG300-10, you will want to have vlan 254 set as UP. This will match the native vlan setting on the C3500. The other vlans should be Tagged. The tunk port has to have one native/untagged vlan and all other vlans should be tagged/allowed.

If you assign PC D a static IP on that subnet, can you ping PC B? If so, then the trunk is working correctly.

I hope this information helps

1807
Views
0
Helpful
1
Replies
CreatePlease to create content