Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SG300 10MP boot code update

If there any procedure on how to update the boot code on a SG300 10MP, to 1.35.06?  I can't seen to find anything

 

Any help would be awesome

9 REPLIES
Hall of Fame Super Gold

Duplicate posts.   Go here:

Duplicate posts.  

 

Go here:  http://supportforums.cisco.com/discussion/12163211/sg300-10mp-boot-code-update

New Member

I have the same problem,

I have the same problem, tried with tftp and throught the console.

Both download the file, I click done and reboot. still old version.....

How can I force this update?

Hi Norman,Please check the

Hi Norman,

Please check the document it may be useful: https://supportforums.cisco.com/document/12321266/firmware-upgrade-troubleshooting-300-and-500-series-managed-switches

Regards,

Aleksandra

 

New Member

Hi Aleksandra,I tried this

Hi Aleksandra,

I tried this and the firmware updates fine, but the boot code does not.

After it updates the new firmware and I try to do the boot code it says it is to old.

When I switch back to the old firmware and I try the bootcode it says it is succesfull, but after a reboot it is still the old bootcode.

It doesn't seem to want to change....

 

Hi Norman,Please perform boot

Hi Norman,

Please perform boot code upload and reboot the switch and only when after firmware upload, change active image and reboot.

The reason for this is that boot code allows to upload bigger firmware but switch needs to start with this new boot first to allocate this space.

I hope this helps,

Aleksandra

New Member

I can't seem to load the boot

I can't seem to load the boot code at all. I've tried with both Solarwinds and TFTPD32. The firmware loaded fine. But, every time I try to load the boot code, it says file not found. Like it's not there. I'm looking right at it, and even used the "copy" feature in tftpd32, but it just can't see it. Any suggestions?

Green

Hi Lard, it's not too special

Hi Lard, it's not too special of a process. You need to use TFTP server. If you don't have a TFTP server, download a free program like TFTPD32 or TFTPD64.

Then it's pretty much just selecting TFTP, boot code and typing the file name on the upgrade page of the swtcih.

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Hi Lardog200, Please follow

Hi Lardog200,

 

Please follow my TRL file. My file show you step by step how to change boot code and firmware. 

 

Thanks,

New Member

Hey All, I am having a

Hey All,

 

I am having a problem updating my boot code as well. I've followed these docs, guides etc with no luck. I had previously upgraded to 1.3.5+ without first doing the boot code, I know not smart, and now even when downgrading the firmware to a lower version that boot code update never sticks. I have used TFTP via console, via the GUI and no luck. What should I try? Thanks

 

4337
Views
0
Helpful
9
Replies
CreatePlease login to create content