Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

SG300-10P + CCA 3.2(3), "credentials expected to be encrypted" error

Hello,

 

We currently use CCA to manage our UC560 + 9 switches. I am able to properly authenticate on all but one of these devices. The device in question has a configuration nearly identical to that of all other switches.

 

This problem switch is running firmware v 1.3.5.58, is an SRW2008P-K9-V02. I'm using CCA 3.2 (3).

I'm able to login to the switch with our credentials through the webUI just fine. Attempting with those same credentials through CCA repeats the prompt and finally says "Authentication Failed".

When checking the logs via webUI, it reveals (for each CCA attempt) the following:

 

21474338312014-Jun-06 18:17:36Error%HTTP_HTTPS-E-DIAGNOSTICS: viaGetSecurityHandler:credentials expected to be encrypted      
21474339992014-Jun-06 18:11:32Error%HTTP_HTTPS-E-DIAGNOSTICS: viaGetSecurityHandler:credentials expected to be encrypted, aggregated (2)      
21474341512014-Jun-06 18:11:30Error%HTTP_HTTPS-E-DIAGNOSTICS: viaGetSecurityHandler:credentials expected to be encrypted      
21474343192014-Jun-06 17:59:38Error%HTTP_HTTPS-E-DIAGNOSTICS: viaGetSecurityHandler:credentials expected to be encrypted, aggregated (2)     

 

I have tried in CCA > Connect > Advanced Options setting to HTTP + HTTPS, but each returns the same error situation, either when attempting to add to the UC560 site or trying to directly connect via IP.

 

I have rebooted the switch, made sure the user account has full admin access, enabled SNMP, but it is still the only switch which we cannot access via CCA.

1 REPLY
Community Member

After working with a Cisco

After working with a Cisco tech via live chat / remote desktop, upgrading the firmware to the latest version wound up fixing it. Our best guess is that the older version wasn't supported by CCA as far as access went. All is well now.

288
Views
0
Helpful
1
Replies
CreatePlease to create content