Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SG300-10P

Do these switches support option 66?

If not, how should I configure my Polycom phones to work with it, or should I get a different type of switch?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

SG300-10P

Hello,

The latest firmware version (1.3.5) for these switches has actually added option 66 to the GUI for the DHCP server.

So yes, these switches do support option 66, just make sure you upgrade to the latest firmware and bootcode and it will be listed when you setup a DHCP network pool.

Make sure you upgrade the bootcode as well, both are required.

Thank you for choosing Cisco,

Christopher Ebert

---

Senior Network Support Engineer - Cisco Small Business Support Center

Green

Re: SG300-10P

Hi Cramer, please advise if this is what you're asking here is a sample config

vlan database            

vlan 100

exit

interface vlan 100

ip address 10.90.0.1 255.255.255.0

exit

ip dhcp server

ip dhcp pool network Phone

address low 10.90.0.10 high 10.90.0.254 255.255.255.0

lease infinite

next-server-name http://myphone.company.com

default-router 10.90.0.1

time-server 10.0.90.2

dns-server 10.90.0.3

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
7 REPLIES
Gold

SG300-10P

Silver

SG300-10P

Hello,

The latest firmware version (1.3.5) for these switches has actually added option 66 to the GUI for the DHCP server.

So yes, these switches do support option 66, just make sure you upgrade to the latest firmware and bootcode and it will be listed when you setup a DHCP network pool.

Make sure you upgrade the bootcode as well, both are required.

Thank you for choosing Cisco,

Christopher Ebert

---

Senior Network Support Engineer - Cisco Small Business Support Center

New Member

SG300-10P

How do I translate this from a Cisco 3560 to this switch?

ip dhcp pool Aastra

   network 10.90.0.0 255.255.255.0

   option 66 ascii http://myphone.company.com/sip-ps

   default-router 10.90.0.1

   dns-server X.X.X.X

I have it upgraded to 1.3.5. But I'm not able to get the correct syntax in the SG300 to get it working. It wont allow me to use the domain name or the /sip-ps.

ip dhcp server

ip dhcp pool network NAME

address low 172.31.253.10 high 172.31.253.62 255.255.255.0

lease infinite

next-server 10.0.0.15

next-server-name sip-ps

default-router 172.31.253.1

time-server X.X.X.X

dns-server X.X.X.X

exit

Green

Re: SG300-10P

Hi Cramer, please advise if this is what you're asking here is a sample config

vlan database            

vlan 100

exit

interface vlan 100

ip address 10.90.0.1 255.255.255.0

exit

ip dhcp server

ip dhcp pool network Phone

address low 10.90.0.10 high 10.90.0.254 255.255.255.0

lease infinite

next-server-name http://myphone.company.com

default-router 10.90.0.1

time-server 10.0.90.2

dns-server 10.90.0.3

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Silver

SG300-10P

Hello Cramer,

Tom's sample config above should work just fine.  For some reason the GUI won't let you enter anythign but letters for the next-server-name, but if you do it through CLI it should work just fine.  I tested it here in my lab as well.

I am going to go ahead and get a bug together for the GUI not working properly with that, but for now I'd say using CLI to set those options should work just fine.

Let us know how it goes,

Christopher Ebert

---

Senior Network Support Engineer - Cisco Small Business Support Center

*Please rate helpful posts*

New Member

SG300-10P

Thanks. I will try this Monday. Yes the gui wouldn't allow me to enter the info I needed for option 66. I will update this post on Monday. 

Brandon

New Member

SG300-10P

This is working. Thanks Brandon

262
Views
0
Helpful
7
Replies